
 

Allied Telesis™
AlliedView Network Management System

User Guide 12.1 (SP1)
Issue 1

Copyright © 2010 Allied Telesis, Inc. All rights reserved  Information in this document is subject to change without notice.

613-001542 Rev A



Copyright © 2010 Allied Telesis, Inc. All rights reserved Information in this document is subject to change without notice.

Introduction

Congratulations on your purchase of the AlliedView™ Network Management System product. This product 
allows users to query all aspects of Allied Telesis products in their network.

Who Should Read This Guide?

This document is for users who need to understand the user interface of the NMS product and be able to 
query and control the Allied Telesis network elements using the NMS. Highlighted are tasks involved in 
configuring individual devices (called device configuration) and groups of devices (called network 
provisioning), since the NMS for certain applications must change a set of devices. Also highlighted are the 
tasks involved in producing graphs and reports in both historical and real-time formats. 

For in-depth knowledge of the NMS and its applications, refer to the NMS Administration Guide.

About this Guide

This guide includes all aspects of the NMS product and includes information on the installation and 
administration of the NMS server software.

• Chapter 1 provides on overview of the NMS product and how this document is organized.

• Chapter 2 lists the various interfaces (clients) for the NMS and how to access each type

• Chapter 3 shows how to use the Network Maps application and how the maps allow access to other 
applications for one or more devices.

• Chapter 4 describes the Fault application and how to monitor the NMS for events and alarms.

• Chapter 5 describes the Performance Management application and how to report statistics.

• Chapter 6 describes the Network Inventory application and how to query networks, nodes, and interfaces.

• Chapter 7 shows the HTML interface and its capabilities.

• Chapter 8 lists the object properties most commonly used to define objects and create Custom Views.

Tracking Updates since the Previous Release

Section 1 of the AlliedView NMS Administration Guide includes a Reason for Update table, allowing the 
user to see what features have been added or changed. Change bars let the user know where technical 
information has been updated.

Service and Support

For information about support services for Allied Telesis, contact your Allied Telesis sales representative or 
visit the website at www.alliedtelesyn.com.
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1. Product Overview

1.1  AlliedView Network Management System (NMS)
For managing a network, the NMS product provides a powerful client that presents the network and its devices in 
a user-friendly way that allows users to learn quickly how the network is configured, how to reconfigure ele-
ments when necessary and how to spot problems (or potential problems) before they degrade network perfor-
mance.

Users of NMS have two methods to query and control the objects in the network.

• A graphical map interface that shows the network and its managed objects both physically and functionally. 
Users can start at the network level and drill down to the appropriate device.

• A set of forms (tables), which list the various objects and their attributes.

Each method allows the user to access information about the network, see in real time any changes in the network 
(and therefore take appropriate action), and change the configuration or status of any device to ensure the net-
work is operating efficiently.

FIGURE 1-1  AlliedView NMS GUI (SE Version)

1.1.1  Managed Device Types
The AlliedView NMS manages the following types of devices:

• iMAP - These products currently use the series number 7000 and 9000. They are powered by -48Vdc and can 
be integrated into a central office environment. They are modular in nature and so cards can be replaced when 
necessary. Products with the number x700 are duplex in that they have dual processors (called Control Mod-
ules) and so one side can take over activity if necessary. Current Allied Telesis products are listed in the 
AlliedView NMS Administration Guide.

• AT - These are products that use the name Allied Telesis (AT). They are usually ac-powered and are usually 
non-modular, although some types (such as the Switchblade family) do have replaceable cards. For a com-
plete listing of devices supported and load compatibility, refer to the AlliedView NMS Administration Guide.

• iMGs/RGs - Refer to the AlliedView NMS Administration Guide.
• Other Devices - Although the NMS in many cases can only monitor (and not manage) these devices, they can 

be discovered by the NMS and so can be included in the management system.

Note: In 12.0, the introduction of the Enterprise Edition (EE) version of the NMS means some GUIs 
are modified. Most changes involve the addition of devices on a LAN and the deletion of 
customer provisioning options. Refer to the AlliedView NMS Administration Guide.

This document is for those who use the client interface and are responsible for configuring and monitoring all or 
some part of the network. After reading this document, the user should be able to access any object in the net-
work, query and change any attribute of that object, and monitor the object (or objects) for potential problems.
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Note: This document does not include administrative tasks that can be run from the Application or 
HTML interface. These tasks are in the AlliedView NMS Administration Guide.

1.2  How this Document is Organized
This first sections of this document cover the Application Interface and the tasks that are done from that inter-
face.

The document then follows the following tree hierarchy for the Application interface. (Sub-nodes are in paren-
theses.)

• Network Maps (from overall network to user-configured sub maps)
• Fault Management (Network Events and Alarms)
• Performance Management (Configuration Collection)
• Network Inventory (overall network to user configured groups)

The last sections give an overview and a description of tasks done using the HTML interface.

To help the user understand how these areas work and interact, this document uses the following strategies:

• Starting with the map interface, the user can learn how to drill down from the network view to any network 
object, as well as how to create custom maps, usually to highlight particular device types or device states. 
Once gaining access to that device, the user can then see how to configure (or reconfigure) the device as well 
as monitor what the device is doing.

• At the beginning of each Section is the following:
• A figure that highlights specific parts of the interface. For electronic versions, there will be a link from 

these specific areas to the relevant section.
• A table with links that includes the main tasks that are performed.

• When performing certain actions at the map interface, the system will automatically go to other views, since 
that view is what controls the action. When describing the map action in this document, there will be an elec-
tronic link to the other part of the document that has the details.

• Throughout the document, there will be subsections that show sample configurations. These subsections 
allow the user to see how specific Allied Telesis devices are configured and what strategies to use to ensure 
the network is being properly monitored. There will also be background information to help the user under-
stand the sample configuration.

1.3  Document Conventions
To help the reader use this document, the following conventions are used:

• Menu selections are in bold/italic, with -> for accessing a submenu, such as Policy -> Add Policy.
• Descriptions of properties are in a two-column table, with the order of properties matching those shown on 

the window.
• Names of windows and window elements (such as Tool Tips) are in bold, such as the Restore Configura-

tion window.
• Admonishments use the words Note, Caution, and Warning, where note means added information, Caution 

means a potential degradation of service, and Warning means a potential loss of service/revenue.

1.4  How to Use Supporting Documents

1.4.1  Document Media
Customer documentation is included with the NMS CD-ROM and at the Allied Telesis website. The CD-ROM 
has only the documentation for a specific release, while the web-site will give the user the option to download 
available document releases.
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1.4.2  Printing Hardcopy
Hardcopy of the documents is in pdf format and requires Acrobat Reader. The link to the Acrobat site is provided 
on both the CD-ROM and NMS document web site. 

1.4.3  Accessing Online
The documents are also delivered in HTML format for viewing on a browser, and are included with both the 
CDROM and website download.

1.4.4  Using Online Help with AlliedView NMS
In the main screens of NMS and various forms, there is a help button. When the user presses this button, the rel-
evant section of the online document will appear if the user has downloaded the online version of the User Guide 
onto the client. The links to other parts of the document will be active, allowing the user to navigate further in the 
document if necessary. The user can also press the Show Document link which will show the full online help 
document and therefore include a frame with the Table of Contents, Index, and Search window.

1.5  Reason for Update
Refer to the AlliedView NMS Administration Guide for a list of feature changes to the AlliedView NMS for 
Release 12.1.
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2. Starting Up the User Interface

2.1  Starting Up Methods
The AlliedView Network Management System (NMS) offers a variety of startup methods, with each having its 
advantages:

• Application Client - This is used entirely on the AlliedView NMS server.
• Application Start (Web Start) - This is the preferred method when accessing the NMS from a remote loca-

tion. It requires Web Start (JRE: 1.6.0_nn) on the client. (This is also the first option on the Logon screen using 
a browser.) Refer to Figure 2-2.

• Web Client (HTML) - All that is required is a browser that meets the criteria listed in Table 2-1. (This is the 
second option on the Logon screen.)

• Applet Client - This involves loading of the correct applet and can be local or remote to the server. It requires 
the Java Runtime Environment (JRE)1.6.0_nn. (This is a link at the bottom of the Logon screen.)

Note: The monitor used by a AlliedView NMS client should have a resolution of 1280x1024 or better.

Table 2-1 lists the client types and the startup methods for each platform.

TABLE 2-1  User Interfaces and Startup Methods for the NMS

Client Type Description Windows Solaris

Web Start You must have the correct 
browser to view the logon 
screen. These are the same as 
for the Web Client (HTML) 
option.

This is used for terminals con-
nected remotely to the NMS 
server. It is the preferred 
method of accessing the NMS 
from a remote location, since 
the correct applet is automati-
cally included as part of the 
startup and does not require 
reloading on subsequent client 
startups

On the Logon screen, select the 
Launch button for the Applica-
tion Client (Web Start).

Refer to 2.2.2.

The same as Windows
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Note: When using the html client type, the browser property should be set so that for every visit to 
the page there is a check for the newer versions of the stored page. This is to ensure that any 
changes made are immediately reflected in the GUI. Refer to 7.2.2 for an example.

Web Client 
(HTML)

This uses a browser using 
HTML only and can be used 
from remote and local inter-
faces.

Browsers:

- Internet Explorer 7 and 8

- Firefox 3.0 or above

On the Logon screen, select the 
second option, and input the user 
Name and Password 

Refer to 2.2.2.

The same as Windows

Application This is used for terminals con-
nected directly to the NMS 
server and includes all soft-
ware needed.

From the Start menu of win-
dows, select Programs->Allied 
Telesis -> AlliedView NMS          
->Start NMS Client.

Directly from the home directory 
of the NMS Client, go to the bin 
directory and invoke the star-
tApplicationClient.bat file.

From the home directory of 
NMS Client, go to the bin 
directory and invoke the 
startApplicationClient.sh 
file.

TABLE 2-1  User Interfaces and Startup Methods for the NMS (Continued)

Client Type Description Windows Solaris
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2.2  Logging In

2.2.1  Using the Non-HTML Client
By choosing the Start NMS Client option from the Start menu, you get the AlliedView NMS Authentication 
dialog box. By default, the username and password are root and public, respectively. You can also change the 
username and password based on your requirements.

By default the form shows only the User ID and Password. If you select the Advanced button you see the figure 
below. Included is the name of the host machine on which the NMS server is running, which is usually already 
filled in. The default port number is 9090. If the Show Console option is checked, the Logs console will appear 
on the screen; otherwise it will not be shown.

After entering the username and the password, you can connect to the host server by clicking the Connect button. 

FIGURE 2-1  Logon Using the Application Client (Advanced Button)

2.2.2  Using the Browser
Connect the host from the browser after providing the name of the host and the port number as the Uniform 
Resource Locator (URL), such as http://<hostname>:9090. The logon screen (Figure 2-2) appears. Choose one 
of the three logon methods.

Note: The login and password entry field on the main AlliedView NMS web page are not used when 
the user selects “Application Client (Web Start)”. The Web Start Client log in procedure will 
prompt for the user/password on another window displayed later in the start up process.
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FIGURE 2-2  Logon Screen Using the Browser
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2.3  Connecting to the NMS Server

2.3.1  First Time Connection (Configuring the Password)
The NMS provides the option to configure your password once you have logged into the application client or the 
browser client for the first time. The Password Configuration dialog box appears by choosing the Tools -> 
Change Password menu item. Refer to the following figure. You can type in your new password and set the time 
duration for which this password is to remain valid. Refer to the following figure.

Note: The expiration duration is the number of days before the password expires; 0 (or negative 
number) means no expiration. To force a password to expire, the user must set the duration 
for one day, and the password will expire on the second day.

FIGURE 2-3  Setting a New Password

2.3.2  Possible Connection Failures

2.3.2.1 Password Has Expired

If you try to log in to the NMS Server after your password has expired, you will get an error message. You can 
reset the password.

2.3.2.2 User Account Has Expired

If your account has expired, a Login Failed dialog box pops up. In this condition, you will be unable to access 
the Java Client until your user account is re-activated by the NMS Administrator through the Security Adminis-
tration User Interface (UI).

2.3.2.3 User is Disabled

If your user account is disabled by the NMS Administrator through the Security Administration UI, you will be 
unable to access the Java Client until your account is re-enabled. A Login Failed dialog box will pop up indicat-
ing that your account is disabled.
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2.3.2.4 Maximum Number of Client Sessions is Reached

If you try to log in to the NMS Server while five other users are already logged in, your login attempt will fail 
with an error message indicating that the maximum number of sessions has been exceeded. The AlliedView 
NMS Server supports a maximum of five simultaneous client sessions. If you receive this error message, you 
will have to wait until one or more of the current users log out before you can log in.

2.3.2.5 Client-Server Connection is Lost

If you lose your connection with the NMS server, a dialog box with a message pops up. Restart the client using 
the methods in Table 2-1.

2.4  The Application Screen

2.4.1  Initial Screen Layout

2.4.1.1 Screen Areas

When you log in to the application interface, the initial screen that is displayed shows the map symbols repre-
senting the discovered network devices. An example is shown in Figure 2-4. Callouts in the figure identify the 
various screen areas. 

Note: For display purposes, the entire map is not shown in the figure.

You can find the Panel-Specific Menu Bar, Toolbar, Map Toolbar, NMS Tree, Alarm Count Panel, Status Bar, 
and the NMS Display Panel displayed in the user interface.

FIGURE 2-4  Layout of Initial Screen for Application Client
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2.4.1.2 Panel-Specific Menu Bar

The Panel-Specific Menu Bar is positioned at the top edge of the display area. This menu bar contains the labels 
of drop-down menus attached to it. Right-clicking a menu label displays the drop-down list of menu items for 
that menu label. In a drop-down menu, separator lines distinguish types of tasks. The menu list is context-specific 
and will vary depending on which node in the NMS Tree is being displayed in the NMS Display Panel. However, 
a few of the items are common to all of the displays. These include: Refer to www.google.com

• File - Provides control of the NMS client tool and the displays. The items include:
• Back - Moves the display in the NMS Display Panel back to the previous display
• Forward - Moves the display in the NMS Display Panel forward to the next display
• Detach - Puts the current display in the NMS Display Panel in a separate window
• Close - Closes the current display in the NMS Display Panel
• Close All - Closes all open displays in the NMS Display Panel
• Broadcast Message - Sends a message to other NMS users
• Exit - Exits the NMS Client

• Tools - Provides various tools related to the NMS. The items include:
• View Tasks - Displays a list of currently scheduled tasks
• Manage CLI Users - Provides Command Line Interpreter (CLI) user management functions
• System Log Configuration - Provides configuration functions for System Log Management
• NMS Database Backup - Provides NMS database backup functions
• Discovery Configurator - Provides configuration functions for NMS discovery
• Security Administration - Provides security administration functions
• Change Password - Allows you to change your password
• Application Manager - Provides application management functions
• Mib Browser - Provides Management Information Base (MIB) browsing functions
• Open Telnet - Allows you to telnet to another device

• Window - Provides control for the NMS client display windows. The items include:
• A radio-button list of the most recently accessed panels
• Cascade - Cascades the open windows in the NMS Display Panel
• Tile Horizontal - Tiles the open windows horizontally in the NMS Display Panel
• Tile Vertical - Tiles the open windows vertically in the NMS Display Panel
• Save Location and Size - Saves the current size and screen location of the NMS display
• Show Toolbar - Displays or hides the Toolbar

• Help - Provides Help information for the AlliedView NMS.

The context-specific menu items will be described later in this document.

2.4.1.3 Toolbar

The Toolbar displays a collection of actions, commands, or control functions. Toolbars are used to display fre-
quently used components. It is placed below the menu bar and has various tools for different nodes. A tool tip is 
provided for each tool. The Toolbar is movable and floatable. The tools that appear on the Toolbar will vary 
depending on which NMS Tree node is being displayed in the NMS Display Panel. The Toolbar for the Network 
Maps node is shown in the following figure.
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FIGURE 2-5  Example Toolbar
The Toolbar icons and their function are listed in the following table.

TABLE 2-2  Toolbar Tools and their Function

Toolbar Icon Function

Move backward to the previous display in the NMS Display Panel.

Move forward to the next display in the NMS Display Panel.

Add a new map.

Delete the currently displayed map.

Save the currently displayed map.

Refresh the map data.

Re-layout the currently displayed map.

Delete the currently selected item(s) in the map.

Undo the last Add or Delete.

Search a map or display for a specific string.

Access the properties for the selected item or the currently displayed map. If no object 
is selected in the map, the map properties are displayed. If multiple objects are 
selected, a property sheet for each selected item will be displayed.

Detach the current display in the NMS Display Panel from the NMS Display Panel. 
The display will appear in a separate window from the main NMS window.

Launch the NMS HTML user interface.

Stop the currently in-progress action.

Access the AlliedView NMS Help information.

Add a custom view.
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Note: Not all of the icons listed in Table 2-2 are shown in Figure 2-5. The actual icons that appear 
will depend on which tree node is being displayed in the NMS Display Panel.

2.4.1.4 NMS Tree

The NMS Tree is built by the user to display a set of hierarchical data. The fundamental object in a tree is called 
a node, which represents a data item in the given hierarchical set. Thus, a tree is composed of one or more nodes. 
The root node is the top node of the hierarchical data.

Nodes inside the root nodes are called child nodes. Nodes that contain no child nodes are called leaf nodes. By 
choosing a particular node, the corresponding panel will be displayed on the right-side frame.

2.4.1.5 Alarm Count Panel

The Alarm Count panel shows the count of alarms of each severity (major, minor, critical, etc.) for each category. 
The Alarm Count panel is located below the tree. An example is shown in the figure.

FIGURE 2-6  Example Alarm Count Panel
The colors used in the alarm display and their meaning are shown in the following table.

Modify a custom view.

Remove a custom view.

TABLE 2-3  Status Colors and their Meaning

Description Sample Meaning

Red Critical alarm condition

Orange Major alarm condition

Yellow Minor alarm condition

Light Blue Warning

Green No alarm-normal operation

Gray Not managed by the NMS

TABLE 2-2  Toolbar Tools and their Function

Toolbar Icon Function
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The categories are as follows:

• Topology - Alarms in the Topology map
• Fan - Fan Failures
• Provisioning - Components have not been provisioned properly
• Rediscovery - Alarms for rediscovery (mainly for iMG./RG)
• Interface - 
• Discovery - Alarms from the discovery process
• VLAN Interface - 
• Device - Alarms received from devices
• Port - Alarms relevant for device ports

Clicking an alarm count displayed in the Alarm Count panel displays the alarms of the specific severity in the 
corresponding Alarm panel. This panel is updated automatically and the counts can be seen all the time, regard-
less of the current View. The tool tip and the cursor shape change when the mouse pointer is pointed on alarm 
counts. By clicking the counts in the alarm count panel, you can find the display of the respective alarms on the 
Alarms display in the NMS Display Panel.

Note: The Alarms display panel is described later in this document.

2.4.1.6 Status Bar

The Status Bar indicates the status of the process going on such as Done or if all the contents are loaded or load-
ing... if the process is in progress. The transformation of the status bar color from dark blue to green takes place 
during the loading of the product.

2.4.1.7 AlliedView NMS Display Panel

The NMS Display Panel is the main window and shows the results of what is selected in the tree or in a menu.

Note: As you click on different nodes or menu items, the displays will stack on top of each other. 
Use the Window menu options as described in 2.4.2 to control how the displays are stacked.

2.4.1.8 MAP Toolbar

The Map Toolbar displays a collection of commonly performed actions, commands, or control functions specific 
to the map being displayed. The Map Toolbar is described in 3.1.3.

2.4.1.9 Zoom Slider

The zoom slider allows you to quickly zoom in or zoom out the map display. It appears only on Network Maps. 
Left-clicking the slider button while dragging it to the right zooms in, while dragging it to the left zooms out.

2.4.2  Controlling Windows
The pull-down Windows menu allows the user to control how the display panels are organized.

• The current open displays are listed as a radio button list with the display currently in the foreground 
checked. Clicking one of the display buttons brings the corresponding display to the foreground.

• Cascade, Tile Horizontal, and Tile Vertical control the layout of the displays.
• Save Location and Size freezes the current window size. Selecting again toggles back.
• Show Toolbar checkbox toggles showing of the Toolbar. When checked, the Toolbar is displayed.
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2.4.3  Allied Telesis Name
Clicking on the Allied Telesis name brings up the Allied Telesis Networks web site.

2.5  Broadcasting a Message
You can send messages to all clients connected to the front-end server or to all the clients managed by the main 
NMS back-end server by selecting File->Broadcast Message. Refer to the NMS Administration Guide for 
details.
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3. Using the Network Maps

3.1  Overview
A Network Map is a graphical representation of networks and Network Elements (devices). Network elements, 
such as desktops, workstations, storage devices, servers, notebooks, printers, switches, routers etc., which are 
connected in a network, can be represented pictorially in a map. This ability of maps to expose logical relation-
ships between devices and to show small but significant changes in the state of the Managed Objects (MOs), 
combined with showing complex networks, make maps an important component of NMS. The map panel con-
sists of a background image and map symbols, which are representations of the managed objects. An example is 
shown in the following figure.

FIGURE 3-1  Network Map Panel

3.1.1  Accessing the Maps
The maps are accessed by clicking on the appropriate node in the network tree. When you click on a node, the 
map appears in the NMS Display Panel as shown in Figure 3-1. As the various maps are accessed, the panel-spe-
cific menu changes to reflect map-specific menu items. These menu items are described later in this section.
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3.1.2  Understanding the Map Symbols and Colors
Each of the five default maps use symbols to represent various components of the network. These symbols and 
their meaning are shown in the following table.

Each symbol on a map depicts the state of the associated component with one of six colors. Each of these colors 
and its meaning are listed in Table 2-3. Notice that all of the symbols shown in Table 3-1 reflect a no alarm state 
(green). Should some other condition exist, the green shown in the affected symbol will be replaced with an 
appropriate color from Table 2-3.

3.1.3  Using the Map Toolbar
The Toolbar specific to the map module is required for performing operations that are specific to maps and their 
display components. The Map Toolbar is displayed at the top of the right side panel of the selected map. Refer to 
the following figure.

FIGURE 3-2  Map Toolbar

TABLE 3-1  MAP Symbols

Symbol Meaning

This symbol represents a network in an Internet Protocol (IP) network or Virtual Local 
Area Network (VLAN).

This symbol represents a router in a network.

This symbol is a solid line that interconnects objects on the map. It represents physical 
or logical connectivity between the two objects.

This symbol represents a physical device on a network. The device type is reflected in 
the symbol table (e.g. iMAP 7400).

This symbol represents a VLAN interface.

This symbol is a dashed line that interconnects two VLAN interfaces in a VLAN. It 
represents logical connectivity between the two VLAN interfaces (VLAN IFs).
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The Map Toolbar icons and their descriptions are given in the following table.

3.1.4  Using the Panel-Specific Menu for Maps
When a Network Map is accessed, menu items appear in the Panel-Specific Menu Bar that are specific to maps. 
Some of the items are common to all Network Maps, while others are specific to individual maps. The items 
common to all Network Maps include:

• Custom Views - Provides the means to create and modify maps. The items include:
• Add New Map - Allows you to add a custom map
• Delete Map - Deletes a map
• Relayout Map - Restores the layout of the map symbols to the original positions
• Save Map - Saves the map information to a file

• Edit - Provides map editing functions. The items include:
• Undo Add/Delete - Removes the previously added item or restores the previously deleted item
• Clear Alarms - Clears the alarms on a selected object
• Delete Alarms - Deletes the alarms associated with a selected item
• Order By - Sorts the objects on the map based on specific criteria
• Select All - Selects all objects on a map
• Search - Searches a map for specific information

• View - Provides access to information on a selected object. Items include:
• Details - Displays the properties associated with a selected object
• Events - Displays the events associated with a selected object
• Alarms - Displays the alarms associated with a selected object
• Performance - Displays the performance information associated with a selected object
• Refresh - Refreshes the information for a selected object

The items specific to the individual maps are described later in this section.

TABLE 3-2  Map Toolbar Icons

Toolbar Option Icon Description for Toolbar Icons

Select Mode Enables or disables select for objects on the map. When enabled (icon background 
is white), objects on the map can be selected. When disabled (icon background is 
gray), objects on the map cannot be selected.

Zoom Overview 
Window

Displays the Zoom Overview window. You can select a particular map symbol 
and click the Zoom Window tool of the Toolbar. The Zoom Overview window 
pops up displaying the exact location of the selected map symbol in the map view. 
This option is very useful when there are thousands of map symbols displayed in 
the map view, wherein you can find the exact location of the map symbol. 

Zoom Mode Enables you to select one or more map symbols for zooming. This is used for spe-
cific viewing of Map Symbols.

Zoom In Enlarges the view of the selected map. The selected map gets zoomed at the cen-
ter.

Zoom Out Reduces the view of the selected map that has been zoomed in. With every click 
on the tool, the map retracts by one size.

Undo Undoes a performed action. That is, if an action, like deleting a map symbol, is 
performed then you can retrieve the symbol in the map by clicking this tool. 
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3.1.5  Performing Common Tasks with the Maps
Use the following table to locate the task you wish to perform. If you are using NMS, use the screen or form 
name as well to locate the relevant section. 

3.2  The Default Maps
The default Network Maps include the following:

• Physical Network - Shows the physical interconnections in the network
• Routers - Shows the routers in the network and how they are interconnected
• Failed Nodes - Shows the nodes that currently have one or more failures
• IP Network - Shows the IP interconnections in the network
• VLAN Network - Shows the VLAN configurations in the network

Each of these maps is represented as a node under the Network Maps branch of the NMS Tree. A node can be 
added anywhere in the tree by specifying the parent node of the node to be added. The menu found in this panel 
for the parent and the child need not be the same. That is, the child can have either the same tree pop-up menu as 
that of the parent node or any other tree pop-up menus. This feature fulfills the Any Node Anywhere concept, 
where you can provide different types of node under a parent node.

Note: Most commonly you would place nodes where they matched the management area.

TABLE 3-3  Task List for the Map

Task Screen /Form Name (if Applicable) Section

Using the Physical Network map Not applicable (n/a) (3.2.1)

Using the Routers map n/a (3.2.2)

Using the Failed Nodes map n/a (3.2.3)

Using the IP Network map n/a (3.2.4)

Using the VLAN Network map n/a (3.2.5)

Searching in a Map n/a (3.4.4)

Sorting Map Symbols n/a (3.4.1)

Searching for Elements Search (3.4.4)

Accessing Devices iMAP Object Properties (3.4.5)

Map Properties iMAP Map Properties (3.4.6.2)

Link Properties iMAP Object Properties (3.4.6.2)
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3.2.1  Physical Network Map
The Physical Network map shows the discovered devices and their physical connections. An example is shown 
in the following figure.

FIGURE 3-3  Example of a Physical Network Map

3.2.1.1 Physical Map Symbols

This map includes a physical device symbol for each discovered device. Each symbol includes the device type, a 
label, and a color, which represents the current criticality of the device. The physical connections are represented 
by a solid line on the map, which, in reality, may be one or more physical links. Since each line on the map may 
represent more than one physical link, the lines are referred to as link sets.

Note: Physical connections between devices must be manually specified so that they can show up 
as seen in Figure 3-3. Refer to Section 6 of the AlliedView NMS Administration Guide.

3.2.1.2 Physical Map Panel-Specific Menus

When the Network Map is selected, items appear on the Panel-Specific Menu Bar that are specific to the Physical 
Map. These items include:

• Network Services - Provides network link and VLAN functions initialized with selected node/link sets. Items 
include:
• Link Operations - Provides the ability to add and delete Layer 2 links.
• Create Unmanaged Link Line - Creates s symbolic link between two selected nodes.
• Audit CES Circuits - Refer to the Admin Guide.
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• VLAN - Provides show, create, and delete functions for VLANs, and provides access to the Network 
VLAN Manager.

• QoS - Create QoS policies that will be applied to ports.
• Profile Menu - Create Profiles for devices, ports, and iMG/RGs.

• Operations - Appears only when one or more network devices are selected and when a network object is 
right-clicked. It provides operational functions on the selected device or devices. Items include:
• View Chassis - Displays the current chassis view for the selected device
• View Device Log - Show in table format the logs for a selected device.
• Provision - Provides provisioning functions for the selected device
• Network Services - Provides network link and VLAN functions for the selected device
• Alarms/Events - Displays the alarms or events, or a summary of the alarms and events for the selected 

device
• Performance - Displays the performance information for the selected device
• View Config Comparison - Brings up a tool to compare two config files.
• Discover Attached iMG/RGs - Run discovery for the iMGs/RGs connected to the device ports.
• Display Switch FDB - Display the Forwarding Database for the selected device.
• Telnet To Device - Opens a Telnet session to the selected device
• Browse Device - Opens a window to login to the device using its IP address. After entering an id and 

password, an interface (using html and javascript) opens, and allows local configuration, monitoring, 
managing, and diagnosing of the device.

• Rediscover Device - Re-initiates discovery for the selected device
• Managed Object Properties - Displays the MO properties for the selected device
• UnManage/Manage - Sets the device to unmanaged if it is currently managed, or managed if it is cur-

rently unmanaged
• Update Status - Updates the information on the selected device

• Physical Link - Appears only when one or more link sets are selected and when a link set is right-clicked. It 
provides operations and information on the selected link set or link sets. The items include:
• Link Operations - Provides network link functions on the selected link set
• Show VLANs - Displays all of the VLANs that are connected via the selected link set
• Link Alarm Events - Display the alarms or events for the selected link
• Properties - Displays the map symbol properties for the selected link set
• Managed Object Properties - Displays the Managed Object Properties form for the selected link set
• UnManage/Manage - Sets the link set to unmanaged if it is currently managed, or managed if it is cur-

rently unmanaged
• Update Status - Updates the information on the selected device/links.

3.2.2  Routers Map
The Routers map displays all of the discovered routers on the network. An example is shown in the following 
figure.
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FIGURE 3-4  Example of the Routers Map

3.2.2.1 Router Map Symbols

The Router Map displays one router symbol for each discovered router. Each symbol has a label that identifies 
the router and a color that represents the current criticality of the router.

3.2.2.2 Router Map Panel-Specific Menus

When the Router Map is accessed, the Router menu appears on the Panel-Specific Menu Bar when one or more 
routers on the map are selected. The Router menu is also displayed when a router object is right-clicked. The 
Router menu provides various functions on the selected router or routers. The items on this menu include:

• Router Details - Displays the Router Display Panel for the selected router
• Symbol Properties - Displays the Symbol Properties form for the selected router
• Managed Object Properties - Displays the Managed Object Properties form for the selected router
• Node Edit - Provides the means to delete the symbol from the map or add/delete properties for the selected 

router
• Delete Object and Traces - Deletes the selected router from the map
• Routing Table - Displays the router table for the selected router
• Interfaces - Displays the interfaces for the selected router
• TCP Table - Displays the Transmission Control Protocol (TCP) table for the selected router
• UDP Table - Displays the User Datagram Protocol (UDP) table for the selected router
• IpNetToMedia Table - Displays the IP network to media table for the selected router
• RMON Tables - Displays the Remote Monitor (RMON) tables for the selected router
• Events And Alarms - Displays the alarms and events for the selected router
• Telnet to device - Initiates a Telnet session on the selected router
• SnmpMonitor - Starts the Simple Network Messaging Protocol (SNMP) monitor on the selected router
• Performance - Displays performance information for the selected router
• UnManage/Manage - Sets the link set to unmanaged if it is currently managed, or managed if it is currently 

unmanaged
• Update Status - Updates the status information on the selected router
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3.2.3  Failed Nodes Map
The Failed Nodes map displays all nodes that have reported a major or critical failure. This map can be used to 
view all devices that are in such an alarm state. An example is shown in the following figure. 

FIGURE 3-5  Failed Nodes

3.2.4  IP Network Map
The IP Network Map shows the configuration of the discovered IP networks. This map can be used to get a high-
level view of the state of your networks. An example is shown in the following figure. Below the IP Network 
node in the NMS Tree may be one or more subnet maps. These maps narrow the view to a subnet. Clicking on 
any of the subnet map nodes will display a similar map for the selected subnet.
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FIGURE 3-6  Example of the IP Network Map

3.2.4.1 IP Network Map Symbols

The IP Network Map uses the following symbols:

• Network - One symbol exists for each discovered network.
• Router - Represents a discovered router.
• Logical Connection - A solid line that interconnects the objects. Although identical in appearance to the phys-

ical connection symbol in the Physical Network map, this symbol represents a logical connection in the IP 
Network map and not a physical link set.

3.2.4.2 IP Network Panel-Specific Menus

When the IP Network map or one of its submaps is accessed, items appear in the Panel-Specific Menu Bar that 
are specific to IP Network maps. These menu items include:

• Network - Appears when one or more network objects are selected on the map or when a network icon is 
right-clicked. It performs various functions on the network object. The items include:
• Open Submap - Displays the submap for the selected network
• Symbol Properties - Displays the map symbol properties for the selected network
• Managed Object Properties - Displays the Managed Object Properties form for the selected network
• Node Edit - Provides the means to delete the symbol from the map or add/delete properties for the 

selected router
• Delete Object and Traces - Deletes the select network object
• Stop Discovery - Stops the discovery process for the selected network
• UnManage/Manage - Sets the link set to unmanaged if it is currently managed, or managed if it is cur-

rently unmanaged
• Update Status - Updates the status information for the selected network



The Default Maps VLAN Network Map

AlliedView NMS Installation Guide (Using the Network Maps)3-10

• Operations - Appears when one or more router objects are selected or when a router object is right-clicked. 
This menu is the same as the Operations menu in the Router Map (refer to 3.2.2.2).

• Linkmenu - Appears when one or more link objects are selected or when a link is right-clicked. This menu 
provides access to information on the link. Items include:
• Properties - Displays the map symbol properties for the selected link
• Managed Object Properties - Displays the Managed Object Properties form for the selected link
• Delete Object and Traces - Deletes the selected link
• Add/Delete Property - Adds or deletes a property for the selected link
• UnManage/Manage - Sets the link set to unmanaged if it is currently managed, or managed if it is cur-

rently unmanaged
• Update Status - Updates the status information for the selected link

3.2.5  VLAN Network Map
The VLAN Network Map shows the configuration of discovered VLANs. This map can be used to get a high-
level view of all the VLANs in your network and their Layer-3 (IP) connectivity. An example is shown in the 
following figure.

Note: To have a VLAN network map with links, these links must be already configured. Refer to 
Section 6 of the AlliedView NMS Administration Guide.

FIGURE 3-7  Example of the VLAN Network Map
Below the VLAN Network node in the NMS Tree may be one or more VLAN maps that show a single subnet-
work or VLAN. These maps narrow the view to a specific Layer-2 subnetwork. Clicking on any of the VLAN 
map nodes will display a similar map for the selected VLAN. 

3.2.5.1 VLAN Map Symbols

The VLAN Network map uses the same symbols as the IP Network map to show the VLAN configurations. 
These symbols include:

• Networks
• Routers
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• Logical Connections (solid lines)

The VLAN Network submaps use the VLAN interface symbols and the VLAN connection symbols (dashed 
lines) to show VLAN configurations.

3.2.5.2 VLAN Network Panel-Specific Menus

When the VLAN Network map is accessed, items appear in the Panel-Specific Menu Bar that are specific to the 
VLAN Network map. These menu items include:

• VlanNetwork - Appears when one or more network objects are selected in the map. This menu provides func-
tions on the VLAN networks. The menu items include:
• Open Submap - Displays the submap for the selected network
• Symbol Properties - Displays the map symbol properties for the selected network
• Managed Object Properties - Displays the Managed Object Properties form for the selected network
• Alarms/Events - Displays the alarms or events, or a summary of the alarms and events for the selected 

device
• UnManage/Manage - Sets the link set to unmanaged if it is currently managed, or managed if it is cur-

rently unmanaged
• Update Status - Updates the status information for the selected network

• Operations - Appears when one or more router objects are selected in the map. This menu is the same as the 
Operations menu in the IP Network map. Refer to 3.2.4.2.

• Linkmenu - Appears when one or more link objects are selected in the map. This menu is similar to the Link-
menu menu in the IP Network map. Refer to 3.2.4.2.

3.2.5.3 VLAN Network Submap Panel-Specific Menus

When a VLAN Network submap is accessed, items appear in the Panel-Specific Menu Bar that are specific to the 
VLAN Network submaps. These menu items include:

• VLAN Operations - Appears when a VLAN Network submap is displayed in the NMS Display Panel. This 
menu performs operations on VLANs and the VLAN submaps. The menu items include:
• Delete VLAN - Deletes a VLAN. Refer to the NMS Administration Guide.
• Map Properties - Displays the Object Properties form for the map.

• VLAN Interfaces - Appears when one or more VLAN interface objects are selected on the map. This menu 
performs various operations on VLAN interfaces. The menu items include:
• Configure VLAN Interface - Configures the selected VLAN interface. Refer to the NMS Administration 

Guide for information on configuring VLAN interfaces.
• Extend Vlan - Extends a VLAN. Refer to the NMS Administration Guide for information on extending 

VLANs.
• Managed Object Properties - Displays the Managed Object Properties form for the selected VLAN inter-

face.
• Alarms/Events - Provides alarm and event information for the selected VLAN interface.
• UnManage/Manage - Marks the selected interface as unmanaged if it currently is being managed, or as 

managed if it is currently unmanaged.
• Update Status - Updates the status information on the selected VLAN interface.

• VLAN Link - Appears when one or more VLAN logical connection objects are selected in the map. This 
menu provides various operations on the VLAN links. The items include:
• Delete Vlan Link - Deletes the selected VLAN link. Refer to the NMS Administration Guide.



Custom Views Sorting Map Symbols

AlliedView NMS Installation Guide (Using the Network Maps)3-12

• Properties - Displays the Symbol Properties tab of the Object Properties form for the selected VLAN 
link.

• Managed Object Properties - Displays the Managed Object Properties form for the selected VLAN link.
• UnManage/Manage - Sets the link set to unmanaged if it is currently managed, or managed if it is cur-

rently unmanaged.
• Update Status - Updates the status information for the selected network.

3.3  Custom Views
Refer to 8.4 for a list of properties that are commonly used to create meaningful custom views.

3.4  Using the Network Maps and Symbols

3.4.1  Sorting Map Symbols
To arrange the map symbols and facilitate the viewing of map symbols in maps, you can use the sort option. To 
sort the map symbols, select Edit->OrderBy from the Panel-Specific Menu Bar, and then specify a criteria. You 
can sort the map symbols as you wish based on the criteria in the following table.

Note: The sorting of map symbols will not take place once you save the map. This is because 
sorting occurs only for the symbols whose anchor property is set to False. When you save a 
map, the anchor property of all symbols is set to True and so the sorting will not occur.

3.4.2  Managing and Unmanaging Elements in the Map
Managing an element means that you are making the NMS monitor the element, while unmanaging an element 
means that you are making the NMS stop monitoring the element. Every object in the map has a symbolic repre-
sentation of a network element, so the user can manage or unmanage elements as needed.

A selected map symbol can be made managed or unmanaged either by selecting the map symbol and then select-
ing the Operations->Manage or Operations->UnManage from the Panel-Specific Menu Bar, or by right-click-
ing the map symbol, and then selecting Manage or UnManage. The actual option selected will depend on 
whether the selected map symbol is currently in the managed or unmanaged state (it is a toggle operation). 

Once a selected map symbol is made managed, you can find the icon displayed against the selected map symbol 
in the color that reflects the severity status of the device. The same icon becomes gray in color when the selected 
device is made unmanaged.

Note: When the NMS has discovered an object (device) but it is not yet being managed (monitored), 
it will have a gray color. Double-clicking the device will cause the message No Data to appear 
in the console. (Refer to 2.2.1 on how to enable the console.) Since the device has been 

TABLE 3-4  Sorting Criteria for Map Symbols

Criteria for 
Sorting Description for Sorting Criteria

name Sorts the map symbols based on their names. Order of sorting is ascending American Standard Code 
for Information Interchange (ASCII). 

label Sorts the map symbols based on the symbols' label values. Order of sorting is ascending ASCII.

objName Sorts the map symbols based on the name of the managed object that is represented by the symbol.

status Sorts the map symbols based on the status of the managed objects represented by the symbols. Order 
of sorting is from critical to clear, meaning critical symbols will be positioned first followed by sym-
bols of lower severity.

objType Sorts the map symbols based on the type of the managed object represented by the symbols. (Node, 
Network, Router, Switch etc.)
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discovered, selecting the Network->Manage from the Panel-Specific Menu Bar will load the 
data and change the device color to reflect the device severity status.

3.4.3  Drilling Down
Drilling down into a network means exploring the details of a network element displayed in a map. Each dis-
played network element is represented by a network icon in the displayed map. The network layout of this net-
work element gets displayed as a submap by double-clicking the corresponding network icon. In this way, you 
can retrieve the information of all the elements of the sub networks, which are represented pictorially in the sub 
maps. The displayed map may contain certain sub maps of the displayed networks.

3.4.4  Searching for Elements in a Map
You can search for elements in a map based on certain match criteria. For example, you can search all elements 
displayed in the current map based on the element's label name. This section describes how you should go about 
searching for an element in a map. The search is made on all the elements in the current map displayed on the 
interface. 

The search option can be invoked by selecting Edit->Search from the Menu-Specific Menu Bar, or by clicking 

the Find button (  ) in the Toolbar. The result is the following figure.

FIGURE 3-8  Find/Search Form
In the Find form, enter the label name in the Symbol label text field available in the search screen and click Find 
next. You can skip a particular map by choosing the Next map button, which moves to the next map available in 
the NMS Tree. 

The Up and Down radio buttons can be used to notify the direction in which the search is to be performed. To 
search for an element in a map, you can also use the Ignore case option and the Match whole word option for an 
easy search. The New search button resets the values on the search form to the defaults. The Close button closes 
the search window, and the Help button displays the help document Searching for Elements in Map Views. 

3.4.5  Accessing Devices (Managed Object Properties)
When a network is discovered, all the devices that are discovered in that network are represented as symbols in 
the submap associated with each network. When devices are discovered, their symbols are added to the submap. 
Each device has properties associated with it. The property details of every device that has been discovered can 
be viewed by displaying the device Object Properties form.

The Object Property form is a tabbed panel that contains the tabs Managed Object Properties and Symbol 
Properties. The details, such as a description of the element status, the device name, the display name, the device 
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status, whether the device is managed or not, etc., are given in the Object Properties form. You can access the 
device Object Property form by clicking its symbol, and then selecting View -> Details from the Panel-Specific 
Menu Bar, or by right-clicking the device symbol, and then and selecting the Managed Object Properties 
option.

The Object Property form is the same for all network elements. The following figure shows a sample Object 
Properties form.

Note: For a complete list of MO attributes and examples, refer to Section 8.

FIGURE 3-9  Object Properties Form
Note: The communication and inventory details (placed together as Advanced Device Information) 

of the discovered devices can also be accessed. All these details are given as tables. The 
tabular information derived from the SNMP Agents associated with these devices is defined in 
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the RFC 1213 MIB, Bridge-MIB, and in the Printer MIB. These details are presented in 
Advanced Device Information in the NMS Administration Guide. The advanced device 
information details how the packets traverse in a network.

The Managed Object Properties fields can be entered in both the map view and the Network Inventory view.

3.4.6  Viewing Map and Symbol Properties

3.4.6.1 Map Properties

The Map Properties form contains the map properties, such as its name, label, image name, etc. The details can 
be viewed and modified, if necessary, by double-clicking on the map or by selecting View->Details from the 
Panel-Specific Menu Bar when no objects on the map are selected. The various map properties that are displayed 
are shown in the following figure. 

FIGURE 3-10  Map Symbol Properties Form
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The following table lists the map properties while the next table lists the map criteria properties that appear after 
clicking Next on the properties form.

 

3.4.6.2 Link Properties

Links represent the connection between two objects. The Object Properties form consists of properties such as 
name, label, source, destination, etc. It also contains the object-related properties and the user-related properties. 
The following figure shows a sample Object Properties form for a link.

TABLE 3-5  Map Properties

Property Description for Map properties

Name The unique name of the map, which is non-editable. 

Label The label of the map, which is displayed in the tree. 

TreeIconFileName The icon that is to represent the map in the tree.

ImageName The image that appears as the background of the map. 

MapLinkRenderer The name of the renderer for the links placed in the map.

MapSymbolRenderer The name of the renderer for the symbols placed in the map.

CurrentTopology The name of the renderer for the symbols placed in the map.

Anchored A checkbox that specifies whether the map symbols are anchored. If checked, the user cannot 
edit, cut, or copy any map symbols, links, etc. 

AutoPlacement A checkbox that specifies whether the map symbols are to be placed automatically. If 
checked, the symbols are placed automatically.

HelpDoc The URL of the help document to be invoked for the help option of this map. 

TABLE 3-6  Map Criteria Properties

Property Description for Map Criteria Properties

MenuName The panel-specific menu configuration file
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FIGURE 3-11  Link Symbol Properties Form
The Symbol Properties tab in the Object Properties form are shown in the following table.

TABLE 3-7  Symbol Properties for Links

Property Symbol Property for Links

Name A unique name for the map link. This property cannot be edited. 

Label The label of the map link. 

ObjName The name of the managed object with which the map link is associated. 

Source The name of the starting map symbol from where the link starts. 

Destination The name of the destination map symbol where the link ends. 

MapName The name of the map on which the link is placed. This property cannot be edited. 

MenuName The name of the object-specific menu configuration file. 
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3.4.6.3 Network Object Properties

The Object Properties form that is displayed for network objects includes symbol and managed object proper-
ties. The following figure shows a sample Symbol Properties form for a network symbol.

ObjType The type of the managed object from the combo box. 

LinkType The type of link that is to be rendered in the map. That is, based on the value specified for the 
LinkType, the desired type of link can be rendered in the map.

Status The severity of the symbol is mentioned here. This property cannot be edited. 

Managed A checkbox that indicates whether the object is managed by the NMS. If checked, the object is 
managed. 

Thickness The thickness of the link line. 

OwnerName The name of the owner to whom the link belongs. 

Type The type of the link.

iconName The name of the icon that is to represent the link in the Network Inventory. 

X The X coordinate value of the position of the Map Link. 

Y The Y coordinate value of the position of the Map Link. 

ParentName The name of the parent in the NMS Tree. 

Anchored A boolean that indicates whether the object is anchored on the map. If set to true, the object is 
anchored. 

TABLE 3-7  Symbol Properties for Links (Continued)

Property Symbol Property for Links
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FIGURE 3-12  Network Symbol Properties Form
The following table lists the Symbol Properties for network objects.

TABLE 3-8  Symbol Properties for Network Objects

Property Symbol Properties for Network Objects

Name A unique name for the map symbol. This property cannot be edited. 

Label The label of the map symbol.

ObjName The name of the managed object for which the map symbol is added. 

MapName The name of the map on which the symbol is placed. This property cannot be edited. 

IconName The name of the icon that represents the map symbol. 

MenuName The name of the object-specific menu configuration file. You can change the menu file at run time.
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3.4.6.4 Container Object Properties

Containers are created in a map and contain different map symbols. The map symbol, whose container name is 
specified against the parentName property in the form, is encapsulated in a specific container. The following 
table lists the properties for containers.

3.4.7  Monitoring and Controlling Devices

3.4.7.1 Overview

A Network Manager must be informed on the state of every device on the networks that he or she is monitoring. 
The Network Manager receives network notifications about the state of every managed device. These notifica-
tions are either unsolicited messages sent either by the agent in the device or through status polling techniques 
configured by the Administrator. These malfunctions or faults are acknowledged by the NMS as generated 
events and alarms. You can view the generated events and alarms for a MO by selecting the corresponding map 
symbol displayed in the map. This can be accomplished by selecting View->Events or View->Alarms from the 
Panel-Specific Menu Bar. On selecting the required menu item (i.e., Events or Alarms) from the Panel-Specific 
Menu Bar, the corresponding panel is displayed, which contains the generated events or alarms of the selected 
map symbol. 

ParentName The name of the parent in the tree. 

ObjType The type of the managed object from the combo box. 

Status The severity of the symbol is mentioned here. This property cannot be edited. 

Managed A checkbox that sets the object to managed/unmanaged. When checked, the object is managed. 

Discover A checkbox that enables/disables object discovery. When checked, discovery is enabled.

Anchored A checkbox that sets the object to anchored/unanchored. When checked, the object is anchored, which 
means the symbol is not handled by the map layout. For example, you can move the symbol anywhere 
in the layout. When you zoom in, it won't be in the moved position; that is, it remains in its original 
position.

X The X coordinate value of the position of the map symbol. 

Y The Y coordinate value of the position of the map symbol. 

Height The height of the map symbol image. 

Width The width of the map symbol image.

OwnerName The name of the object owner.

Type The object type.

TABLE 3-9  Container Object Properties

Property Description for Container Properties

containment A boolean that indicates whether the symbols inside the container should truly be contained within the 
boundaries of the container. If the value is set to True you cannot move any of the symbols outside the 
boundaries of the container (meaning containment is true). If it is set to False you can move symbols 
outside the boundaries and still they will be children objects of the container with their ParentName 
referring to the container object. 

layout The layout of the map symbols that are contained in the container. You can change the layout as per 
your requirement. 

currentlayout The current layout of the map symbols of the container. 

TABLE 3-8  Symbol Properties for Network Objects

Property Symbol Properties for Network Objects



Monitoring and Controlling Devices Using the Network Maps and Symbols

3-21AlliedView NMS Installation Guide (Using the Network Maps)

3.4.7.2 Accessing Alarms for Device 

You can view the alarms generated for the MOs by selecting the corresponding map symbols displayed in the 
map and selecting View->Alarms from the Panel-Specific Menu Bar. On clicking this menu option, the Alarms 
panel (under Fault Management) of the NMS Tree gets selected, displaying the last generated alarm and its 
severity status for the selected map symbol. 

You can also right-click on a device, and then select Alarms/Events - > Alarms from the pop-up menu.

3.4.7.3 Accessing Events

You can view the events generated for the MOs by selecting the corresponding map symbols displayed in the 
map and selecting View->Events from the Panel-Specific Menu Bar. On selecting this menu option, the Network 
Events panel (under Fault Management) of the NMS Tree is selected, displaying the list of generated events over 
a period of time for the selected map symbol.

You can also right-click on a device, and then select Alarms/Events - > Events or Alarms/Events - > Summary 
from the pop-up menu.

3.4.7.4 Accessing Statistics

You can retrieve polled data collected for the MOs by selecting the corresponding map symbols displayed in the 
map and selecting View->Performance from the Panel-Specific Menu Bar. Based on the collected statistical 
data, the performance of the selected device can be monitored for a given time period. On selecting this menu 
option, the Configured Collection panel (under Performance) of the NMS Tree is selected, displaying the created 
polled data for the selected map symbol. 

You can also right click on a device, and then select Performance from the pop-up menu.

3.4.7.5 Updating Status 

To poll an element for its status, you can right click on the element, and then select Update Status from the pop-
up menu. This menu item enables the user to view the status of the selected map symbol despite the set polling 
period. You can also select the symbol on the map, and then select Operations->Update Status from the Panel-
Specific Menu Bar.
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4. Using the Fault Management View

4.1  Overview 
Views are used in the AlliedView NMS to display information related to a specific aspect of network manage-
ment, such as network events. The Fault Management view is a default view that displays information related to 
events, system logs, and alarms. In addition to the Fault Management view are two other default views: Perfor-
mance and Network Inventory. These views display additional information on the network and are described 
later in this document. This section focuses on the Fault Management view and how it is used.

Network Events are entities that represent the various happenings in the network devices. Events can convey gen-
eral information or the current status of the devices in a network. Working with the NMS, the user can know the 
history of a device by browsing through the Event Viewer in the client. The Event Viewer provides a wide range 
of features to the user in extracting the required information from the Network Events.

System logs are indications from individual devices that some change has occurred on the device. It may be a 
minor change in which case the log merely provides information, or it may be a significant change that requires 
attention, such as an alarm or failure. The System Log Events viewer, which is a subview of the Network Events 
view, provides a wide range of features to the user in extracting the required information from the system logs.

Alarms are generated when a failure or fault is detected in the network devices. The generated Alarms are dis-
played in the Alarm Viewer. The Alarm list containing alarms of various severity levels, such as critical, major, 
minor, clear, etc., can be viewed in the Alarm Viewer. The Alarm Viewer provides a wide range of features to the 
user in extracting the necessary information from the Alarms and viewing them in a specific way.

4.2  The Network Event View
This Event Viewer gets displayed on selecting the Network Events Panel under Fault Management of the NMS 
Tree as shown in the following figure.

FIGURE 4-1  Network Events Main Panel
As shown in Figure 4-1, the Network Events view presents information on all events that have occurred on the 
network. 
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Note: The Node clear. No failures on this node event indicates the node was successfully polled 
and that the results show a previous failure on the node has cleared. When this event occurs, 
if no other alarm conditions exist on the node, the alarm severity for the node will change to 
green. However, if another alarm exists on the node, such as a Threshold Crossing Alarm 
(TCA), the alarm severity of the Node clear. No failures on this node event and the node will 
reflect the severity of the persisting alarm even though the event indicates no failures on the 
node. Please keep in mind that the Node clear. No failures on this node event means that all 
failures have been cleared on the node and not that all alarms have been cleared.

4.2.1  Panel-Specific Menus for Views
As with Network Maps, the Panel-Specific Menu Bar is available for each view. Some of the menus are com-
mon to all views, while others are specific to an individual view. The relevant menus appear when a view is dis-
played in the NMS Display Panel.

4.2.1.1 Panel-Specific Menus Common to all Views

The panel-specific menus that are common to all views include:

• File
• Custom Views
• Tools
• Window
• Help

The File, Tools, Window, and Help menus are the same menus that appear for Network Maps. These menus are 
described in 2.4.1.2. Although the Custom Views menu also appears for Network Maps, the items in this menu 
are different for views. For views, the items in the Custom Views menu include:

Add Custom View - Adds a custom view to the NMS Tree (custom views are described later in this document)

Remove Custom View - Removes a view from the NMS Tree

Modify Custom View - Modifies the filtering criteria for a view

Save Custom View State - Preserves the state of the current view displayed in the NMS Display Panel

Rename Custom View - Renames a view

4.2.1.2 Panel-Specific Menus for the Network Events View

When the Network Events view is displayed in the NMS Display Panel, the following menu items appear in the 
panel-specific menu that are specific to the Network Events view:

• Edit - Provides editing functions for the view. Items include:
• Configure - Provides configuration functions for trap and event parsers, and for event filters.
• Search - Provides a search function for the view (refer to 4.2.2.1).
• Export Table Data - Provides an export function for all of the view data. The data may be exported to a 

file (in delimited tabular form) or to a Web browser. The data may also be filtered. Refer to the NMS 
Administration Guide for more information.

• Export Selected Rows - Provides an export function for selected rows in the view data. Refer to the NMS 
Administration Guide for more information.

• Schedule Event Export - The Events in the View can be exported to a file now or at a later time. There is 
a separate subsection (4.2.1.3) to explain this feature.

• View - Provides additional display functions for the view. Items include:
• Event Details - Brings up the Event Details Form, where attribute values can be seen.
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• Source Details - Brings up the Details Form, except as follows:

- For the VLAN IF, the Chassis View appears.

- For the iMG/RG, the Triple Play Service Management Form appears

- For a port, brings up the Port Menagement Form

• Alarms - Provides alarm information specific to the selected event. 

Note: Selecting this option will take you to the Alarms view.

• Refresh - Refreshes the view information.
• Actions - 

• Save To File option, which saves the event information to a file.
• Export Events - 

4.2.1.3 Schedule Event Export

The menu item Schedule Event Export exports the event view to a file either now or a later time. Figure 4-2 
shows the form that is displayed.
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FIGURE 4-2  Export Scheduler Task Window
This form is similar to other scheduling forms. Note the following:

• The words DATE and TIME in the Export Destination will be replaced by the date and time on the server 
when the schedule is executed and the names of files generated will have the actual date and time.

• Separator fields work the same way as they do in on-demand table data export and the selected separator will 
be used when the data is exported to text files.

• Match criteria fields (options) available on the screen are very similar to those in on-demand Events/Alerts 
Table Data Export. 

• One new option in match criteria used instead of dates allows the user to select number of previous days 
within a range to be included in each of the scheduled export. The criteria is Days/Range and within. 

For example, the user may set a schedule to export of all critical events every day by selecting Recurring 
radio button and every day of the week checkboxes and set the Days/Range option to 1 to export daily data 
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every day. For every week by the user would select one day in the Recurring schedule and set the Days/Range 
to 7 to export data for the past seven days once every week.

• The output files generated by each export are very similar to those generated by on-demand Events/Alerts 
Table Data Export. In the scheduled export there will be a new file every time the schedule is executed.

All schedule fields are the same as used in other schedule related operations such as NMS backup.

4.2.2  Navigating in a View
By using the Navigation Panel, the user can help isolate specific items in a view. Refer to the following figure.

FIGURE 4-3  Navigation Panel
The Navigation Panel button functions are as follows:

• First – View the first page of the items
• Previous – View the previously viewed frame
• Next – View the next frame of items
• Last – View the last frame of items

The range of items to display is controlled by the View Range fields. You can also use the drop-down list to use 
the default ranges available.

You can sort the items based on the column type by clicking on the column. There are two types of sorting:

• Server – By clicking on the column, you sort the complete data. Clicking on the column again will toggle the 
ascending to descending. The sort indicators for server-side sorting for ascending and descending are  and 

, respectively
• Client – By pressing and holding the Ctrl key, and then clicking the column, you sort the client-side data. The 

sort indicator for client side sorting for ascending and descending are  and , respectively.

You can combine both in one column by performing both types of sorts. You can also reorder the columns by 
dragging a column header to the right or left.

Note: When starting the client and opening the Network Events or Alarms panel for the first time, you 
will see the last page with the most recent events or alarms shown. Click the Date column 
twice, then click the First Page button, so that the most recent events or alarms appear on the 
first page in descending order (most recent event or alarm first).

Note: Sorting on IP Addresses results in lexical order, not numeric.

4.2.2.1 Searching in a View

To search for specific items in a view, select Edit -> Search from the Panel-Specific Menu Bar, or click the 

Search button (  ) in the Toolbar. This will display the search window shown in the figure, which will allow 
you to specify the search criteria.
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FIGURE 4-4  View Search Window
You can choose whether all the criteria or any of the criteria should match by clicking the Match any of the fol-
lowing or the Match all of the following radio button.

Each criteria is defined as the column name, a search pattern qualifier, and the search pattern. The column name 
can be selected from a drop-down list of the column names displayed in the current view. The search pattern 
qualifier can be selected from a list of the following:

• starts with
• doesn’t start with
• ends with
• doesn’t end with
• contains
• doesn’t contain
• equals
• not equals

The search pattern is the string to be matched in the search and is simply typed into the text box. To add addi-
tional criteria, click More. To begin the search, click Search.

When Search is clicked, the entries matching the search criteria will be displayed in the view, and the Show All 
button will appear to the right of the navigation buttons. (If no entries match the criteria, the view display will be 
blank.) To restore all of the entries in the view, click the Show All button.

Note: Searching on Date will result in incorrect match on current date.

The following behavior may be observed when searching on the Message column in Syslog Events:

• using the search pattern qualifier “starts with” or “ends with” takes a while to complete
• using the search pattern qualifier “equals” yields an empty result set
• using the search pattern qualifiers “doesn't start with”, “doesn't end with”, and “not equals” returns all mes-

sages including those that do not meet the criteria.
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4.3  Creating Custom Views for Events
Refer to 8.4.10 a list of properties that are commonly used to create meaningful custom views.

4.4  Event View Tasks

4.4.1  Specify Event Details
Event Details gives detailed information about the properties of the event that is selected from the displayed 
Event viewer. The properties are displayed in the Details form in which you can view properties such as Severity, 
Message, Category etc.

By double-clicking any part of an event displayed in the Event Viewer, you can view the event property details. 
You can also select View->Details from the Panel-Specific Menu Bar to retrieve the property details after select-
ing the event. (The selected event will turn dark gray.) This brings up the Event Details form showing the com-
mon criteria, as shown in the following figure.

FIGURE 4-5  Event Details Form
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The following table lists the properties and their values.

4.4.2  Saving Events to a File
The event information displayed in a Network Events map can be saved to a file by selecting Actions->Save To 

File from the Panel-Specific Menu Bar or by clicking the Save icon ( ) in the Toolbar. This will display the 
Save Event file on Remote Server window shown in the following figure. 

FIGURE 4-6  Save Event file on Remote Server Window
To save the information, type a file name in the File Name field, and then click the Save File button. A confir-
mation dialog box will appear indicating that the file was saved. You will find the file in directory <Web NMS 
Home>/state. The file will be an ASCII file that contains the event information in a colon-separated (:) list as 
shown in the following figure. You can open and view the file using any ASCII file editor, such as Notepad or 
vi.

TABLE 4-1  Event Detail Properties

Property Description for Event Detail Properties

Index A unique index number to every generated event. 

 Severity 
(Class)

The severity of the event to be filtered can be assigned here using the combo box. Multiple 
severity can also be assigned by separating them using comma. 

Message A property in the event object which stores any important additional information of the event. If 
you want to view the event with a particular message, then you may fill the message in this field, 
which will display the events with the corresponding message. 

Category The text that appears in the Category column if it is displayed. 

 Domain Any domain-specific information based on physical location, functional categorization, or logical 
categorization of the source of the event. 

Network Information about the network to which the source of the event belongs is specified here. 

Node Any additional information about the source, or the source itself, of the event. 

Failure 
Object

Information about the specific entity within the source of the event, which is primarily responsible 
for the occurrence of this alarm. The name of the failure object to be filtered can be given in this 
field. 

Source Information about the source of the alarm. The source based on which alarms are to be filtered can 
be given in this field. 

Help URL The URL of the help document related to the event, which is reached through the Help button at 
the bottom of the event details sheet. 

Date/Time An date/time after which events that occur are displayed in the custom view. In other words, 
events that occur after this date/time are displayed.

AlliedView 
NMS

The name of the AlliedView NMS.
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FIGURE 4-7  Sample Event File
When saving these files, the AlliedView NMS sets as the default directory the <NMS Home>/state directory, 
so the file as entered in Figure 4-6 would be stored as:

 <NMS Home>/state/NetEvents-AUG2003

If the user wishes to store the file in another directory, the path included must be relative to the default path. For 
example, if the user wishes to save the file in the <NMS Home>/conf directory, the user would enter

 ../conf/NetEvents-AUG2003

This will be shown in the status message when the file is successfully saved.

4.4.3  Configuring Trap Parsers
Configuring a trap parser is done to create and refine the information received from a trap (a specific unsolicited 
report by a device). 

Configuring trap parsers can be done by using the information in the MIB to set the match criteria or by defining 
the configuration and saving it to a file.

To configure a trap parser, select Edit -> Configure > Trap Parsers from the Panel-Specific Menu Bar for Net-
work Events. 

Caution: Configuring Trap Parsers is an Administrator task. For information on adding, 
modifying, and deleting Trap Parsers, refer to the NMS Administration Guide.

4.4.4  Configuring Event Parsers

When an event arrives into Web NMS, the event parsers list is checked to see whether the incoming event satis-
fies the match criteria of the event parser. If the event parser matches, the event is passed through the correspond-
ing event parser. The outgoing event from the parser is then matched with the remaining set of parsers (if any, in 
sequence). If there are any matches, the event will be passed through those parsers. This process will continue 
until there are no parsers left to be scanned.
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Configuring Event Parsers can be done by defining the Event Parser or the information or defining the configu-
ration and saving it to a file.

To configure an event parser, select Edit -> Configure > Event Parsers from the Panel-Specific Menu Bar for 
Network Events. The Event Parser Configuration form will appear as shown in the following figure.

Caution: Configuring Event Parsers is an Administrator task. For information on adding, 
modifying, and deleting Event Parsers, refer to the Administration Guide.

FIGURE 4-8  Event Parser Configuration Form - File
In the Configured Event Parsers list on the Event Parser Configuration form, the user can view the list of cur-
rently configured event parsers. Clicking any of them will the display the corresponding details in the form. By 
default, the event parsers that are saved in the file event.parsers under <Web NMS Home>/conf directory will 
be loaded automatically when the server is started afresh. (cold start i.e., server is started after re initializing) and 
displayed in the list.

4.4.5  Configuring Event Filters
Event Filters provide a way of setting matching criteria to filter events and then configuring an action (such as an 
email) for those events. To configure an event filter, select Edit -> Configure > Event Filters from the Panel-
Specific Menu Bar for Network Events. 

Caution: Configuring Event Filters is an Administrator task. For information on adding, 
modifying, and deleting Event Filters, refer to the Administration Guide.

4.4.6  Viewing Related Alarms
To view the related alarms for a particular event, click anywhere on the event row and select View -> Alarms 
from the Panel-Specific Menu Bar. The alarm view related to the event appears. Refer to 4.6.



Viewing Related Alarms System Log Events Subview

4-11AlliedView NMS Installation Guide (Using the Fault Management View)

4.5  System Log Events Subview
The System Log Events subview is a default subview of the Network Events view. The System Log Events view 
shows the system logs received from the managed devices on the network. It is shown in the following figure.

FIGURE 4-9  System Log Events Subview
The logs that are displayed in this view are configured using the System Log Configuration tool. Refer to the 
NMS Administration Guide for information on using this tool.

You can view detailed information on a log by right-clicking the log, and then selecting Details from the pop-up 
menu. An alternative method is to select the log, and then select View -> Details from the Panel-Specific Menu. 
In either case, the Event viewer will appear as shown in the following figure.
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FIGURE 4-10  Log Event Details Window - File
You can create custom views and event parsers for system logs in the same way you create them for Network 
Events. You can also save the log information to a file by selecting Actions->Save To File from the Panel-Spe-
cific Menu Bar or by clicking the Save icon in the Toolbar. 

4.6  Alarm View Display
The Alarm View displays alarm information on your network. To access the Alarm View, select the node 
Alarms from the NMS Tree. An example of the Alarms View display is shown in the following figure.

FIGURE 4-11  Alarm View Main Panel
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Navigating the view is the same for all views and is described in 4.2.2. Searching for information in the view is 
also the same and is described in 4.2.2.1.

4.6.1  Panel-Specific Menus for the Alarms View
When the Alarms view is displayed in the NMS Display Panel, the following menu items appear in the Panel-
Specific Menu Bar that are specific to the Network Events view:

• Edit - Provides editing functions for the view. Items include:
• Configure - Provides configuration functions for trap and event parsers, and for event filters.
• Delete - Deletes the selected alarm.
• Pick Up/UnPick - Assigns or unassigns ownership of the selected alarm to you.
• Clear - Clears the selected alarm.
• Search - Provides a search function for the view (refer to 4.2.2.1).
• Export Table Data - Provides an export function for all of the view data. The data may be exported to a 

file (in delimited tabular form) or to a Web browser. The data may also be filtered. Refer to the NMS 
Administration Guide for more information.

• Export Selected Rows - Provides an export function for selected rows in the view data. Refer to the NMS 
Administration Guide for more information.

• Schedule Alert Export - The Alarms in the View can be exported to a file now or at a later time. The form 
for this function is the similar to the Schedule Event Export, and is explained in subsection 4.2.1.3.

• View - Provides additional display functions for the view. Items include:
• Alert Details - Brings up the Alarm Details Form, as explained in 4.8.1.
• Source Details - Brings up the Details Form, except as follows:

- For a port alarm, brings up the Port Details tabbed form.

- For the VLAN IF, the Chassis View appears.

- For the iMG/RG, the Triple Play Service Management Form appears

• Alarms - Provides alarm information specific to the selected event. 
• Actions - Provides a Save To File option, which saves the event information to a file.
• Export Alerts - Export to a file the rows displayed or all rows associated with the current view.

4.7  Creating Custom Views for Alarms

4.7.1  Overview
Refer to 8.4.11 a list of properties that are commonly used to create meaningful custom views.

4.8  Alarm View Tasks

4.8.1  Specify Alarm Details
By double-clicking or right clicking an alarm, you can view the complete details of the alarm. You can also select 
View-> Details from the Panel-Specific Menu Bar after selecting an alarm from the Alarm Viewer. (The selected 
alarm entry will turn a dark gray.) This brings up the alarm details form, as shown in the following figure.
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FIGURE 4-12  Alarm Details Form
The following table lists the properties.

On the alarm details screen are buttons that provide the following (left to right):

• Pickup

TABLE 4-2  Properties for Alarm Details

Property Description for Alarm Detail Properties

Message Important additional information regarding the alarm.

Failure object Information about the specific entity, which has caused the alarm within the source as identified by 
the source field of the alarm.

Source Information about the source of the alarm.

Owner The name of the owner with which the alarm is associated.

Category The category of the alarm.

Created The date and time when the alarm was first created.

Modified The date and time when the alarm was last modified.

Severity The criticality of the alarm.

Previous 
severity 

The previous severity.
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Clicking this annotates the alarm with the id of the user, so that others can see who is working the problem. 
The option then toggles to Unpick so that the user can remove the id later.

• Annotate (Alarm Annotations)

Clicking this allows you to add notes for an alarm so that other users can see how this type of problem was 
solved, allowing for more efficient problem resolution.

• Refresh

Clicking this refreshes the information on the form.

• Properties

Clicking this opens a small window containing any user property that you have included for the alarm. This is 
actually non-editable and helps only to view the properties you have specified.

• View history

Clicking this allows you to view the status of alarms added, updated, or deleted. NMS automatically takes 
care of updating, clearing, and deleting Alarm History. 

• Merge

Clicking this allows you to simultaneously view both Alarm Annotations and Alarm History by choosing the 
Merge option.

• Close

Clicking this closes the window.

4.8.2  Configuring Alarm Filters
Alert filters are used to filter and modify the properties of an incoming alert. When the alert matches specified 
criteria, an action (such as sending an email) will occur.

To parse alarms, select Edit -> Configure > Alarm Filters from the Panel-Specific Menu Bar for Network 
Events. The Alert Filter Configuration form appears.

Caution: Configuring alarm filters is an Administrator task. For information on adding, 
modifying, and deleting Alert Filters, refer to the Administration Guide.

4.8.3  Saving Alarms to a File
Saving alarm information to a file is similar to saving network event information to a file, which is described in 
4.4.2.

4.8.4  Viewing Related Events
To view the related events for a specific alarm, select the alarm anywhere in its row, and then select View -> 
Events from the Panel-Specific Menu Bar. This displays the Event view panel and displays the events related to 
the alarm.

4.8.5  Clearing and Removing Alarms
Clearing alarms means to change the status of the alarm to Clear. Highlight the alarm (or alarms using the Ctrl 
key), and then select Edit -> Clear from the Panel-Specific Menu Bar. To remove the alarms from the database 
so that they will not be reported, highlight the alarm, and then select Edit -> Delete from the Panel-Specific 
Menu Bar.
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4.8.6  Alarm Count Panel
The Alarm Count Panel provides a way to view the summary of the Alarms generated by the NMS. The sum-
mary gives the number of Alarms that have been generated under various categories and severity levels, as 
shown in the following figure.

FIGURE 4-13  Alarm Count Panel
The Alarm Count Panel displays the Alarms generated in a tabular fashion to facilitate easy viewing. You can 
also see the alarm numbers in bar code and pie chart format.

Each row corresponds to a specific Application of Alarms. The Applications that are to be displayed in the Panel 
are configurable. Thus, the number of rows corresponds to the number of Applications of Alarms that have been 
configured to be viewed (excluding the last row that gives the Totals). An alarm will have a Severity; - Critical, 
Major, Minor, Warning, Clear. So, the number of columns corresponds to the number of Severity levels config-
ured (excluding the last column that highlights the Application Name).

The Alarm count is done based on severity and when an Alarm is generated. The count is updated automatically 
under the appropriate column (Severity).

The last row gives the total count of Alarms of all applications (including the ones without any application 
defined) classified into different severity levels.
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5.  Using the Performance View

5.1  Overview
Performance monitoring basically means collecting useful data from network devices and determining how effi-
ciently the network is functioning. Performance is measured based on various factors, such as:

• The number of bytes of data received (over a period) by a particular interface of a device
• The number of bytes of data sent (over a period) by a particular interface of a device
• An estimate of the interface's current bandwidth in bits per second

The data pertaining to a network device are collected based on the definition of performance variables (otherwise 
called statistics and polled data). 

Use the following table to locate the task you wish to perform. If you are using AlliedView NMS, use the screen 
name or form name as well to locate the relevant section. 

5.2  Polling Concepts
The process of collecting the data from a network device is called polling. Every statistic has the following 
details: 

• The data to poll
• The device from which the data will be polled
• The polling interval

The following figure lists the basic flow for Performance Monitoring.

TABLE 5-1  Task List for Performance Monitoring

Task Screen / Form Name (if Applicable) Section

Review Screen Components Configured Collection (5.3.4)

View Graphs Not applicable (n/a) (5.5.3)

Print a Graph n/a (5.5.4)

View Data Real Time n/a (5.5.5)

Configure Thresholds Threshold Properties (5.6.1)

Configure Statistics Data Collection Detailed Properties (5.7) (Administrator Task)
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FIGURE 5-1  Setting up Performance Monitoring
The person or persons responsible for performance monitoring will have the following tasks, which are 
explained in detail later in this section:

• Viewing Data Collection Details - Statistics are the basic unit of network data collection. The data about a 
network device is collected based on the definition of a statistic.

• Creating a Custom View - By default, you are able to view all the statistics of all the network devices in the 
Configured Collection panel. To view very often a particular set of statistics you can create a custom view 
and specify the matching criteria. Only those statistics that match the specified condition will appear in the 
custom view.

• Viewing the Data - AlliedView NMS allows you to plot collected statistical data as bar or line graphs. This is 
useful for trend analysis. You can view the collected data in the form of graphs and reports.

• Monitoring Real-Time Data Collection - If you want to view the data as it is collected rather than fetching it 
from the database, you can choose this option. This is otherwise called on line data collection monitoring. 
You may require this when you want to view the data currently collected for the device. Graphs and tables 
are available for monitoring.

5.3  Data Collection Interface

5.3.1  Overview
The interface for performance data in the AlliedView NMS is the Configured Collection view under the Perfor-
mance node in the NMS Tree. This view displays the statistics for the nodes on the network and is used as the 
interface to the data.

5.3.2  Setting Up the Interface
Before starting any data collection process, you must define what data to poll, from where, in what interval, etc. 
This definition is created in objects called Statistics. To collect n type of data from a device you have to create n 
Statistics. The NMS Administrator can configure this setup and add more Statistics, if necessary, before the 
AlliedView NMS server starts. The NMS Administrator can also add Statistics at runtime. You can view the list 
of statistics associated with each of the MOs discovered in the network using the Configured Collection panel. 

Note: An MO represents a network element for which data have to be collected. It can be a node, 
interface, a port, a card, a slot, etc.
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5.3.3  Panel-Specific Menus for the Configured Collection View
When the Configured Collection view is displayed in the NMS Display Panel, the following items appear in the 
Panel-Specific Menu Bar that are specific to the Configured Collection view:

• Edit - Provides editing functions for the view. Items include:
• Threshold - Provides the ability to add, modify, and delete thresholds.
• Polling Objects - Provides the ability to view, add, modify, and delete polling objects.
• Add Statistic - Provides the ability to add a new statistic.
• Remove Statistic - Provides the ability to remove a statistic.
• Modify Statistic - Provides the ability to modify a statistic.
• Search - Provides a search function for the view (refer to 4.2.2.1).
• Export Table Data - Provides an export function for all of the view data. The data may be exported to a 

file (in delimited tabular form) or to a Web browser. The data may also be filtered. Refer to the NMS 
Administration Guide for more information.

• Export Selected Rows - Provides an export function for selected rows in the view data. Refer to the NMS 
Administration Guide for more information.

• View - Provides additional display functions for the view. The items include:
• Plot - Provides graphing functions for the current and collected statistics. Refer to 5.5.2.
• Refresh - Refreshes the view data.

• Actions - Provides a Save To File option, which saves the event information to a file.

5.3.4  Screen Components for Statistics
To access the Data Collection screen, perform the following:

1. Select the Configured Collection node from the tree in the left frame. You can see the Configured Collection 
panel in the right frame, which displays a list of nodes under the Hosts column. This list indicates that these 
devices have been identified in the network for data collection.

2. Select any of the hosts, and you will see the associated Statistic. (Each row of information is called a Statis-
tic). Refer to the following figure.

FIGURE 5-2  Collection View Panel
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The following table lists the components in.the previous figure.

Note: The green colored branch-like image adjacent to the Statistic name denotes the type of 
Statistic. Statistics are of three types: Node, Interface, and Multiple. The symbol with 

multiple branches  denotes that the statistic is of type Multiple (one node and all 
associated interfaces).

If no data are to be collected for a Statistic, the data are disabled temporarily by the Administrator. In such a 
case, you will see the Statistic row displayed in blue color. Once it is activated, the row color changes to green.

5.4  Creating Custom Views
Refer to Section 9 for a description of creating custom table views. Refer to 8.4.9 for a list of the properties that 
can be used when creating a custom view

TABLE 5-2  Data Collection Screen Components

Component Description for Data Collection Screen Components

Property 
Columns

You can see for every statistic that the associated properties are displayed in columns. For 
example, Statistic name, Poll ID, Data Identifier, DNS Name, interval etc. The Administrator 
decides which properties are to be displayed. Some of the properties are described below.

• Statistic Name - A string to identify the Statistic uniquely. This should be a mean-
ingful name describing the Statistic

• Poll ID - A unique number associated with each Statistic for AlliedView NMS 
Performance module to identify the Statistic. Poll ID is automatically generated 
and hence no two Statistics will have the same Poll ID.

• DNS Name - This is the Host name (device name) with which this Statistic is 
associated

• Data Identifier - This is the Identification number of the device interface from 
which data about the device is to be collected. This Data Identifier is otherwise 
called as Object Identifier (OID), which is unique for every device. A list of pos-
sible OIDs for a device exists in the MIB definition of the device. 

• Interval - This specifies when data should be collected for the Statistic. For exam-
ple, the value 300 indicates that after every 300 seconds, data is collected. 

Page Length You can see a drop-down box labeled Page Length, which displays a number of hosts to be 
displayed per page. By default, it is set to 10. Hence, you can see 10 hosts displayed in the left 
panel of the Configured Collection frame.

From and To 
Range

There are two text boxes available labeled Displaying and To. You can set values in these and 
see the hosts list in that range. For example, If you set Displaying as 4 and To as 13, you will 
be able to view from Host 4 to Host 13. By default, the hosts are displayed in reverse 
alphabetical order.

Navigation 
Buttons

You can see four navigation buttons provided at the top right of the frame. They are Go to first 
page, Go to previous page, Go to next page and Go to Last page respectively. They will be 
enabled and disabled automatically based on your choice of page length and total number of 
hosts

Total This text box cannot be edited, and it shows the total number of hosts available for data 
collection.
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5.5  Viewing Historical Data

5.5.1  Overview
Once the AlliedView NMS server starts, data collection also starts automatically. Data is collected from the 
devices listed under the Hosts list in the Configured Collection panel. Data is collected only for those Statistics 
listed in the panel for each host.

The collected data is stored in a database maintained by the AlliedView NMS. Every day's data is stored in sepa-
rate database tables. Every table has a name with the current date appended to the name in the form 
STATSDATAmm_dd_yyyy. (The mm and dd fields may be one or two digits.) A sample database table name is 
STATSDATA4_23_2002, which contains data collected on April 23, 2002.

You can deal with the collected data in various ways:

• Allow the data to be stored in the database for later viewing (for long-period trend analysis).
• View the Data in the form of a graph.
• View the Data in the form of a report.

5.5.2  Using Graphs
Two types of graphs are provided: line graphs and bar graphs. The graph is plotted by fetching the collected data 
already available in the database. No update is made in the graph as it is being viewed; that is, there is no 
dynamic plotting of the graph for the data collected from the device for that moment.

5.5.3  Procedure to View a Graph
You can view the graph by following these steps:

1. Select the statistic in the Configured Collection panel for which you want to view the graph.
2. Select View -> Plot -> Collected Statistic from the Panel-Specific Menu Bar.

Possible Messages you may receive are:

• Data not yet Collected - By default, automatic data collection starts after five minutes after the server starts 
up. Also, data collection for a new statistic added via UI will start within five minutes of its creation. But this 
delay is configurable and will be set according to the requirement in your network. So do not get confused if 
you see the message Data not yet collected when you choose to view a graph or a report. It indicates that a 
data collection delay has been set. Please note that for counter-type OIDs, the first data collected is not stored. 
When second time data is collected, the difference between the two values is calculated and stored. Hence, 
depending on the polling interval set, the data will be collected on the second time. So, you might have more 
delay with respect to counter-type OIDs.

• A blank Graph and the message No data collected - There are two possible reasons:
1. No data was collected for the current day, so choose Yes and change the From date and To date to view 

past data.
2. The AlliedView NMS Server and Client are running on different machines and their time settings and 

time zones are not the same. Hence, synchronize the time settings to view the graph data.

The following figure shows the resulting graph.
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FIGURE 5-3  Collected Statistics Graph
Following are the main graph components:

• Graph Type - A drop-down box that displays two options, Line graph and Bar graph. You can choose any of 
these whenever you want and monitor the collected data.

• Data Range Setting - To view the data collected between a particular date range.
• Plot Button - Whenever you change the Graph type or Date Range, click the Plot button to restart plotting.

5.5.4  Printing a Graph
You can print the graph using the Print option provided in the Web browser or by using the Print Screen key on 
the keyboard.

5.5.5  Viewing Real Time Data
Once you narrow down your search and identify which device is the cause of the problem, you can use real-time 
monitoring to view and analyze the data of a particular statistic as it is collected from the device.

You cannot achieve this using Collected Statistics graph because of the following:

• The Collected Statistic graph displays only historical data; that is, past data available in the database.
• The Collected Statistic graph does not update its display when you are viewing it. Hence, to view the updates 

in the graph, you will have to either close the graph window and redisplay it periodically, or change the time 
range and then click the Plot button.

In this situation, you can select the current statistics graph.

Note: You might get an error message such as Time out, which indicates that the agent has been 
delayed in responding or the agent is down.
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Assume, for steady performance, that you might need the value of the statistic ifInErrors to be between 13000 
and 13500. You can monitor it in real time in this graph, and if the value goes beyond these limits, you can mon-
itor it for another time period and decide on an appropriate action.

The Current Statistic graph (also referred to as a Runtime chart) provides two advantages when you do real-time 
monitoring:

1. You can change the Data Collection interval

By default, the data collection interval shown in the graph is 15 seconds. You can specify the required polling 
interval in seconds. Decrease the value if very close monitoring of a statistic is needed. This helps you in ana-
lyzing the effect of changes in intervals on data collection. But every time you change the interval, follow 
these steps:

1.  Click the Stop button.
2.  Change the interval.
3. Click Restart. This helps you analyze the effect of change of time over data collection.
4. Change Graph type.

2. You can choose to view the data as a bar or line graph as you monitor the collected data. When small values 
are plotted, line graphs can be difficult to view. In such cases, you can immediately change to a bar graph.

Follow these steps to view Current Statistic Graph:

1. In the Configured Collection panel, select the Statistic for which you want to monitor in real time.
2. Select View -> Plot -> Current Statistic from the Panel-Specific Menu Bar. You will see the following fig-

ure.

FIGURE 5-4  Plotting Current Statistic
You can change the Polling Interval and Graph Type and see the results change.
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5.6  Threshold Notification

5.6.1  Overview
Performance monitoring involves the following concepts:

• Data is collected from agents of network devices and stored.
• The collected data is cross-checked with threshold values. If it exceeds the limits of the threshold values, a 

notification can be sent to the user indicating that network performance is degrading.

A threshold has the following:

• a value
• a type (Max, Min or Equal). 

For example, if type is set to Max, the Threshold is exceeded when the collected value goes above the thresh-
old value.

• a message that is to be generated when the threshold is exceeded.
• a value at which the threshold is reset

Thresholds are defined and associated with Statistics. A single Statistic can have many thresholds indicating a 
severity, such as Critical, Major, Minor, etc. Whenever data are collected for the statistic, it is cross-checked 
with the associated thresholds. If the collected value exceeds the thresholds, the threshold message is displayed 
as an Event in Fault Management.

Note: If multiple thresholds are associated with a Statistic, then the collected value will be checked 
with every threshold value. For every threshold value exceeded, its corresponding message 
will be displayed.

Caution: Creation of thresholds and its association with statistics is an Administrator task. For 
information on adding, modifying, and deleting thresholds, refer to the NMS 
Administration Guide.

5.6.2  Example
Assume a Statistic called Interface_in_octet for the switch named switch_vg3w. For efficient performance of the 
switch, the value of this statistic must be between 1300 and 1370. This means that you should have some notifi-
cation mechanism to inform you when the statistic value is not within this limit.

Define three thresholds for this statistic:

switch_vg3w-critical, switch_vg3w-major, and switch_vg3w-minor, as shown in the following table.

In short, if the Statistic value is 1350, the threshold switch_vg3w-major is exceeded. The message “Monitor the 
value; it might exceed critical threshold” will be generated. But if the statistic value goes below 1369, the thresh-
old will be reset and, again, data collected for the Statistic will be monitored.

TABLE 5-3  Threshold Example

Threshold 
Property Switch_vg3w-minor Switch_vg3w-major Switch_vg3w-critical

value 1320 1350 1371

type max max max

threshold 
message

Has entered violation stage Monitor the value; it might exceed 
critical threshold

Reached critical point. 
Immediate attention required.

reset value 1319 1349 1369
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5.6.3  Threshold Interactions
• The reset value plays an important role. Once a threshold is exceeded, until the collected value reaches the 

threshold's reset value, the threshold will be in that severity state itself. As soon as the value reaches the reset 
value, the threshold is reset until the threshold is exceeded again.

• If another threshold exists of a lower severity and if the collected data falls in its limits, that threshold will 
generate the message.

• If another threshold exists with higher severity, the higher severity threshold will take precedence and its 
message will be displayed. The threshold with lower severity loses its importance and will not be generated 
until the threshold with the higher severity reaches its reset value.

5.6.4  Viewing Thresholds on the Network Events Screen
Once the collected value for a Statistic exceeds threshold limits, a notification is sent to the Fault module of the 
AlliedView NMS. The fault module receives this notification and displays it on its Network Events panel.

Note: You can see the number of events that have been generated of different severity in the Alarm 
count by severity panel. Clicking on a number will display the associated alarms. The colors 
denote the severity (Red means Critical, Orange means Major, etc.).

5.7  Configuring Statistics
When setting up the AlliedView NMS, an Administrator will have to set up polling objects and polling filters so 
that the polled data (Statistics) are written to the AlliedView NMS database as polled data (Statistics) and can be 
extracted to provide real-time or historical reports. Once a AlliedView NMS system has been in service for a 
period of time, additional statistics may be needed. This can be done by modifying the appropriate polling object 
or creating a Statistic for specific node.

To add a statistic, select Edit ->Add Statistic from the Panel-Specific Menu Bar. The Modify Polled Data form 
appears.

Caution: Creation of statistics is an Administrator task. For information on adding, modifying, 
and deleting statistics, refer to the Administration Guide.
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6. Using the Network Inventory View

6.1  Overview
The Network Inventory view is used to view, search, modify, and delete network objects, such as networks, 
nodes, and interfaces. The Network Inventory view displays an inventory of all network entities, such as net-
works, nodes, ports, interfaces, routers, and links. Under the Network Inventory node in the NMS Tree are the 
following default subviews:

• Networks
• Nodes

• Profile Association
• Discovery Status

• Cards
• Ports
• iMG/RGs
• Interfaces
• Routers
• VLAN Interfaces
• EPSR Domains
• Physical Links

Each of these subviews narrows the network inventory to a specific type.

6.2  Network Inventory View
The Network Inventory maintains the properties of all MOs in a network. These MOs and their object properties 
are listed in the Network Inventory panel, as shown in the following figure.

FIGURE 6-1  Network Inventory Main View
Refer to 4.2.2 for information on navigating the view.  Refer to 4.2.2.1 for information on searching the view.
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When the Network Inventory view is displayed in the NMS Display Panel, items appear in the Panel-Specific 
Menu Bar that are specific to the Network Inventory views. Some of the items are specific to the type of object 
that is selected in the view, while others are common to all of the object types. The common items include:

• Edit - Provides editing functions for the view. Items include:
• Add Node - Adds a node.
• Add Network - Adds a network.
• Refresh Node - Updates the information on the selected node.
• Clear Alarms - Clears the alarms on the selected node.
• Delete Alarms - Deletes from the alarm database the alarms on the selected node.
• Search - Provides a search function for the view.
• Export Table Data - Provides an export function for all of the view data. The data may be exported to a 

file (in delimited tabular form) or to a Web browser. The data may also be filtered.
• Export Selected Rows - Provides an export function for selected rows in the view data.

• View - Displays additional information. Items include:
• Details - Displays detailed information on the selected object.
• Events - Opens a Network Events view in which the events associated with the selected object are dis-

played.
• Alarms - Opens an Alarms view in which the alarms associated with the selected object are displayed.
• Performance - Opens a Configured Collection view in which the statistics for the selected object are dis-

played.
• Refresh - Updates the information on the selected object.

These menu items also appear for all of the Network View subviews. The object-type-specific menus include:

• Network - For network objects
• Operations - For nodes and routers on the network
• Port - For customer ports
• Interface - For Interfaces (This includes the Ping menu item.)
• VLAN Interface - For VLAN interface objects
• Link - For physical link objects

The object-type-specific menus are described in the following sections.

6.3  The Network Inventory Subviews

6.3.1  Networks Subview
The Networks subview narrows the Network Inventory view to the discovered network objects. To access this 
view, click on the Networks node under Network Inventory in the NMS Tree. An example is shown in the fol-
lowing figure.
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FIGURE 6-2  Example Networks Subview
When the Networks subview is displayed in the NMS Display Panel or when a network object is selected in the 
Network Inventory view, the Network menu appears in the Panel-Specific Menu Bar, which is specific to net-
works objects. In the Networks subview, the menu appears when you select an item in the view. The items in the 
Network menu include:

• Managed Object Properties - Displays the Managed Object Properties form for the selected object.
• Delete Object and Traces - Deletes the selected network object. Refer to the NMS Administration Guide.
• Stop Discovery - Stops the discovery process in the selected network.
• UnManage/Manage - Marks the object as unmanaged if it is currently being managed, or as managed if the 

object is currently unmanaged. Managing an element means that you are setting the NMS to monitor its sta-
tus. Unmanaging an element means that you are stopping the NMS from monitoring the element.

Once a selected device is made managed (by selecting on the Manage menu item of either the table pop-up 
menu or the Network menu in the Panel-Specific Menu Bar), the icon displayed for the device will indicate 
the severity status of the device. The same icon will become gray in color when the selected device is made 
unmanaged by clicking the corresponding menu item. These menu items are also accessible from the object-
specific menus.

• Update Status - Updates the status information for the selected object. If any changes have been made to the 
object (such as clearing alarms), clicking this will update the row.

6.3.2  Nodes Subview
The Nodes subview narrows the Network Inventory view to the nodes on the network. To access this view, click 
on the Nodes node under Network Inventory in the NMS Tree. An example is shown in the following figure.

Note: It is possible to sort the Modes by Config Changed, so the user can see the latest nodes that 
have had their configurations changed and acknowledged by the Device Backup operation (for 
recurring backups).

FIGURE 6-3  Example Nodes Subview
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When the Nodes subview is displayed in the NMS Display Panel or when a node object is selected in the Net-
work Inventory view, the Operations menu appears in the Panel-Specific Menu Bar. In the Nodes subview, this 
menu appears when a node is selected in the view. 

Note: If multiple nodes are selected and the nodes are of different types (e.g. Rapier, 9400, etc.), 
the Object menu will appear instead of the Operations menu.

The items in the Operations menu include:

• View Chassis - Displays the current chassis view for the selected device. Refer to the NMS Administration 
Guide.

• View Device Log - Displays the Device Log Viewer.
• Provision - Provides provisioning functions for the selected device. Refer to the NMS Administration Guide 

for provisioning tasks.
• Network Services - Provides network link and VLAN functions for the selected device. Refer to the NMS 

Administration Guide.
• Alarms/Events - Displays the alarms or events, or a summary of the alarms and events for the selected 

device. Selecting this and then choosing Alarms or Events will bring up the Alarms or Events view. Selecting 
Summary will bring up the Events and Alerts display, which gives a summary of the Events and Alerts. 
Refer to the following figure. 

FIGURE 6-4  Summary Display for Events and Alarms (One Device)

• Performance - Brings up the Configured Collection window for the selected device.
• View Config Comparison - Brings up the Config Comparison Form. This is used for only non-i MAP 

devices, and must be text files.
• Discover Attached iMGS/RGs - If there are subtending iMGs/RGs, they are discoverd. This is used in a vari-

ety of provisioning scenarios in the AlliedView NMS Administration Guide.
• Display Switch FDB - For swith (layer 2) devices, lists the Port, MAC, and VLAN association, as well as the 

Status.
• Power over Ethernet Management - This is for a future release.
• Telnet To Device - Opens a Telnet session to the selected device.
• Browse Device - Brings up the HTML browser for the device.
• Rediscover Device - Re-discovers the device immediately.
• Managed Object Properties - Displays the Managed Object Properties form for the selected device.
• Delete Object and Traces - Deletes the selected object. Refer to the NMS Administration Guide.
• UnManage/Manage - Sets the device to unmanaged if it is currently managed, or managed if it is currently 

unmanaged.
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• Update Status - Updates the event and alarm information on the selected device.

6.3.3  Profile Association
This subview shows which profiles are associated with which devices. If the attributes are not in synch, a * 
appears next to the Profile name and should be reapplied. Refer to the AlliedView NMS Administration Guide 
for creating and applying Profiles.

6.3.4  Discovery Status
This subview provides a quick way to see when a device was last discovered and whether the device passed or 
failed. It also gives the date of when the configuration of the device was last changed.

Note: This subview also includes the RG devices.

6.3.5  Customer Cards Subview
The Customer Card subview narrows the Network Inventory view to the customer cards. To access this view, 
click on the Cards node under Network Inventory in the NMS Tree. An example is shown in the following figure.

FIGURE 6-5  Example Customer Cards Subview
When the Customer Cards subview is displayed in the NMS Display Panel or when a customer port is selected in 
the Network Inventory view, the Card menu appears in the Panel-Specific Menu Bar, which is specific to cus-
tomer ports. In the Customer Ports subview, this menu appears when you select a port. The items in the menu 
include:

• View/Modify Details  - Displays the Port Management form for the selected port, which is used to manage 
(display and modify) the attributes of the port.

• Remove Association with Profile - Removes the association, so changing an attribute does not show the card 
as being Out-of-Profile.

• Compare Card with Profile - If the card has a Profile, compares the attributes and highlights what is not the 
same. (If the card has no Profile, there is the error message Profile not found.)

• Audit CES Circuiits - For CES cards, brings up the Diagnostic Audit screen
• Alarms/Events - Brings up the submenu to view associated alarms, events, or a summary.
• Delete Object and Traces - Deletes the selected card. 

6.3.6  Customer Ports Subview
The Customer Ports subview narrows the Network Inventory view to the customer ports. To access this view, 
click on the Ports node under Network Inventory in the NMS Tree. An example is shown in the following figure.



The Network Inventory Subviews Customer Ports Subview

AlliedView NMS Installation Guide (Using the Network Inventory View)6-6

FIGURE 6-6  Example Customer Ports Subview
When the Customer Ports subview is displayed in the NMS Display Panel or when a customer port is selected in 
the Network Inventory view, the Port menu appears in the Panel-Specific Menu Bar, which is specific to cus-
tomer ports. In the Customer Ports subview, this menu appears when you select a port. The items in the menu 
include:

• View/Modify Details  - Displays the Port Management form for the selected port, which is used to manage 
(display and modify) the attributes of the port.

• Provision New Customer/Port - Brings up the appropriate form to provision this port. This form can be the 
Provision New Triple Play Customer Form or the Provision new DS1/E1 Port Form.

• De-provision Customer/Port - If the port has already been provisioned, this form appears. Refer the the 
NMS Administration Guide for details on this form.

Note: In the EE version, the previous two items are not available.

• Remove Association with Profile - If a profile has been created and associated with the port, this option 
removes that association. Note that this does not affect the profile. Refer to Section 6 of the AlliedView NMS 
Administration Guide for details on creating port profiles and associating them with ports.

• Compare Port with Profile - Compares the attributes of the port with its profile. A window then appears that 
lists where attributes do not match (or the message No Differences).

• Alarms/Events - Brings up the submenu to view associated alarms, events, or a summary.
• Delete Object and Traces - Deletes the selected port. 

The Port Management tool is used for the administration and maintenance of customer ports. The tool is 
accessed from the Customer Ports view by right-clicking a port in the view, and then selecting View/Modify 
Details from the pop-up menu. It can also be accessed by selecting Tools->Customer Management->View/
Modify Customer Ports from the Panel-Specific Menu Bar.

The three main tabbed forms are:

• Triple Play Service Management
• DS1
• E1

Viewing the Triple Play Service Management Port form shows the attributes for the associated interfaces:

• Ether-like
• ADSL
• SHDSL
• POTS
• EPON
• ONU
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• NTE8
• CES

These are explained in the following subsections.

Note: The Statistics tab and Log tag are common across these interfaces and show all statistics and 
logs for all ports in the Triple Play service.

6.3.6.1 Ether-Like Port Management

The display is a tabbed panel where each tab displays specific information on the Ethernet-like port. The tabs are 
as follows:

• Status - Displays general status
• Ether-Like Configuration - These have subtabs:

• General - The main configuration attributes for the port
• Port Thresholds - Displays the threshold settings for the RMON counters
• Device Data Collection - Configures the data collection configuration (intervals and buckets)
• IP Filters - Displays information on any IP filters that are applied to the selected port

• Statistics - Displays the results of the set-up that was done in the Configuration tab
• RMON Stats - Allows enabling/disabling of performance and fault statistics
• Graph Stats - Allows selecting and graphing of up to six statistics

• Port Log - Displays any log messages associated with the selected port

For information on using the Ether-like Port Management tool for port administration, refer to the AlliedView 
NMS Administration Guide.

6.3.6.2 ADSL Port Management

The display is a tabbed panel where each tab displays specific information on the ADSL port. The tabs are as fol-
lows:

• Status - Displays general status
• ADSL Configuration - These have subtabs:

• General - Displays general status and configuration information for the selected port.
• VCs/VLANs - Correlates the port to Virtual Channels (VCs) and then the VC to one or more (up to four) 

VLANs.
• PMON Thresholds - Allows thresholds to be set for the ATU-C and ATU-R statistics.
• Device Data Coll. - Configures buckets that will collect statistics and the interval at which they are filled
• IP Filters - Allows classifiers to be applied to the port.

• Statistics - These have subtabs:
• PMON Stats - Collects traffic statistics over a specified time period (called the interval).
• RMON Stats - Tracks packet flows and highlights errors as well as overflows of packets.
• Graph Stats - Makes graphs both in real-time and for statistics that have been collected.

• Port Log - Displays any log messages associated with the selected port

For information on using the ADSL Port Management tool for ADSL port administration, refer to the NMS 
Administration Guide.
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6.3.6.3 SHDSL Port Management

The display is a tabbed panel where each tab displays specific information on the SHSDL port. The tabs are as 
follows:

• Status - Displays general status
• SHDSL Configuration - These have subtabs:

• General - Displays general status and configuration information for the selected port
• VCs/VLANs - Correlates the port to Virtual Channels (VCs) and then the VC to one or more VLANs. 

Note that in this release only one VLAN can be associated with the VC.
• PMON Thresholds - 
• Device Data Collection - Configures buckets that will collect statistics and the interval at which they are 

filled
• IP Filters - Allows classifiers to be applied to the port

• Statistics
• PMON Stats - Collects traffic statistics over a specified time period (called the interval)
• RMON Stats - Tracks packet flows and highlights errors as well as overflows of packets.
• Graph Stats - Makes graphs both in real-time and for statistics that have been collected

• Port Log - Displays any log messages associated with the selected port

For information on using the SHDSL Port Management tool for port administration, refer to the NMS Adminis-
tration Guide.

6.3.6.4 POTS Port Management

The display is a tabbed panel where each tab displays specific information on the POTS24 port. The tabs are as 
follows:

• Status - Displays general status
• Voice Configuration

• POTS - The main attributes of the POTS port
• Statistics

• POTS Stats - Lists the RTP statistics. For an explanation, refer to the iMAP Administration Guide.

• Graph Stats- Makes a graph of selected statistics and displays them with varying attributes
• Diagnostics

• POTS - allows the user to run a set of diagnostics on the port interface
• Port Log - Lists all the port-related management logs that have been generated.

For information on using the POTS Port Management tool for port administration, refer to the AlliedView NMS 
Administration Guide.

6.3.6.5 DS1/E1 Port Management

The display is a tabbed panel where each tab displays specific information on the DS1/E1 port. The tabs are as 
follows:

Note: The form is the same for dual endpoints, but the panels/fields are changed to accommodate 
two rather than one DS1/E1 port.

• Status - Displays general status
• DS1/E1 Port - Lists the status and main attributes of the port.
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• PSPAN - Lists the attributes for the PSPAN. For dual endpoints, the initially selected port is what is on the 
left panel of the form.

• PMON Statistics - Enables for viewing the port and PSPAN statistics.
• Stats Graph - Makes a graph of selected statistics and displays them with varying attributes. For dual end-

points, the statistics are suffixed with an -A and -Z.
• Port Thresholds - Sets the DS1 and PSPAN thresholds that will activate a log and event.
• Port Log - Lists all the port-related management logs that have been generated

For information on using the DS1/E1 Port Management tool for port administration, refer to the AlliedView NMS 
Administration Guide.

6.3.7  iMG/RGs Subview
This subview shows the iMGs/RGs and shows its main attributes (such as Customer ID) as well as profile associ-
ateionj. For details on this, refer to the AlliedView NMS Administration Guide.

6.3.8  Interfaces Subview
The Interfaces subview narrows the Network Inventory view to the network interfaces. To access this view, click 
on the Interfaces node under Network Inventory in the NMS Tree. An example is shown in the following figure.

FIGURE 6-7  Example Interfaces Subview
When the Interfaces subview is displayed in the NMS Display Panel or when a network interface object is 
selected in the Network Inventory view, the Interface menu appears in the Panel-Specific Menu Bar, which is 
specific to network interfaces. In the Interfaces subview, this menu appears when you select an interface in the 
view. This menu provides various functions in the interface. The items include:

• InterfaceMonitor - Provides a ping function, which allows you to ping the selected interface. Refer to the fol-
lowing figure. Selecting this item brings up the Status Message window, which contains the ping results. 
Refer to the following figure.
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FIGURE 6-8  Ping Result Display

• Managed Object Properties - Displays the Managed Object Properties form for the selected interface. Refer 
to Section 9.

• Delete Object and Traces - Deletes the selected interface. Refer to the NMS Administration Guide.
• UnManage/Manage - Marks the selected interface as unmanaged if it currently is being managed, or as 

managed if it is currently unmanaged.
• Update Status - Updates the status information for the selected interface.

6.3.9  Routers Subview
The Routers subview narrows the Network Inventory view to the routers on the network. To access this view, 
click on the Routers node under Network Inventory in the NMS Tree. An example is shown in the following fig-
ure.

FIGURE 6-9  Example Routers Subview
When the Routers subview is displayed in the NMS Display Panel or when a router object is selected in the Net-
work Inventory view, the Operations menu appears in the Panel-Specific Menu Bar. In the Routers subview, this 
menu appears when you select a router in the view. This is the same Operations menu that appears in the Nodes 
subview. Refer to 6.3.2.

6.3.10  VLAN Interfaces Subview
The VLAN Interfaces subview narrows the Network Inventory view to the VLAN interfaces on the network. To 
access this view, click on the VLAN Interfaces node under Network Inventory in the NMS Tree. An example is 
shown in the following figure.
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FIGURE 6-10  Example VLAN Interfaces Subview
When the VLAN Interfaces subview is displayed in the NMS Display Panel or when a VLAN interface is 
selected in the Network Inventory view, the VLAN Interfaces menu appears in the Panel-Specific Menu Bar, 
which is specific to VLAN interfaces. In the VLAN Interfaces subview, the menu appears when an interface is 
selected in the view. This menu provides various functions on VLAN interfaces. The menu items include:

• Configure VLAN Interface - Provides functions for configuring the selected VLAN interface. Refer to the 
NMS Administration Guide for more information on configuring VLAN interfaces.

• Extend Vlan - Provides functions for extending a VLAN. Refer to the NMS Administration Guide for more 
information on extending VLANs.

• Alarms/Events - Provides alarm and event information for the selected VLAN interface.
• Managed Object Properties - Displays the Managed Object Properties form for the selected VLAN interface. 

Refer to Section 9.
• Delete Object and Traces - Deletes the selected VLAN interface. Refer to the NMS Administration Guide.
• UnManage/Manage - Marks the selected VLAN interface as unmanaged if it currently is being managed, or 

as managed if it is currently unmanaged.
• Update Status - Updates the status information on the selected VLAN interface.

6.3.11  EPSR Domains Subview
The EPSR Domains Subview is a way to see in list format all of the domains that have been defined and the 
devices/control VLANs that are part of that domain. Refer to the following figure.

Note: Refer to the AlliedView NMS Administration Guide for how to use this table to understand and 
troubleshoot the EPSR configuration.

FIGURE 6-11  EPSR Domains Subview

6.3.12  Physical Links Subview
The Physical Links subview narrows the Network Inventory view to the physical links on the network. To access 
this view, click on the Physical Links node under Network Inventory in the NMS Tree. An example is shown in 
the following figure.
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FIGURE 6-12  Example Physical Links Subview
When the Physical Links subview is displayed in the NMS Display Panel or when a physical link object is 
selected in the Network Inventory view, the Link menu appears in the Panel-Specific Menu Bar, which is spe-
cific to physical links. In the Physical Links subview, the menu appears when a link is selected in the view. This 
menu provides various functions on physical links. The menu items include:

• Link Operations - This brings up the Layer 2 form that allows the user to add or delete physical links. Refer 
to Section 6 of the AlliedView NMS Administration Guide on how to use this form.

• Managed Object Properties - Displays the Managed Object Properties form for the selected link. Refer to 
Section 9.

• Alarms/Events - Provides alarm and event information for the selected link.
• UnManage/Manage - Marks the selected link as unmanaged if it currently is being managed, or as managed 

if it is currently unmanaged
• Update Status - Updates the status information on the selected link.

6.4  Creating Custom Views
Refer to 8.4.2 a list of properties that are commonly used to create meaningful custom views.

6.5  Adding a Node / Network (without Discovery 
Configurator)
The user can add networks and nodes in the Network Inventory screen as Managed Objects (not modifying the 
seed.file) and this will take effect immediately. The menu choice:

• Network Inventory / Edit -> Add Network
• Network Inventory / Edit -> Add Node

brings up the dialog to add a network or node.

Caution: Adding a Network is an Administrator Task and is covered in the NMS Administration 
Guide.

6.6  Adding and Refreshing a Node
Select Edit -> Add Node from the Panel-Specific Menu Bar to add a new node to the existing object list in the 
Network Inventory panel. 

Caution: Adding a Node is an Administrator Task and is covered in the NMS Administration 
Guide.
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7. Using the HTML Interface

7.1  Overview
Use the following table to locate the most common tasks you wish to perform. If you are using NMS, use the 
screen name or the form name as well to locate the relevant section. 

7.2  Starting Up

7.2.1  Overview
You can view the HTML Interface through any Web browser, such as Mozilla or Internet Explorer. Just open the 
Web browser and type the machine name and port number of the server in the address bar, as shown below:

Input: http://<machine name>:<port number>

For example:

Input: http://nms-server:9090

In the above example, nms-server is the name of the machine in which the server is running, and 9090 is the port 
number on which the server is listening. 

Note: The HTML AlliedView NMS interface does not have all the features and functions of the Java 
interface, and is therefore more suitable for query and report functions that can be accessed 
over any compatible browser. There are administrative tasks that can be done, but these 
should be done by authorized personnel only.

TABLE 7-1  Task List for HTML Interface

Task Screen / Form Name (if Applicable) Section/Notes

Change Password Not applicable (n/a) (7.2.3)

Review Screen n/a (7.3.2)

Network Map Tasks Overview (7.4.1)

Manage Alarms Alarms Review Screen (7.5.1)

Manage Network Events Network Events

Event Details

Review Screen (7.5.4)

View Details (7.5.6)

Managing Network 
Inventory

Network Inventory

Object Details

Review Screen (7.7.1)

(7.7.2)

Managing Nodes SNMP MIB Manager (7.8.1)

Setting up Users n/a (7.9)

Logging Out Main screen, logout option Note: If you log out by closing the 
browser, it requires 30 minutes for the 
client session to time out. Use the 
Logout option.
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7.2.2  Setting Web Browser Caching
The web browser caching function should be set to always check for updates from the server before retrieving 
content from cache.

For example, with IE, use Tools -> Internet Options and click on the General tab. Under Temporary Internet 
files, select Settings...

In the Settings window, under Check for newer versions of stored pages:, select the button Every visit to the 
page.

7.2.3  Modifying the User Account and Password
There are several situations in which the user account status or password must be modified. These include:

• Setting up user names and passwords for the first time.
• The password has expired - If you try to log in to the NMS Server when your password has expired, you get 

a message stating that your password has expired.
• The user account has expired - If you try to log in to the AlliedView NMS Server when your user name has 

expired, you get the message:
The User Account has EXPIRED. Please contact the Administrator.

You will have to contact your NMS Administrator to have your account renewed.

• The user account has been disabled - If you try to log in to the AlliedView NMS Server when your user 
account is disabled, you get the message:

The User Account has been DISABLED. Please contact the Administrator.

You will have to contact your NMS Administrator to have your account re-enabled.

Note: Defining users, user profiles, and user groups from the html interface is explained in the 
AlliedView NMS Administration Guide.

7.3  Common Interface Components

7.3.1  Overview
After you have logged into the browser HTML client by giving a valid user name and password, the screen dis-
plays the following three frames: the Tree frame, Display frame, and the Alarm Count frame. An example screen 
is shown in Figure 7-1. This section explains the various setups available initially on the screen.

7.3.2  Initial Screen Layout (Function Tabs)
The initial screen has the following components: 

• At the top of the html frame is a set of function tabs. Each tab controls what appears in the Tree Frame and 
Display Frame. Directly underneath the tabs is a reminder of where the user is in the tab hierarchy.

• The Tree Frame is on the left-hand side of the screen. It has the tree that displays the different nodes for the 
chosen function tab.

• The Alarm Count Frame is on the left-bottom corner of the screen. It shows the categories of alarms, based 
on severity. Clicking on any number will list the associated alarms in the Alarm view. This frame appears 
regardless of which tab has been selected. The Alarm view is explained in 7.5.

• The Display Frame is on the right side of the screen. It shows the different nodes or tables for the node cho-
sen in the Tree frame.

Refer to the following figure for an example initial screen and what icons mean.
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FIGURE 7-1  Initial Screen for html Interface

7.3.3  Search Function
To search for a particular device, the user can input a device attribute in the Find Device field, and then select 
GO. The Adv. Search brings up the Network Inventory View (explained later) with a Search Criteria options.

7.3.4  Maps and Symbols
For all the map types, the user has the following options:

• Add Map - This allows the user to add a map type to the Network Map tree. The newly created map will 
appear as a node of where the user is currently at; for example if the user is at the Physical Network Node and 
creates a map, the new map will appear as a node (leaf) under the Physical Network node. In the example 
below, the user has created a map called 33_1_only to show only a single device.
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FIGURE 7-2  Creating a Map under Physical Networks

FIGURE 7-3  Map Created Successfully

• Configure Map - This allows the user to change the attributes of the create Map
• Delete Map - This deletes the Map the user is currently displaying

Note: Do not delete a Map that is included by default, since the default Maps have information that is 
usually important to assess the network.

• Add Symbol - Allows the user to add a symbol (image) to the map. This symbol can then be given attributes 
so that network changes can be highlighted using the image. NEED INFO - can give fault attributes to sym-
bol?
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7.3.5  Performance Monitoring
In previous releases, there was a separate tab for a Performance Monitoring frame. This has changed; the proper-
ties of a node in the Network Inventory view now include the appropriate graphs of statistics, and this is 
explained in the Network Inventory section, 7.7.

7.4  Network Maps

7.4.1  Overview
The Network Maps Tree has the following default nodes:

• Physical Network
• Routers
• Failed Nodes
• IP Network (usually highlighted when accessing the html interface for the first time)
• VLAN Network

The main map tasks are as follows, and explained in the next subsections:

• Drilling down the networks - The method to reach the exact, desired map element. This makes the monitoring 
easier. 

• Managed properties - The method to get the details of a particular map symbol. It shows the editable proper-
ties and provides information on the allowable values for the properties.

• Query and Control the Device - From the map symbol the user can manage/unmanage the node and view 
events and alarms (which changes the function tab view). This is explained in detail below.

All icons accessed from the Network Maps tree have three buttons to perform these tasks. The following table 
explains these buttons.

TABLE 7-2  Actions available from Network Map and Device Icons

Icon Icon Buttons Action

Clicking on this brings up the managed objects form, 
explained in 7.4.2.

A state button, brings up the Fault Management View

Brings up a smart (custom) view if one has been created.

Clicking on this brings up the managed objects form, 
explained in 7.4.2.

A state button, brings up the Fault Management View



Network Maps Managed Properties Form

AlliedView NMS Installation Guide (Using the HTML Interface)7-6

7.4.2  Managed Properties Form
The necessary details of map symbols are available in a form called the Properties form. Refer to the following 
figure.

FIGURE 7-4  Map Properties Form (Network)

The properties are grouped as follows: 

TABLE 7-3  Properties Form for Network Map Objects (Editable fields are in bold)

Type Area Detail

General General Information Device Type

Status

Is Managed - the result of Manage / Unmanage

Display Name - what appears for the object

Identification Details IP Address

Netmask

Is DHCP Enabled?
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Some of the above properties are kept editable so that you can make changes as per your requirements. For exam-
ple, the icon displayed for the map symbol can be changed to any other image by changing the icon name under 
General Properties.

7.4.3  Physical Network
The physical network lists all the device icons as described in Table 7-2, and is shown in the following figure.

Note: As with the non-html interface, the RGs are not included in the Physical Network view; these 
are shown when the user chooses the relevant IP network.

Monitoring Status Monitoring Details Is Status Polling Enabled - whether the object status polling has been 
enabled for the object

Tester for Status Polling - how the device is polled

Last Status Update Time 

Last Status Change Time 

User Class Name

Failure Threshold - number of failed polls before alert created

Failure Count - how many times polling has failed

Status Polling Interval - 

Discovery Discovery Setting Discovery Status

Start / Resume Discovery

Details Nodes & Interface Details List of Nodes

List of Interfaces

Sub Networks

Sub Netmasks

Parent Netmask

Parent Network

Utilization Currently Unused CPU

Memory

Disk 

Alarms Status

Failure Object

Alarm Details

Date / Time

Tabs Symbol Properties

Manage/Unmanage

View Events

View Alarms

TABLE 7-3  Properties Form for Network Map Objects (Editable fields are in bold)

Type Area Detail
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FIGURE 7-5  Physical Network - All Devices (Except iMG/RGs)
Clicking on the icon will bring up the Managed Object Properties Form, as shown in the following figure and 
table.
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FIGURE 7-6  Managed Object Properties Form for a Device
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TABLE 7-4  Properties Form for Device Map Objects (Editable fields are in bold)

Type Area Detail

General General Information Device Type

Status

Is Managed - the result of Manage / Unmanage

Display Name - what appears for the object

Identification Details IP Address

Netmask

Is DHCP Enabled?

Monitoring Status Monitoring Details Is Status Polling Enabled - whether the object status polling has been 
enabled for the object

Tester for Status Polling - how the device is polled

Last Status Update Time 

Last Status Change Time 

User Class Name

Failure Threshold - number of failed polls before alert created

Failure Count - how many times polling has failed

Status Polling Interval - 

Interfaces & Par-
ent Networks

List of Interfaces

Parent Network

Parent Object

List of Groups

Is Container?

Children Keys

Is Group?

Protocol Config-
uration Settings 

SNMP Port

Base MIBs

Read Community

Write Community

SNMP Version

SysOID

System Description

Host Netmask

Interfaces Index

Description

Speed

Status

MAC

Utilization CPU

Memory

Disk 

Other Graphs Performance Monitoring
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7.4.4  Other Network Maps
• Routers - These show only the devices configured as routers
• Failed Nodes - These show only those devices that have an Alarm with a severity
• VLAN Network - This shows the devices associated with each VLAN interface for the network chosen. 

Therefore, there will usually be a VLAN id repeated for the different devices it is configured on. Refer to the 
following figure.

FIGURE 7-7  VLAN Interfaces for the Selected Network

7.5  Fault Management (Events and Alarms)

7.5.1  Overview of Alarms
The devices connected with the NMS create various events. These events are converted (parsed) into alarms 
based on their significance. By default, the alarms are classified into five categories: Critical, Major, Minor, 
Warning, and Clear. This classification is based on the severity of the fault. 

When you click the Alarms node in the Fault Management tree, the Alarms page is displayed, as shown in Figure 
7-8. By default, it shows the following columns:

• Status - These are color-coded to indicate criticality in the same manner as events:
• Red - Critical
• Orange - Major
• Yellow - Minor
• Blue - Warning
• Green - Clear

•  Failure Object - Clicking on the link brings up the Alarm Details form.
• Actions - Using the icons, the user can acknowledge the alarm and annotate the alarm for future reference.
• Alarm Details - The text for the alarm.
• Date/Time - The date and time the alarm occurred.
• Alarm Group - ALarms can be assigned to a group when a parser is created. Groups are not used in the base 

NMS and are not shown in the HTML interface.
• Owner - The name of the login filled in the Alarm Details form.
• System Location - This is the value that was filled in the Managed Object Properties form.
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The alarms are grouped by default for sets of 25 alarms in a page. This can be changed using the pull-down.

By clicking on a column header name, you can sort the list by the selected column information. When you click 
the name, an arrow shows the direction of the sort (up descending, down ascending). Each time you click the 
name, the sort direction toggles.

The following figure shows the alarm view.

FIGURE 7-8  Alarm View for HTML Interface

7.5.2  Alarm View Options
The following options are available from the Alarm View. (These options are also used in the Events and System 
Logs Events view.)

7.5.2.1 Add Alarm Child View

This options allows the creation of a filtered view so that only certain alarms are shown. The following figure 
shows the Custom View Form.
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FIGURE 7-9  Creating an Alarm Child View
The name (Child view name) must be unique. For the criteria, refer to 8.4.11

When the child view is created, it appears as a subnode to the Alarms node (where it appears cannot be changed).

The following table lists the properties.   

TABLE 7-5  Alarm Custom View Properties

Property Description

Custom View 
Name

The name of the custom view. This is a mandatory parameter. If you try to submit the form without 
mentioning the name, the message “No Custom View is mentioned” is displayed.

Severity The severity of the event object, which indicates the criticality of the event. You can choose one of the 
severity (All, Major, Minor, Warning, Clear, Info, or Unknown) from the list box. 

Previous 
Severity

The matching criteria based on the previous severity of the alarm.

Owner The name of the owner with whom the alarm is associated. 

Group A group value based on which alarms are grouped in the client. 

Message An Alarm message for the particular custom view. 

Category The name of the category to which the alarm belongs. This could be used for better organization of 
alarms. 

Failure 
Object

Information about the specific entity within the source of the event, which is primarily responsible for 
the occurrence of this event. The name of the failure object which caused the event to occur can be 
given in this field. 
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7.5.2.2 Edit View Criteria

This option allows the user to modify the criteria for the selected view. The criteria is the same as when creating 
a custom view.

7.5.2.3 Search

The search option allows the user to further refine a view by listing columns and the criteria the column must 
match. The More button allows more that one column to be used, and the Match radio buttons allow an OR (any) 
or AND (all) criteria to be set. Refer to the following figure, which shows a search based on the severity of 
Clear.

Source Information about the source of the alarm. Alarms matching a particular source can be filtered out 
using this criterion. 

From Date/
Time 
(Modified 
Time)

A from date and time for filtering out alarms modified from a particular date/time onward. 

To Date/Time 
(Modified 
Time)

A to date and time for filtering out alarms modified before a particular date/time. 

From Date/
Time (Create 
Time)

A from date and time for filtering out alarms generated from a particular date/time onward.

To Date/Time 
(Create Time)

A to date and time for filtering out alarms generated before a particular date/time. 

GroupViewM
ode

The mode of grouping. It could be max, latest, or none. If max is selected, then alarms are grouped with 
the alarms of maximum criticality being shown at the top of the group. If latest is selected, then alarms 
are grouped with the latest alarm in a group shown at the top of the group. If GroupViewMode selected 
is none, then the alarms are not grouped. 

Alarm Age An age for filtering alarms based on the age of alarms. Age of an alarm denotes the time lapsed since 
the occurrence of the alarm in the NMS system. 

Refresh 
Period 
(in Min.)

The frequency at which the latest alarms should be updated in the alarm browser from the database. 

TABLE 7-5  Alarm Custom View Properties

Property Description



Alarm View Options Fault Management (Events and Alarms)

7-15AlliedView NMS Installation Guide (Using the HTML Interface)

FIGURE 7-10  Advanced Search for a View
For the text values for criteria, refer to 8.3.3.

7.5.2.4 Customize Columns

This options allows the user to control which columns are displayed in a view. The user moves (using the right 
and left arrows) the columns to be displayed. To control the order, select one of the Displayed columns and use 
the up and down arrows to control where it is placed. Refer to the following figure.

7.5.2.5 Operations 

After checking the tic box for one or more alarms the user can choose one of the following actions:

• View Events - displays the list of events for the object that had created the alarm.
• Clear - This will set the status to Clear and show what the previous status was.
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• Delete - Deletes the alarm (after a confirmation window).
• Pickup - Allows a user to be associated with an alarm.
• Unpick - Disassociates a user with an alarm.

Note: If any of the parameter fields (except Custom View Name) is left blank, the default value all is 
assigned.

7.5.3  Alarm Properties (Details)
After clicking on the link for the Failure Object, the user will see the Network Inventory Window with the MO 
Objects properties form. The properties of this form are explained in 

The user has the following options:

• Unmanage
• View Events
• View Alarms

If the object is a Network, a list of alarms is listed at the bottom of the window, and the user can query the indi-
vidual failure object. For details on the Network Inventory frame, refer to 7.7.



Overview of Network Events Fault Management (Events and Alarms)

7-17AlliedView NMS Installation Guide (Using the HTML Interface)

FIGURE 7-11  Alarm Details Form

7.5.4  Overview of Network Events
Events are simply the complete sets of notifications from the network. They are basically of two types: External 
and Internal events. External events are actions or notifications that are external to the NMS (for example, Traps, 
which are basic notifications from the SNMP agents or management applications). Internal events are notifica-
tions that are generated by the NMS during data polling and status polling (for example, threshold events and sta-
tus events). The following figure shows the default Event view.
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FIGURE 7-12  Network Events View for html Interface

7.5.5  Event View Options
The options for the event view are the same as the alarm view, explained in 7.5.2.

7.5.6  Viewing Event Details
The Event Details page is accessed by choosing the Source field, and has the same fields as the Alarm view, 
explained in 7.5.3.

7.5.7  System Log Events View
The relationship between the components that provide system logs is as follows:

• The filtering of logs produced by the device that are sent to the NMS is controlled by applying log filters. 
This is described in the AlliedView NMS Administration Guide.

• The logs that are displayed in the System Log Events tree node (Under Network Events) are controlled 
through configuring the system log server.

At the html GUI, the initial System Log Events view lists the logs that the NMS has been set up to filter and dis-
play. Refer to the following figure.
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FIGURE 7-13  Initial System Log Events View
The properties of the System Log Events are shown by clicking on the Source field, and are almost the same as 
the Alarm properties as explained in 7.5.3.

Refer to the following figure.
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FIGURE 7-14  SYSLOG Event Properties

7.6  Performance

7.6.1  Overview
To control statistics that are collected and reported the user can select a host and then add, modify, or delete a 
statistic. Refer to the following figure.
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FIGURE 7-15  Controlling Performance Data

7.7  Network Inventory

7.7.1  Overview
The Network Inventory, sometimes referred to as the topology database, is the repository of all of the data for all 
of the objects managed by the AlliedView NMS. A network, therefore, is an object that contains one or more 
nodes, each of which in turn contains one or more interfaces. The properties of all these objects are maintained in 
the Network Inventory. These are shown under the Network Inventory node in the tree.

The inventory views for all of these objects are based on a table view, where each row pertains to a managed 
object. Clicking on the column name sorts the table data according to the information in the selected (clicked) 
column. 

The following figures and tables show each object view, the icons that are used, and descriptions of the table col-
umns.
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FIGURE 7-16  Network Inventory View (HTML)

TABLE 7-6  Network View Columns

Column Meaning

Name The object name. The icon to the left of the name ( ) is the icon for a network object, which is the object 
type, where the icon color depicts current criticality state of the object.

Left-clicking the name brings up the Object Details form.

The arrow to the right of the name ( ) brings up a menu of appropriate actions (Manage/Unmanage). 
Left-clicking the arrow brings up the menu.

IPAddress The object IP address. Every object has a unique IP address.

Status The alert status.

Type One of the types listed in the Network Inventory tree

NetMask The object subnetwork or network category.
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FIGURE 7-17  Node View (HTML)

TABLE 7-7  Node View Columns

Column Meaning

Name

The object name. The icon to the left of the name ( ) is the icon for a network node object, 
which is the object type, where the icon color depicts current criticality state of the object.

Left-clicking the name brings up the Object Details form.

The arrow to the right of the name ( ) brings up a menu of appropriate actions (Manage/
Unmanage). Left-clicking the arrow brings up the menu.

SysLocation The MO property to identify a location

Type The device type (the type of AT device).

Release The software release the device is running.

Serial Number The unique name given by AT to identify the device.

IPAddress The object IP address.

NetMask The object subnetwork or network category.

Status The alert status.

Last Status Time 
Change

The date and time at which the object information was last updated.

webcli-
ent.topo.con-
figChange
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FIGURE 7-18  Profile Association

TABLE 7-8  Profile View Columns

Column Meaning

Name

The object name. The icon to the left of the name (such as ) is the icon for a network node 
object, which is the object type, where the icon color depicts current criticality state of the object.

Left-clicking the name brings up the Object Details form.

The arrow to the right of the name ( ) brings up a menu of appropriate actions (Manage/
Unmanage). Left-clicking the arrow brings up the menu.

Type The device type (the type of AT device).

IPAddress The object IP address.

Profile The associated Profile
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FIGURE 7-19  Card Inventory View

TABLE 7-9  Cards View Columns

Column Meaning

Device The device that contains the card

Slot The slot number of the card

Type The type of card.

IP Address For cards that require an IP interface (POTS24, CES8)

CLEI Code For cards that have a CLEI code
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FIGURE 7-20  Customer Ports View

Note: For details on the iMG/RG view, refer to the AlliedView NMS Administration Guide.

TABLE 7-10  Customer Ports View Columns

Column Meaning

Device The node name

Port The port number on the card. Typically, the port number is the customer’s telephone number

Type The interface for the port

Customer ID An ID number that uniquely identifies the port.

Status The current status of the port.

Profile The profile the port has been associated with. If there is an *, the data on the port and the associated 
profile do not match.

ADSL IfIndex Index number created for the ADSL port

ifIndex Index number created for the ethernet port
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FIGURE 7-21  Interface Inventory View (HTML)

TABLE 7-11  Interface View Columns

Column Meaning

Name The object name. The icon to the left of the name ( ) is the icon for an interface object, which is the 
object type, where the icon color depicts current criticality state of the object.

Left-clicking the name brings up the Object Details form.

Type The object type (interface).

IPAddress The object IP address.

NetMask The object subnetwork or network category.

IsSNMP The state of SNMP in the device (enabled or disabled).

Status The alert status.

Last Status 
Time Change

The date and time at which the object information was last updated.
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FIGURE 7-22  Routers Inventory View (html)

FIGURE 7-23  VLAN Interfaces View (html)

TABLE 7-12  Routers View Columns

Column Meaning

Name
The object name. The icon to the left of the name ( ) is the icon for a router object, which 
is the object type, where the icon color depicts current criticality state of the object.

Left-clicking the name brings up the Object Details form.

The arrow to the right of the name ( ) brings up a menu of appropriate actions (Manage/
Unmanage). Left-clicking the arrow brings up the menu.

Type The object type (AT device).

IPAddress The object IP address.

NetMask The object subnetwork or network category.

Version The version of SNMP (v1 or v2) in the object.

System Descr The detailed name of the device and software load running.

Status The alert status.

Last Status Time 
Change

The date and time at which the object information was last updated.
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FIGURE 7-24  EPSR Domain View

TABLE 7-13  VLAN Interface View Columns

Column Meaning

Display Name Matches the name given for the associated VLAN

Name
The object name. The icon to the left of the name ( ) is the icon for an interface object (VLAN 
interface, in this case), which is the object type, where the icon color depicts current criticality state of 
the object.

Left-clicking the name brings up the Object Details form.

VLAN Type

ID The object (interface) ID.

Type The object type (AT device).

IPAddress The object IP address.

NetMask The object subnetwork or network category.

VID The version of SNMP (v1 or v2).

Status The object status.

UnTagged 
Ports

The ports on the VLAN interface object that are untagged.

Tagged Ports The ports on the VLAN interface object that are tagged.

Device The device on which the VLAN IF resides

Network Vlan The name of the VLAN if crosses mulitple devices.

Forwarding 
Mode

For the UFO VLAN interface, the type of Forwarding used. (Standard VLANs do not have Forward-
ing configured.)

Node Type Whether the Node is a Primary Upstream Node (into the upstream network), Secondary Upstream 
Node, or Non-Upstream

Pri UP Node 
Status

The status of the Primary Upstream Node (should be active)

Sec UP Node 
Status

The status of the Secondary Upstream Node (if configured, should be standby)
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FIGURE 7-25  Physical Links View

TABLE 7-14  EPSR Domain View Columns

Column Meaning

Display Name Matches the name given for the associated VLAN

Name The domain name that applies to this specific Network VLAN and all of its associated nodes.

Domain State The overall state of the EPSR domain. LINK DOWN means one (or more) of the data VLANs has 
been broken.

Type Whether the Domain is a Master or Transit

Ctrl VID The VID of the network VLAN that is being used to create the protection ring

Pri Ifc The interface for the associated VLAN with a state of Primary

PI State The state of the Primary interface (BLOCKED or FORWARDING)

Sce Ifc The interface for the associated VLAN with a state of Secondary

SI State The state of the Secondary interface. (BLOCKED or FORWARDING

Status The overall state of the domain (whether it is ENABLED or DISABLED)
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7.7.2  Network Inventory View Options
The options from Network Views (Add Child View, Edit View Criteria, etc.) are similar to other views. Refer to 
7.5.2 for details. Also the options for individual objects, once selected using the tic box, are similar to other 
views.

The necessary details of network objects are available in a form called the Properties form. The properties of an 
object are displayed by clicking on the underlined value for a column, usually Name. Once the properties form is 
displayed, Expand lists all properties. Refer to the following example figure for Network Objects.

Note: Cards, Ports and EPSR objects do not have a Details form.

When editable fields have been changed, the Update Object button applies these changes so that the AlliedView NMS 
database will register these the next time this object is discovered. (The user can go up to the objects view level, check the tic 
box, and perform a Start Discovery if desired.)

TABLE 7-15  Physical Links View Columns

Column Meaning

Display Name

Name The name supplied when the link was created (optional) The icon to the left of the name (such as 

) is the icon for a link object, which is the object type, where the icon color depicts current 
criticality state of the object.

Left-clicking the name brings up the Object Details form

Source Device The source node name

Source Port The port on the source device to which the link is attached

Dest. Device The destination node name

Dest. Port The destination port

Status The alert status
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FIGURE 7-26  Object Details Form for Network Object (html)
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TABLE 7-16  Properties Form for Network Objects

Type Area Detail

General

(All objects)

General Information Device Type

Status

Is Managed

Display Name

Identification 
Details

IP Address

Netmask

Is DHCP Enabled?

Monitoring

(All objects)

Status Monitoring 
Details

Is Status Polling Enabled

Tester for Status Polling 

Last Status Update Time 

Last Status Change Time 

User Class Name

Failure Threshold

Failure Count

Status Polling Interval

Discovery

(Network 
objects only)

Discovery Status

Start / Resume Discovery

Network Ele-
ments

(Network 
objects only)

Nodes & Interface 
Details

List of Nodes

List of Interfaces

Sub Networks

Sub Netmask

Parent Netmask

Parent Network

 Relationship

(All objects 
except net-
works)

Interfaces & Parent 
Networks

List of Interfaces

Parent Networks

Logical & Hierarchi-
cal Relationship 
Details

Parent Object 

List of Groups 

Children keys

View Details
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7.8  Working with SNMP Tools (MIB Manager)

7.8.1  Overview
The MIB Browser is displayed by selecting the SNMP Tools tab from the HTML menu, as shown in the follow-
ing figure. 

FIGURE 7-27  MIB Browser (HTML)
The functionality of HTML UI MIB Browser is similar to that of the Java UI MIB Browser. The difference is 
that MIB Browser of the Java UI has some more advanced features in addition to the features found in HTML 
UI. 

The HTML UI MIB Browser allows “GET”, “GETNEXT”, “GETBULK”, and “SET” SNMP requests to a 
particular variable in the MIB of an SNMP managed device. It also allows table viewing. Apart from these fea-
tures, the UI of the HTML UI MIB Browse represents and differentiates the various objects under the MIB with 
unique icons. In addition, the selected node under the MIB is highlighted with specific colors for easy identifica-
tion as shown in Figure 7-27.

The left-side frame is the MIB tree, in which the selected MIB file is shown, and the right-side frame is for set-
ting the options and for the result display. The right frame includes fields for: 

Protocol Setting 
(All objects 
except net-
works and links)

Protocol Configura-
tion Settings

SNMP Port - 

Base MIBs

Read Community

Write Community 

SNMP Version

Interface Physical Media

Physical Address

Interface Speed

Interface Description

SNMP 

(All objects 
except net-
works, links, 
and VLANs)

SNMP Details System Object Identifier (SysOID) 

System Description

Host Netmask

TABLE 7-16  Properties Form for Network Objects

Type Area Detail
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• the current Node Object ID that's being operated upon the current MIB module 
• the SNMP agent name or address (Host) 
• the community name 
• a text field to enter the value for the set operation 
• a Write Community value, which is used for a set request 
• a drop-down box that shows the currently loaded MIBs 
• a text area to view query results 

TRAP definitions and textual conventions for a specific MIB can be viewed by choosing the TRAPS node or the 
TEXTUAL CONVENTIONS node from the tree-view of MIB Browser.

The operations allowed with the HTML UI MIB Browser are available through the various icons in the toolbar at 
the top of the frame, which are shown in the following table.

The select button, in the right-side frame, is used to select the MIB to be displayed in the tree-view of HTML Client. 
Apart from these, there are text fields for displaying Syntax, Access, Status, Index, and MIB Node Description, which give a 
brief description of the selected MIB file

Note: The UI of HTML UI MIB Browser is not the same as that of Java UI MIB Browser. Apart from 
the difference in the UI, some of the features present in the Java UI MIB Browser such as v3 
support, graphing, etc., are not available in the HTML UI MIB Browser

7.8.2  Loading and Unloading MIBs
The MIB files can be loaded or unloaded as per your requirements. To load the MIB files, use the Load MIB 
option. This displays the HTML page with the list of MIBs.

TABLE 7-17  Task List for HTML Interface

Action Meaning

Load MIB Load the MIB files in the HTML UI MIB Browser.

UnLoad MIB Unload the MIB files in the HTML UI MIB Browser.

Parameters Sets the values for port, version, time-out, retries and max-repetitions. This displays a dia-
log where the Snmp Version, Snmp Port, Time-out, Retries, Max-Repetitions can be spec-
ified

Get Performs a GET operation. This gets all the objects under the selected MIB object, or the 
specific object if the MIB node and instance are specified

GetNext Performs a GETNEXT operation. This gets the next object after the specified object, or 
the specific object instance if a MIB node is specified.

GetBulk Performs a GETBULK operation. This gets a sequence of Next Objects immediately after 
the specified object. The number returned Object instances are equal to the Max-Repeti-
tions field.

Set performs a SET operation. This enables setting the value of the specified object, based on 
the value in the Set Value field. To do a SET for Octet String Type in hex format enter the 
bytes in hex format with each bytes separated by a colon and the entire string within sin-
gle quotes. For example to give 0xff0a3212 enter 'ff:0a:32:12' in the SetValue field

Table Allows you to view the SNMP Table. This brings the display of SnmpTable, if the 
selected OID is a table

Clear Clears the text area. It clears the QUERY RESULTS, which sometimes overflow its 
capacity and needs to be cleared
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The MIB Browser allows loading of compiled MIB files. To store the compiled information, there are two file 
types are used for storing the MIB information in a formatted structure: 

• cmi - This file type contains MIB information such as MIB node, MIB module, naming hierarchy, etc. 
• cds - This file type contains the description and reference of the nodes in the MIB. 

The compiled MIB files reduce the loading time leading to performance improvement. The Load MIBs from 
compiled Files check box can be checked/unchecked to load the MIB files directly or as compiled MIB files. By 
default, this option is unchecked. If this is unchecked, you can directly load the MIB file, as provided. 

When Load MIBs from compiled File is enabled, the MIB Browser tries to load the .cmi and .cds file, if they 
are present. Otherwise, this parses the MIB file and writes the output in .cmi and .cds files and then loads the 
MIB file. For example, for RFC1213-MIB, the compiled MIB files are RFC1213-MIB.cmi and RFC1213-
MIB.cds. The advantage of using this option is that we need not parse the MIB each time we load it, thus opti-
mizing the loading time. 

While loading the compiled MIBs it is enough if we load the .cmi file alone. The .cmi file has reference to 
the.cds files. The <mib_file_name>.cds file should not be loaded directly. 

After loading the MIB file as a compiled MIB file, any change done in the MIB file doesn't get reflected in the 
loaded MIB file. You have to remove the existing .cmi and .cds files, and then load the MIB to get the latest 
changes done. The Overwrite existing compiled MIB files check box can be enabled to overcome this. If this 
option is set to True, the .cmi and .cds files are created each time the MIB is loaded.

Enabling this option is recommended only if you have changed the contents of the MIB file. Otherwise, this 
unnecessarily increases the load time of the MIBs. 

The MIB files displayed in the list box (as shown in the above screen) are provided in the <NMS Home>/mibs 
directory. It may be convenient to copy your MIB files to be loaded, into the <NMS Home>/mibs directory. 

Choose the MIB to be loaded from the list box displayed and choose the Load button. 

You can also load multiple MIBs, which get displayed in the list box provided, as shown in Figure 7-27. Select 
one of the listed MIBs from the list box. Use the Load button to display it in the tree-view of HTML Client. 
When any MIB module is selected, the root node for that MIB becomes the current OID. 

Note: The tree-view of HTML UI MIB Browser displays only one MIB at any time. To view the objects 
of another MIB file, you need to select the respective MIB file from the list box which gets 
overwritten in the tree-view.

To unload the loaded MIB, select the node from the MIB Tree and then choose the Unload option from the MIB 
Toolbar. This removes the MIB and its reference from the tree. 

7.8.3  MIB Browser Settings
The third icon in the toolbar at the top of the frame is the Parameters icon. This option allows configuration of 
various options needed for SNMP operations. 

You can modify the default values as per your requirements. The following table shows the options, description, 
its default values, and other options available.

TABLE 7-18  MIB Browser Settings

Options fir MIB 
Browser Description

Default 
Values Other Options

Snmp Version The version of the SNMP used. SNMP_
Version1

SNMP_Version2c 

Snmp Port The port where the SNMP agent listens. 161 any user-defined port

Time out (Sec) The duration for the SNMP request to 
wait for the response from any device.

5 any user-defined value
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7.8.4  SNMP Operations
The MIB Browser allows you to do typical SNMP operations, such as GET, GET NEXT, GET BULK, and SET. 
To do the GET operation, you have to load the MIB file, select the desired node, and click the Get button in the 
MIB toolbar, provided at the top of the frame. To fully specify an object to an SNMP agent, both the Object ID 
(which defines the type of object) and the instance (the specific object of the given type) need to be provided. 
From the MIB, you can get the Object ID, to which an instance needs to be added to completely identify the 
object of interest. 

For non-tabular objects or scalar objects, this is simply an instance of 0 (e.g., sysDescr.0, this need not be speci-
fied the MIB Browser adds it to the selected node). For tabular objects, the instance is defined by the MIB and is 
a sequence of one or more variables (for example, ifInOctets.2 or tcp-
ConnState.179.74.15.126.1192.225.226.126.197.80).

7.8.5  SNMP Table
To view the SNMP table, click the Table button in the MIB Toolbar provided at the top of the frame. This dis-
plays the SNMP Table if the selected OID is a table.

7.9  Admin (User and Network)
The Admin tab brings up the Administration screen. The options and what they mean are included in the screens.

Refer to the following figure.

FIGURE 7-28  Admin Screen (html)

Retries The number of times the SNMP manager 
should make the request to the SNMP 
agent.

0 any user-defined value

Max. repetitions 
(For GetBulk)

The number of Object instances to be 
returned for a given single request. 
(Applicable only to SNMP_Version2c)

50 any user-defined value

Non Repeaters The number of pairs in the VarBindList 
array for which a single instance should 
be returned (only for SNMPv2c)

any user-defined value

TABLE 7-18   (Continued)MIB Browser Settings
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7.9.1  Security Administration
From the Security admin screen, the user chooses User Configuration, and can then add a user, modify the user 
profile, or remove a user.

7.9.1.1 User Configuration

The Add User form is shown in the following figure. Table 7-19 lists the options.

FIGURE 7-29  Add User Screen (html)

7.9.1.2 Modify User Profile

To modify the User Profile, select the Edit icon. The Modify User Profile form is shown in the following figure. 
Table 7-20 lists the fields.

TABLE 7-19  Options for Add User

Field Meaning

User Name Required, the name must be unique with up to NEED INFO characters.

Password Required, the password must be unique with up to NEED INFO characters. The Re-type 
Password must match or there is an error message.

Available group names The option to add the user to a group, so that the user inherits the privileges of the group.

Add this user to a new 
group

Checking the tic box activates the field, and a new group can be defined that includes the 
new user. NEED INFO - what privileges does the new user have? always admin?

Password expires in Checking the tic box activates the field, how many days the password is valid.

Account expires in Checking the tic box activates the field, how many days the user name is valid.
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FIGURE 7-30  Modify User Profile Screen (html)

7.9.1.3 Group Configuration

To remove the user, select the user name and select the trash can icon. 

7.9.1.4 Operation Configuration

7.9.1.5 Audit Trails

7.9.2  Network Admin
The options here allow the user to add a node, add a network, and refresh a node.

TABLE 7-20  Options for Modify User Profile

Field Meaning

Current and New Password Checking the tic box activates the field, and a new password can be defined.

Groups Which groups the user can belong in. The user must belong in at least one group. 
More than one group can be chosen using the right and left arrows.

Modify password expiration Checking the tic box activates the field, how many days the password is valid.

Modify password expiration Checking the tic box activates the field, how many days the user name is valid.
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Note: Adding nodes and networks is a network administrator task and is covered in the AlliedView 
NMS Administration Guide.

The refresh node form is shown in the following figure.

FIGURE 7-31  Refresh a Node (html)
The name of the node is one of the node’s managed object properties. The Netmask is one of the pull-down 
options, and the SNMP port has the 161 default.

The refresh button, when selected, starts the rediscovery process immediately and updates the system with the 
most current node information.

Note: Refer to the AlliedView NMS Administration Guide for information on rediscovery.

7.9.3  Other Administrative Tasks
The following tables take each of the administrative areas shown in the other panels of the Admin Complete 
View and explain what they provide and when they would be used.

Note: Some of these tasks (such as Shutdown Server) are destructive and should only be done by 
authorized personnel.

TABLE 7-21  Admin Operations

Task Description Notes

Shutdown Server Shuts down the server the client is con-
nected with (FE or FE/BE).

Perform this only if you are authorized to do so.

NE Resync Discards all the traps that are being pro-
cessed by the server. 

Deletes the events and alerts from the 
database. 

Clears all the managed objects and 
updates the status by doing status poll.

 

TABLE 7-22  Admin Configurations

Task Description Notes

Discovery Parame-
ter

Controls Discovery Configuration Set-
tings

Details on the fields in this from are in the NMS 
Administration Guide, Security Administration.

Perform this only if you are authorized to do so.
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Discovery Criteria Specifies the Managed Object properties 
based on which discovery can be enabled 
/ disabled

Perform this only if you are authorized to do so.

Trap Parser Creates and refines the information 
received from a trap (a specific unsolic-
ited report by a device). 

The trap configuration can be imported 
using information the MIB or a file 
where the configuration is defined.

Details on the fields in this from are in the NMS 
Administration Guide, Fault Management.

Trap parsers are critical to alarm correlation and 
should only be changed under the supervision of 
Allied Telesis Technical Support personnel.

Re-Discovery 
Scheduler

Set the schedule for re-discovery Can be at regular interval (recurring) or on user-
created schedule.

Notification Pro-
files

Trap Parser Controls Trap Parser Configuration list

Event Parser Controls Event Parser Configuration list

Event Filters Controls Event filters These are loaded from and saved to conf/
event.filters

Alert FIlters Controls Alert Filter Configuration list These are loaded from and saved to conf/
alert.filters

TABLE 7-23  Server Details

Task Description Notes

Backend Details Provides basic configuration informa-
tion for BE server

This information is useful if reporting a Allied-
View NMS error to Allied Telesis personnel.

Scheduler Details Status of the main software tasks

Frontend Details Provides basic configuration informa-
tion for FE server

Includes server mode as PRIMARY or SEC-
ONDARY, useful when in a distributed server 
configuration.

Client Details Provides basic configuration informa-
tion for client currently being used.

Server Logs Provides a list of NMS server logs; the 
user can click on each one and see the 
logging data

This information is useful if reporting a Allied-
View NMS error to Allied Telesis personnel.

Logging Controls how NMS logs will be written 
to log files

Perform this only if you are authorized to do 
so.

TABLE 7-24  Module Details
Task Description Notes

Discovery Status Provides overall status of Discovery his-
tory for modules and networks

Fault Status Provides the status of the Fault Manage-
ment system (events, alerts and traps pro-
cessing), not faults on the devices

If not set at 0, server is still processing faults and 
so may not have the latest fault snapshot

Performance Status Provides the performance status of a 
Node, using the node name to access

User is also prompted for time period.

TABLE 7-22   (Continued)Admin Configurations
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8. Object Properties to Define 
Objects and Custom Views

8.1  Overview

8.1.1  Main Tasks
With object properties, the user can perform these tasks:

• Define a specific object - The properties of an individual object are viewed and defined using the Managed 
Object properties form. Several of these properties are critical, since certain object properties allow the object 
to be discovered and therefore managed by the AlliedView NMS.

• Define a custom map view - When creating a custom map view, the user can define properties that filter the 
view according to a property criteria. Moreover, certain properties are specifically used to define a filter. For 
example, to create a map view that shows only Telesyn MAP devices, the user could use a number of criteria 
that would result in displaying the Telesyn set. Instead, the user only has to include the property category 
with the value Telesyn to the custom view to select only those devices.

• Define a custom table view - For objects that are listed in the table format, the user can define which proper-
ties will appear as columns and which criteria for properties will filter the view. 

Caution: The user can delete as well as add Custom Views. This provides flexibility, but users 
should not delete any views unless they are sure that is what they wish, since some  
views require the combination of many properties.

8.2  Defining Custom Map Views

8.2.1  Adding a Custom Map - Map Properties Forms
When creating a map, you have these options:

• Create a custom map (only those objects that meet a specific criteria can be included).
• Modify the map appearance for existing default maps or custom maps

To create a custom map, select CustomViews > Add New Map from the Panel-Specific Menu Bar, which brings 
up the following figure.
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FIGURE 8-1  Add/Modify Map Properties Form
In the form, specify the set of map-related information before adding the map. The following table describes the 
various fields that you need to fill in the form.

TABLE 8-1  Map Properties

Map Property Description of Map Properties Example

name To Be Supplied property?

label The name that will be displayed in the panel and 
tree.

iMAP_only

topology The permission layouts of the map. You can use 
comma separated values.

imageName The image file to appear as the background of the 
map. These are stored in <NMS Home>/Images

world.png

autoPlacement A boolean that specifies whether the symbols on the 
map are placed automatically. The default is True.
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menuName The panel-specific menu file for this map. The menu 
files are in the 

<NMS Home>/mapdata/
menus 

directory.

To be Supplied

mapSymbolRenderer The renderer that paints the map symbols in the map 
canvas. By default, there are three map symbols 
renderers included with the product.

To Be Supplied

mapLinkRenderer The renderer that paints the links in the map canvas. 
By default there are two map link renderers included 
with the product.

To Be Supplied

anchored A boolean that specifies whether the anchor 
property of the map is True or False. If True, the 
map becomes non-editable (cannot add mapclient 
components). If False, the map is a normal editable 
map. The default is False.

treeIconFileName The name of the icon file that appears in the client 
tree against the map node.

To Be Supplied

currentTopology The layout to apply to default of this map. If you do 
not specify one, the first entry of the topology field 
is the default. If you do not specify anything in the 
topology field, then NMS uses the flow layout by 
default.

ParentNode The name of the of the parent node in the tree. For 
example, if you specify the parent node as “Fault” 
then the map is added under the Fault Node in the 
tree.

TABLE 8-1  Map Properties (Continued)

Map Property Description of Map Properties Example
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Once you have filled in the map properties, click More, and the UI shown in the following figure will pop up. In 
this UI, you can specify a Managed Object and the criteria that will filter what will appear in the map. Note that 
the match criteria can only be the properties of the managed object.

Caution: The property name on the left is case-sensitive. Property names usually have medial 
capitalization (“camel-case”), for example ipAddress. If you enter the case 
incorrectly, no criteria will be used, and the new map will contain all managed objects 
in your network. For the correct property name to use, refer to the tables in Section 
8.4.

Note: The property value on the right may contain the wildcard character “*”, and may contain 
comma separated values, for example “10.1.1.*, 10.1.2.*”. For more information, refer to 
Section 8.3.3.

FIGURE 8-2  Adding Managed Object Criteria to Map View
Click the Add Map button to add the map. The new map will appear in the tree.

Note: The properties for an object type can be applied for both the Map and Table Custom Views; 
for example, the properties/criteria for routers can be applied for both routers as a map node 
and routers in the network inventory. Therefore, to see which properties apply for a map node 
object, refer to the table for the same object for a table view.

To change the map properties for an existing map, the user can double-click in a blank area. This brings up the 
Map Properties form, as shown in the following figure.

Note: If you double-click a blank area for the Physical Network, the Layer 2 links form appears. If 
you wish to change the appearance of a map with physical devices, select View -> Details with 
no devices selected.

Note: The tic box Save changes on server makes the change so that all users will see the same 
changes.
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FIGURE 8-3  Map Properties Form

8.2.2  Example - Change a Background Map
An example for Map Properties is to change the background map for the Physical Network node. Following are 
the steps:

1. Go to the Physical Network node and select View -> Details. The Map Properties form appears.
2. Images are stored in <NMS home>/Images. (You can add other images to this directory.) Click on the Ima-

geName book icon in the Map Properties form and select an image file, as shown in the following figure.
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FIGURE 8-4  Selecting a Background Image for a Map
3. Click on Open, and then Modify on the Map Properties form. The image becomes the background image for 

the map.

8.2.3  Example Custom Map for iMAP Devices Only
Following are the steps to create a custom map of Allied Telesis devices.

1. From the Physical Network Map choose Custom Views -> Add New Map. The View/Modify Properties 
Form (See Figure 8-1) appears.

2. In the form, fill in a name (such as iMAP_only) and label (also iMAP_only).
3. Click on More to bring up additional Map criteria.
4. Enter the property category with the pre-defined value Telesyn. 
5. Click OK, and on the Properties form click Add Map.
6. There is now a Custom Map that shows only Allied Telesis iMAP-type devices. Refer to Figure 8-5.
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FIGURE 8-5  Example Custom Map for Telesyn devices

8.3  Using Object Properties

8.3.1  Overview
A custom table view is an option to view a subset of data that meets a certain criteria from the larger collection, 
such as Events or Alarms. You can use custom views to narrow the range of items, which allows an easier search.

Custom views have the following special features:

• A view can be created to match a specific criteria.
• Views are updated dynamically.
• The same custom view can be used at different levels.
• The column (properties to view) can be customized
• Column order and sorting of data can be saved these in the custom view.
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• Custom views can be modified and renamed.

To create a custom view, you first define the criteria for the view, and then specify how to view the filtered data. 
The options for custom views are as follows:

• Add/Modify the Custom View

When creating a custom view, the user fills out a Specify Event Filter Criteria form, which contains Proper-
ties and Tree Node Properties. Once created, the view can be seen in the node tree on the left. The user can 
then select the view and modify the criteria if need.

• Remove Custom View

The user can select the view in the NMS Tree and choose Remove Custom View from the either the Panel-
Specific Menu Bar or from the pop-up menu accessed by a right clicking the view in the tree. This option 
will remove the view form the tree.

• Save Custom View Data

After sorting and selecting a range of items, the user can save that specified list by selecting Save Custom 
View State from the either the Panel-Specific Menu Bar or from the pop-up menu accessed by a right click-
ing the view in the tree.

8.3.2  Objects for Table Views
This section lists the property details of the objects that make up the AlliedView NMS. The following table lists 
the objects that have properties and which subsection describes these properties.

Note: To filter on iMG/RGs, refer to the AlliedView NMS Administration Guide.

. 

8.3.3  Matching Criteria
Points to consider in regards to using properties are as follows:

• Most of the Properties listed while adding a custom view are string based. Additionally, if there is a Boolean, 
the properties form indicates a choice box, containing three items: all, true, and false. Selecting all will 
amount to the property not being taken into consideration. Selecting true or false will have the expected 
behavior.

• For string-based properties, the string value is absolutely matched. For example, the string “Router” matches 
the exact word only.

TABLE 8-2  Tree Node Properties - Reference Table

Object Reference

Network 8.4.2

Device (Node) 8.4.3

Customer Port 8.4.4

IP Interface (IP) 8.4.5

Profile 8.4.6

Vlan Interface (VIF) 8.4.7

Physical Links 8.4.8

PMs 8.4.9

Events 8.4.10

Alerts 8.4.11

Links 8.5.1
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• The wildcard '*' (asterisk) is supported to replace one or more characters. For example, if you want to view 
objects whose names start with ‘sa’, then you have to specify it as ‘sa*’. Similarly, if you want to view 
objects whose names end with ‘com', then you have to specify as ‘*com’.

• Wildcard, '?' is not supported and is treated just as an ordinary character.
• For specifying multiple criteria for the same property, separate them with a comma. For example, if you want 

to view objects named nms-server1, nms-server2 and nms-server3 then specify as nms-server1, nms-server2, 
nms-server3.

• Status, Severity, etc. are also treated as strings. Therefore, for a filter of Alarms, with severity critical, specify 
‘crit*'’.

• To exclude certain items, as part of the filtering criteria, append a '!' before it. The exclamation mark should 
be used to ignore those values. For example, if you want to view objects, which do not start with ‘s’', then 
specify the property as '!sa*' or if you want to see all Alarms, except those with severity other than warning 
and clear, then any of the following will work:
• !war*, !cle*
• !warning, !clear
• cr*, maj*, mino*
• critical, major, minor

• In the Alarms and Events panel, filtering based on time can be done by specifying the starting time and the 
ending time. The formats in which the time is to be specified are as follows:
• MON DD,YYYY HH:MM:SS AM/PM (For JavaUI) for example, Oct 27,2002 12:24:12AM and
• MONTH DD,YYYY HH:MM:SS AM/PM (For JavaUI) for example, Oct 27,2002 12:24:12 AM. (The 

incompatibility is due to different JVM versions on Client and Server sides).
• In the Network Inventory view, the properties form initially contains only properties common to all Managed 

Objects. But the properties form changes to display properties specific to the particular object on double-
clicking the desired property. That is, after viewing the properties of an interface, on double-clicking that, the 
properties specific to the interface are displayed (IfIndex, IfSpeed, etc.) which are part of the properties form.

• It is advisable to leave the fields blank that are not necessary but are part of the filtering criteria.
• Once the filtering criterion is specified, you can optionally give the filter a name and then select the ApplyFil-

ter option. The client then sends a request to the server to filter the objects while it adds the name of the filter 
to the tree in the main panel.

• The time to filter may vary, depending on the total number of objects, the complexity of the filter criteria, and 
the mode of storage.

• Custom Views, once created, continue to be updated and navigable for additions/deletions till the client is 
closed or the custom view is removed using Remove Custom Views option.

Note: Use the Custom Views with caution and remove the unnecessary ones. This allows quicker 
updates and clearing of resources associated with each Custom View, both on the client and 
server side.

Note: If all the above parameters (except filter view name) are left blank, then the default value all is 
assigned. For Date/Time properties by default will show the current date and time, requires 
data in the order of month, date, year, hour, minute, second and AM / PM which can be 
chosen by using the up and down arrows.

In the properties form, you can also click Select Props to View, which opens a window with the default proper-
ties to be shown in the selected table (as shown in the following figure).
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FIGURE 8-6  Selecting Properties to View in a Custom View
Clicking the Additional table columns button in this Select Table Columns form brings up the User defined 
table columns form. In this form the user can enter the user properties that were defined in the Event Parser and 
what the displayed table column will be. 

Note: If additional user properties have been added, they can be included here by using the More 
button and entering them in the Property Name field. The More button can also be used to add 
any properties that are expected to be added in the future.

Figure 8-7 shows the User defined table columns with the property sysLocation filled in.The column display 
will be Physical Location.

Note: The Location Names are defined as part of provisioning device information. Refer to the 
Telesyn Administration Guide, section 5.3.5.

FIGURE 8-7  Adding Properties to a Network Custom View
Clicking the Additional Criteria button in the Show objects with these Properties form brings up the Criteria 
dialog form. In this form additional criteria can be specified for both the NMS properties and any user properties 
(including sysLocation).

Click Apply Filter to see the resulting view. To save, right-click on the node icon in the NMS Tree, and then 
select Custom Views->Save Custom View State from the pop-up menu.
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8.3.4  Default User Properties Added by the NMS and Custom Views
To view information for the devices, user properties have been added to the tree node tables that show relevant 
information. When the NMS is first configured, they are grouped as follows:

• Alarms – sysLocation
• Network – discover
• Nodes - SerialNumber
• Ports – customerID, ethIfIndex, portType, deviceID, adslIfIndex, slotID, portID
• VLAN Interface – parentkey, vlanparentnetwork, valnuntaggedports, vlantype, vlaninterfacevid, vlantagged-

ports
• Physical Links – Snode, DNode, DPort, SPort 

These properties show up by default when the NMS is first configured, and the user can change the displayed 
column name if desired, in either the default view or a Custom view.

Caution: Although in the default View or Custom View these properties can be made not to 
display, the user should not do this since these properties were created to provide 
relevant information about a component. For example, for Physical links, the DPort 
property (Destination Port) would need to be shown to understand the configuration. 
These properties are therefore useful when creating custom views. However, even if a 
property is not displayed, a criteria can be set for the view based on that property.

8.3.5  Tree Node Properties Tab
The Tree Node Properties form determines the way the subset of data is presented for a View. This is done by 
selecting the Tree Node Properties tab of the Show objects with these Properties form, as shown in the following 
figure.
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FIGURE 8-8  Tree Node Properties Form for Events
The following table lists the properties.

TABLE 8-3  Tree Node Properties - To be Supplied

MO Form Property 
(Label) Description for Tree Node Properties

Frame Title The information to be displayed on the title bar of the Custom View's internal frame is 
specified here. 

Menu File Name The panel-specific menu's file name is given here. If you have not specified this then the 
default menu is displayed. 

Icon File The icon to indicate the custom view is taken from this property. This icon is visible in the 
tree as well as in the title bar of the internal frame. 

Table Popup Menu The menu filename for displaying a contextual menu for the objects displayed in the table of 
the newly added custom view. 
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8.4  Managed Object Properties and Custom Views

8.4.1  Overview
The following tables list the properties for the various objects controlled by the AlliedView NMS. The columns 
of the table are as follows:

• Form Property - This is the property as shown on the Managed Objects Form. If an object is usually not 
changed by the user, (Internal only) is included.

• Description - This describes the property in detail.
• Custom View Property - If the property is used for a custom view, it is included here. Note that the spelling 

can be different. This is the exact spelling you must use when adding a property.
• Examples for Custom View - When setting a criteria for a property in a custom view, the example gives a 

typical value and explains how that value filters the custom view.

Note: An object may have many properties, but only a few that are commonly used for creating 
custom views; moreover, many properties are for internal reference and should not be 
changed. Therefore, these tables only include form properties that are useful for network 
administrators. These properties may be those included with the form or those that can be 
added with the More button.

8.4.2  Networks

8.4.2.1 Properties

The following table lists the properties for a network node. All the properties can be viewed by using the Next 
and Back button at the bottom of the form. 

Tree Popup Menu The menu filename for displaying a contextual menu for the newly added custom view node 
in the client tree. 

Node Index The position of the this new custom view in the node tree when this view is added as a child 
to an existing view that already has one or more child nodes. If the value is not entered, then 
the custom view is appended. 

TABLE 8-4  Properties for Network Objects

MO Form 
Property Description for Network Objects

Custom View 
Property (use 
this exact text)

Examples for Custom 
Views

Name The device name, which is a unique name that 
is used as the key in the database. This name 
cannot be changed.

name 172.16.33.0
Note: The name for a 
device should not include 
an ‘&’ or Rediscovery will 
fail.

DisplayName The name by which the device is identified on 
the Graphical User Interface (GUI).This is 
intended to be more intuitive regarding the 
identification of the network, whereas the 
name can be any string with the only constraint 
being that it is unique. 

displayName Site_A
(This would assume the 
network was contained in 
Site_A)

TABLE 8-3  Tree Node Properties (Continued)- To be Supplied

MO Form Property 
(Label) Description for Tree Node Properties
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8.4.2.2 Custom View for Networks Example

If there are a large number of networks being managed, the user can create a view that shows networks in a Crit-
ical or Major state. In the Custom View form, the user would:

1. Select the Network node in the Inventory view and right-click Custom View -> Add Custom View.

Type The type of the object, such as whether it is a 
network, node, or an interface object, or 
something user specified, like router, switch, 
etc. 

type Network
(In a network view, this 
would be the default, in 
other views this would set 
the criteria as showing only 
networks)

Managed A checkbox that indicates whether the 
managed object is managed by the NMS. 
When checked, the object is being managed by 
the NMS. Otherwise, it is not.

managed true (rather than a 
checkbox)

IpAddress The IP address assigned to the object. ipAddress 172.16.33.0
(This would be for the 
network)

InterfaceList The interfaces contained within the network. In 
the Properties form this is a drop down list.

InterfaceList 172.16.33.20 172.16.33.21
The value all would select 
all nodes.

NodeList The devices contained within the network. In 
the Properties form this is a drop down list.

NodeList 172.16.33.20 172.16.33.21
The value all would select 
all nodes. The DNS name 
can also be used.

DiscoveryStatus The current status of the discovery process. 
The possible values are as follows:
1 = YET_TO_BEGIN - Discovery of network 
yet to begin.
2 = IN_PROGRESS - Discovery if network is 
in progress.
3 = FINISHED - Discovery of the network is 
finished.
4 = DISCOVERY_DISABLED - Takes this 
value if either discover is 'false' or managed is 
'false' for this network.

DiscoveryStatus 2

DiscoveryStatus A boolean that indicates whether the object 
status polling has been enabled for the object. 
It is set to true if status polling is enabled for 
the object, false otherwise. 

DiscoveryStatus

DiscoveryStatus The type of testing to run when checking the 
status of the device. 
Refer to the AlliedView NMS Administration 
Guide, section 9.8.

DiscoveryStatus

(More...) subNets 172.16.33.20 172.16.33.21
(The value all would select 
all nodes.)

(More...) stringstatus Critical Major Minor Clear
(separated by comma when 
choose more than one)

TABLE 8-4  Properties for Network Objects (Continued)

MO Form 
Property Description for Network Objects

Custom View 
Property (use 
this exact text)

Examples for Custom 
Views
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2. In the Filter View Name field, type Network_Alarm
3. Click Next to access the Additional Criteria, and type in status and Critical,Major, as follows.

4. Click on OK, and a network_alarm view is formed that shows only networks with a critical or major alarm. 
Refer to the following figure.

FIGURE 8-9  Customer View for Networks

8.4.3  Devices (Nodes and Routers)

8.4.3.1 Properties

The following table lists the managed object properties for Node devices. All the properties can be viewed by 
using the Next and Back button at the bottom of the form.

Note: The classname for Nodes is !RgMO (not RG devices) and this should not be changed.

.

TABLE 8-5  Managed Object Properties for Nodes

MO Form 
Property Description for Nodes

Custom Map 
View Property 
(use this exact 
text) Example

Filter View Name The name given to the panel nodes_alarms

Name The device name, which is a unique name that 
is used as the key in the database. This name 
cannot be changed.

name 172.16.33.11

DisplayName The name by which the device is identified on 
the GUI.This is intended to be more intuitive 
regarding the identification of the device, 
whereas the name can be any string with the 
only constraint being that it is unique. 

displayName Building_A
(This would assume the 
device was contained in 
Building_A)
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Type The type of the object, such as whether it is a 
network, node, or an interface object, or 
something user specified, like router, switch, 
etc.

type 9700
9400
Rapier*
(all Rapier devices)
RG*
(all RG devices)

managed A pull-down that indicates whether the 
managed object is managed by the NMS. 
When True, the object is being managed by the 
NMS. When False, it is not. When all, it 
includes all devices.

managed true
(would not include 
devices that were 
discovered and 
unmanaged)

IpAddress The unique address assigned to each and every 
object. 

ipAddress 172.16.33.11

netmask The netmask that is specified for this managed 
object. Network masking is a methodology by 
which the elements in a network can be 
meaningfully categorized. 

netmask 255.255.255.0

ParentNet The ID of the network that contains this node 
or a list of network numbers if this is a router 
connecting two or more networks.

parentNet 172.16.33.0

InterfaceList A non modifiable drop-down list of all 
interfaces on this device.

InterfaceList 172.16.33.20 
172.16.33.21
(The value all would 
select all nodes.)

Tester The type of testing to run when checking the 
status of the device. 
Refer to the AlliedView NMS Administration 
Guide, section 9.8.

Community The community string of the corresponding 
SNMP agent associated with the link

community

SysName
(Internal)

The system name as reported by the SNMP 
agent

SysDescr The value of the system description associated 
with the type of managed object to be filtered.

sysDesc Telesyn 9700

all

SysOID The system object identifier of the device as 
reported by the SNMP agent of the device.

sysOID .1.3.6.1.4.1.207.1.15.3

Login The CLI username to use when NMS executes 
CLI commands on the device. It is defaulted 
but it should be changed.

login officer

Password The password to use when NMS logs in with 
the CLI username.

password To Be Supplied

SysLocation A string value to identify where the device is 
located

sysLocation Building_A
(This would assume the 
device was located in 
Building_A)

TABLE 8-5  Managed Object Properties for Nodes (Continued)

MO Form 
Property Description for Nodes

Custom Map 
View Property 
(use this exact 
text) Example
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8.4.3.2 Custom View for Device Example

If there are a large number of nodes being managed, the user can create a view that shows only iMAP devices. In 
the Custom View form, the user would:

1. Select the Nodes in the Inventory view and right-click Custom View -> Add Custom View.
2. In the Filter View Name field, type iMAP_devices.
3. Click Next to access the Additional Criteria, and type in category and Telesyn, as follows.

4. Click on OK, and a iMAP_devices view is formed that shows only Allied Telesis Map devices, as follows.

Category The family of the device category Telesyn
(includes all MAP 
devices)
Rapier*
(all Rapier devices)
RG*
(all RG devices)

Release The release ID of the device software. release

SysContact A string to identify the owner of the device sysContact Company_A

ConfigChanged The time that a change to the device's configu-
ration has been detected by the Device Backup 
operation. Config changes will be detected 
automatically when recurring backups are 
scheduled.

This property is included in the Nodes custom 
view under the Network Inventory by default.

configChanged To Be Supplied

LastBackupTime The time of the last backup performed for this 
device via the Device Backup/Restore MDTI 
Operation.

lastBackupTime Wed Aug18 2010*

status (pull-down) stringstatus Critical,Major,Minor, 
Clear
(separated by comma 
when choose more than 
one)

TABLE 8-5  Managed Object Properties for Nodes (Continued)

MO Form 
Property Description for Nodes

Custom Map 
View Property 
(use this exact 
text) Example
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8.4.4  Customer Ports

8.4.4.1 Properties

The following table lists the properties for customer ports. All the properties can be viewed by using the Next 
and Back button at the bottom of the form.

TABLE 8-6  Managed Object Properties for Customer Ports

MO Form Property Description for Interfaces

Custom Map View 
Property (use this 
exact text) Example

Name The port name, which is a unique name that is 
used as the key in the database. 

name 172.16.33.11_17.4
(This follows the 
device_card.port 
format)

DisplayName The name by which the device is identified on 
the GUI.This is intended to be more intuitive 
regarding the identification of the device, 
whereas the name can be any string with the 
only constraint being that it is unique. 

displayName 172.16.33.11_17.4

Type The type of the object, such as whether it is a 
network, node, or an interface object, or 
something user specified, like router, switch, 
etc. 

type CustPort

CustomerID The description from the “Show Port” CLI 
command.

customerID x908_mgmt
(or telephone 
number, a 
convenient way to 
identify the 
customer)

DeviceID The device to which the port belongs deviceID 172.16.33.11

Slot The slot ID of the customer port. To Be Supplied

PortType portType ADSL
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8.4.4.2 Custom View for Ports Example

If there are a large number of ports being managed, the user can create a view that shows only ADSL ports. In the 
Custom View form, the user would:

1. Select the Nodes in the Inventory view and right-click Custom View -> Add Custom View.
2. In the Filter View Name field, type Ports_adsl.
3. Click Next to access the Additional Criteria, and type in portType and adsl, as follows.

4. Click on OK, and a Ports_adsl view is formed that shows only adsl ports, as follows.

EthIfIndex An index number assigned by the NMS to 
identify the port and its type

ethIfIndex 112

GroupNames Blank since customer ports cannot be defined in 
groups.

PortProfileMOName portProfileMOName

PortProfileName portProfileName *ADSL*

IsGroup A boolean that indicates whether the object is a 
group. It is false since this is a port.

AdslIfInadex To Be Supplied

PortID To Be Supplied

TABLE 8-6  Managed Object Properties for Customer Ports (Continued)

MO Form Property Description for Interfaces

Custom Map View 
Property (use this 
exact text) Example
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8.4.5  Interfaces (IP)

8.4.5.1 Properties

The following table lists the properties for interfaces. All the properties can be viewed by using the Next and 
Back button at the bottom of the form.

TABLE 8-7  Properties for Interfaces

MO Form 
Property Description for Interfaces

Custom Map 
View Property 
(use this exact 
text) Example

Name The device name, which is a unique name that is 
used as the key in the database. 

name IF-172.16.33.11

DisplayName The name by which the device is identified on the 
GUI.This is intended to be more intuitive regarding 
the identification of the device, whereas the name 
can be any string with the only constraint being that 
it is unique. 

displayName IF-172.16.33.11

Type The type of the object, such as whether it is a 
network, node, or an interface object, or something 
user specified, like router, switch, network. 

type Always interface

IpAddress The unique address assigned to each and every 
object. 

ipAddress 172.16.33.11

Netmask The netmask that is specified for this managed 
object. Network masking is a methodology by which 
the elements in a network can be meaningfully 
categorized. 

netmask 255.255.255.128

ParentNet The ID of the network that contains this interface. parentNet 172.16.33.0

Community The community string of the corresponding agent 
associated with the link

WriteCommunity The SNMP community string for write access to 
agent used to reach this interface.

writeCommunity private
(for all SNMP 
communities for 
write access, all
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8.4.5.2 Custom View for Interfaces Example

The user can create a view that shows only interfaces for the 7700 devices. In the Custom View form, the user 
would:

1. Select the Interfaces in the Inventory view and right-click Custom View -> Add Custom View.
2. In the Filter View Name field, type Interfaces_255_255_255_0.
3. Click Next to access the Additional Criteria, and type in netmask and 255.255.255.0, as follows.

4. Click on OK, and an Interfaces_255_255_255_0 view is formed that shows only interfaces with the 
255.155.155.0 mask, as follows.

SysOID The system object identifier of the device as 
reported by the SNMP agent of the device.

sysOID .1.3.6.1.4.1.207.1.
15.3

PhysMedia The topology of the network this interface is 
attached to.

To Be Supplied

IsNode A pull-down that indicates whether the object is a 
node.

isNode

ParentNode The ID of the node on which the interface resides. parentNode 172.16.33.11

PhysAddr The physical (MAC) address of this interface

Version The version of the SNMP agent, such as v1, v2, or 
v3.

version v2

IfDescr The SNMP IfDescr value for this interface ifDescr MGMT:ETH:0

IsNetwork A pull-down that indicates whether the object is a 
network. It is false since this is an interface.

(More...) stringstatus Critical Major 
Minor Clear
(separated by 
comma when 
choose more than 
one)

(More...) hostNetmask 255.255.255.0

TABLE 8-7  Properties for Interfaces (Continued)

MO Form 
Property Description for Interfaces

Custom Map 
View Property 
(use this exact 
text) Example
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FIGURE 8-10  Interface Filter

8.4.6  Profiles 

8.4.6.1 Properties

The following table lists the properties for profiles. All the properties can be viewed by using the Next and Back 
button at the bottom of the form. 

TABLE 8-8  Managed Object Properties for Profiles

MO Form 
Property Description for Profiles

Custom Map 
View Property 
(use this exact 
text) Example

ParentName The name of the corresponding panel under which 
this custom view is added is given by default. On 
clicking the combo button, all the current tree nodes 
available are shown.

ParentName

name The name for each type of profile is a default and 
the name given by the user. Default names are:
To Be Supplied
Profile_POTS
Profile_Etherlike_Port
Profile_ADSL
Profile_Rapier_Device
Profile_Telesyn_Device
Profile_SwitchBlade_Device

name Profile_POTS_test

displayName The name by which the device is identified on the 
GUI.This is intended to be more intuitive regarding 
the identification of the device, whereas the name 
can be any string with the only constraint being that 
it is unique. 

displayName

type type of object. This is always Profile. type Profile

community The community string of the corresponding SNMP 
agent associated with the profile

community

(More...) profileName Test_Profile

(More...) profileType Profile
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8.4.7  VLAN Interfaces 

8.4.7.1 Properties

The following table lists the properties for VLAN interfaces. All the properties can be viewed by using the Next 
and Back button at the bottom of the form.

TABLE 8-9  Managed Object Properties for VLAN Interfaces 

MO Form 
Property Description for Interfaces

Custom Map 
View Property 
(use this exact 
text) Example

classname The class name, but not the fully qualified name. 
This property is used when restoring the device 
subclass when it is stored in a relational database. 
For example, for node objects, this property will 
have the value node. 

classname

community The community string of the corresponding agent 
associated with the VLAN interface

community

contextName The SNMPv3 ContextName, if the SNMP version 
is v3.

contextName

DisplayName The name by which the device is identified on the 
GUI.This is intended to be more intuitive regarding 
the identification of the device, whereas the name 
can be any string with the only constraint being that 
it is unique. 

displayName Default_VLAN

Name The VIF name, which is a unique name that is used 
as the key in the database. 

name

parentKey Database key of the parent object--the device that 
contains the vlan interface. 

parentKey

pollInterval The polling interval in seconds, which is the time 
gap between two successive status pollings of 
managed objects. 

pollInterval

stringstatus The status of the VLAN interface stringstatus Critical Major 
Minor Warning 
Clear Unknown
(separated by 
comma when 
choose more than 
one)

type The type of the object, such as whether it is a 
network, node, or an interface object, or something 
user specified, like router, switch, etc. 

type VlanInterface
(Default)

vlanepsrtype vlanepsrtype Master
Transit
Data (All others)

vlangrouplist The domain name for the vlan group, usually 
associated with an EPSR configuration

vlangrouplist dom1,dom2

vlaninterfacevid The VLAN ID associated with a Vlan interface. It 
is always set. The range: 1-4096.

vlaninterfacevid 500
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8.4.7.2 Custom View for VLAN Interface Example

The user can create a view that shows only VLAN Interfaces for the VID 500. In the Custom View form, the 
user would:

1. Select the VLAN Interfaces in the Inventory view and right-click Custom View -> Add Custom View.
2. In the Filter View Name field, type VLAN_500.
3. Click Next to access the Additional Criteria, and type in vlaninterfacevid and 500, as follows.

4. Click on OK, and a VLAN_500 view is formed that shows only interfaces with the 255.155.155.0 mask, as 
follows.

vlantaggedports A compact list of tagged ports on a VlanInterface. 
The list will be empty if none exist.
The format is card.port delimited by commas.

vlantaggedports 11.1-9,12.1 - To Be 
Supplied
None
(no ports are 
tagged)

Vlan Type The type of VLAN (VLAN or HVLAN) vlantype VLAN
HVLAN

UnTagged Ports A compact list of untagged ports on a VLAN 
interface. The list will be empty if none exist.

vlanuntaggedport
s

11.1-9,12.1 - To Be 
Supplied
None
(no ports are 
tagged)

UCP Mode To Be Supplied

Forwarding Mode To Be Supplied

TABLE 8-9  Managed Object Properties for VLAN Interfaces  (Continued)

MO Form 
Property Description for Interfaces

Custom Map 
View Property 
(use this exact 
text) Example
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FIGURE 8-11  VLAN Filter

8.4.8  Physical Links

8.4.8.1 Properties

The following table lists the properties for physical links. All the properties can be viewed by using the Next and 
Back button at the bottom of the form.

TABLE 8-10  Managed Object Properties for Physical Links

MO Form 
Property Description for Interfaces

Custom Map 
View Property 
(use this exact 
text) Example

Name The device name, which is a unique name that is 
used as the key in the database. 

name LINK-
172.16.33.14-9--
172.16.33.10-5
(This follows the 
format of device-
link--device-link)

DisplayName The name by which the device is identified on the 
GUI.This is intended to be more intuitive regarding 
the identification of the device, whereas the name 
can be any string with the only constraint being that 
it is unique. 

displayName

Link Type The type of the object, such as whether it is a 
network, node, or an interface object, or something 
user specified, like router, switch, etc. 

type L2LinkMO

SNode The source node of a physical link. SNode 17.16.33.10

LinkStatus This field has been deprecated. linkStatus

Destination port The destination port of a physical link. DPort 1.1
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8.4.8.2 Custom View for Physical Links Example

The user can create a view that shows only VLAN Interfaces for the VID 500. In the Custom View form, the 
user would:

1. Select the VLAN Interfaces in the Inventory view and right-click Custom View -> Add Custom View.
2. In the name field, type Links_172_16_33_1.
3. Click Next to access the Additional Criteria, and type in SNode and 172.16.33.1, as follows.

4. Click on OK, and a Links_172_16_33_1 view is formed that shows only interfaces with the 255.155.155.0 
mask, as follows.

FIGURE 8-12  Mask Filter

8.4.9  Performance Monitoring

8.4.9.1 Properties

A complete list of the object properties for a polling object is in the AlliedView NMS Administration Guide. The 
following table lists the properties that are used when creating a custom map view.

Dest. Device The destination device of a physical link. DNode

Source port The source port of a physical link. SPort 1.1

(More...) stringstatus Critical Major 
Minor Warning 
Clear
(separated by 
comma when 
choose more than 
one)

TABLE 8-10  Managed Object Properties for Physical Links (Continued)

MO Form 
Property Description for Interfaces

Custom Map 
View Property 
(use this exact 
text) Example
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TABLE 8-11  Properties for Statistics

MO Form 
Property Description

Custom Map View 
Property (use this 
exact text) Example

Name Any meaningful string for the Data Identifier. name etherStatsPkts

SnmpVersion One of the three SNMP versions - VI, V2 or V3. 
Required.

snmpVersion v2

Read Commu-
nity

Enter the string with which the devices are identified 
in a network. Most of the equipment vendors set the 
Community value as public for their devices, so it is 
usually used here. Otherwise you have to check the 
string used for the particular device.

Note: The community specified must be 
enabled on the device.

community public

OID A unique Object Identifier string that represents a 
MIB entry. Data is collected for this identifier. An 
SNMP specific Data identifier is called an OID. For 
example, 2.2.1.16.1 refers to IfInOctects interface 
instance 1. Required.

oid .1.3.6.1.2.1.16.1.1.
1.5

Agent Normally a device will have one agent in it to collect 
device data, and the device name and agent name 
will be the same. Required.

agent 172.16.33.11

DNS Name Name of the device from which data have to be col-
lected.

dnsName 172.16.33.11

Active A checkbox, when checked, means the data collec-
tion will be started for this OID. (The statistic row 
once created will be green.)

Default value: False (unchecked).

active false

Period The time interval for periodic data collection. For 
example, if set to 2, for all the Data identifiers, data 
will be collected once in every 2 seconds. 

Default value: 300 seconds.

period 300

(the default value)

Threshold Checking means the Threshold will be applied on 
this Data identifier. Unchecked means no Threshold 
will be applied.

Default value: False (unchecked).

threshold false

ThresholdList Name of the Thresholds in comma separated format, 
thus associating them to this Data identifier for mon-
itoring data collection.

thresholdList ?

failureThreshold Threshold at which a failure is declared. failureThreshold 1

Multiple Checking means the data identifier is of type multi-
ple.

isMultiplePolledData true

Policy Name The name of the polling policy. policyName
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8.4.9.2 Custom View for Statistics Example

The user can create a view that shows which statistics match a DNS Name. In the Custom View form, the user 
would:

1. Select the Configured Collection in the Performance view and right-click Custom View -> Add Custom 
View.

saveAbsolutes This option is applicable only for Counter type 
OIDs. By default, data collected for Counter type 
OIDs is not stored as it is. The difference between 
the previous data and latest data is collected and 
stored. If the exact value (absolute value) of col-
lected data has to be stored for Counter type OIDs, 
then this check box should be checked. Data col-
lected for OIDs of other data types are saved as 
absolute values.

Default value: False (Unchecked).

saveAbsolutes false

SaveOn Thresh-
old

Possible values are true and false. If true the col-
lected data is saved only when it exceeds the thresh-
old.

Default value: false

saveOnThreshold false

Time Average Checking means the Time Average will be calcu-
lated as follows:

(<Latest collected value> + <Previous collected 
value>) / <Difference in data collection Time value>

This is mostly calculated for counter type and gauge 
type OIDs where the data collected will be an incre-
mental value and at one point will reach the final 
value and reset to zero. As this reset may happen 
soon and very often, it is preferred that a delta value 
is derived from two consecutive polls.

Default value: false.

timeAvg false

Last Counter 
Value

The counter value last read. lastCounterValue 0

Last Time Value The time the counter was last read. lastTimeValue 0

Next Time 
Value

The next time the counter will be read.

Log Directly Checking means to store the collected data in flat 
files rather than storing them in database.

Default value: false (unchecked).

log Directly false

Log File The log file name with a full path (the location on 
the hard disk as where the log file has to be stored).

logFile

parentObj Name of the Managed Object which acts as the par-
ent for this Data Identifier.

Poll ID A unique number associated with each Statistic to 
identify the Statistic. Poll ID is automatically gener-
ated so no two Statistics will have the same Poll ID.

id 334

Advanced Allows the optional values to be modified.

TABLE 8-11  Properties for Statistics

MO Form 
Property Description

Custom Map View 
Property (use this 
exact text) Example
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2. In the Filter View Name, type Active.
3. In the Active pulldown, select True.
4. Click on OK, and a view is formed that shows only devices with activated statistics, as follows. (Click on 

each device to see the active statistics.)

FIGURE 8-13  Statistics Filter

8.4.10  Events

8.4.10.1 Properties

You can set the match criteria by using the Specify Event Filter Criteria form. This form can be accessed by 
selecting Custom Views -> Add Custom Views from the Panel-Specific Menu Bar. Refer to the following figure.
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FIGURE 8-14  Matching Properties Form for Events
The following table lists the properties in detail.

TABLE 8-12  Custom View Criteria for Events

MO Form Property Description for Match Properties

Custom View 
Property Name 
(use this exact 
text) Example

Severity The severity of the object. Severity is a 
property in the event object that indicates the 
criticality of the event. The severity of the 
event to be filtered can be assigned using the 
combo box. Multiple severities can also be 
assigned by separating them using a comma. 

severity Major (if multiple, 
separate with 
commas)

Message Any important additional information 
regarding the event. If you want to view the 
event with a particular message then you can 
fill the message in this field whereby the 
events with the corresponding message is 
displayed. 

text Unavailable 
seconds - line 15
all
To Be Supplied
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Category A value that can help in useful categorization 
of the alarm. 
Note that the default is !SYSLOG-*, since 
the SYSLOG events are listed in the System 
Log Events leaf node.

category Port
(Port has been 
affected)

Domain Any domain-specific information, based on 
physical location, or functional 
categorization, or logical categorization of 
the source of the event. The domain name of 
the event can be specified, which is to be 
matched by this custom view. 

domain

Network Information on the network to which the 
source of the event belongs. The network of 
the particular event in which you are 
interested is specified here.

network

Node Any additional information about the source, 
or the source itself, of the event. The name of 
the node to be filtered can be given in this 
field. 

node

Failed Object Information about the specific entity within 
the source of the event, which is primarily 
responsible for the occurrence of this alarm. 
The name of the failure object to be filtered 
can be given in this field. 

entity ADSL_172.16.33.
19;adslAtucUASL
_Port0.15
(Separated with 
semicolons, these 
are objects affected 
by the alarm)

Source Information about the source of the alarm. 
The source, based on which alarms are to be 
filtered, can be given in this field. 

source

From Date/Time The events, after the time specified in this 
field, are displayed in the custom view. 

To Date/Time The events, before the time specified in this 
field, are displayed in the custom view. 

Event Age Criterion that is used to filter events based on 
the age of the event. Age of an event denotes 
the time lapsed since the last modification of 
the event in the NMS system. Event age 
property can be age in min, age in hrs, age in 
days, today, yesterday and any for all these 
together. 

customerID The Customer ID assigned when 
provisioning for triple-play

customerID 746*

(More...) notes Unavailable 
seconds - line 15
all

(More...) stringSeverity

(More...) groupName

TABLE 8-12  Custom View Criteria for Events

MO Form Property Description for Match Properties

Custom View 
Property Name 
(use this exact 
text) Example
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8.4.10.2 Custom View for Events Example

The user can create a view that shows which events are associated with a specific subscriber. In the Custom 
View form, the user would:

1. Select the Network Events in the Fault Managements view and right-click Custom View -> Add Custom 
View.

2. In the name field, type ID_626.
3. Click Next to access the Additional Criteria, and type in 626*, as follows.

4. Click on OK, and a view is formed that shows only events associated with customer IDs that include 626, as 
follows. (Click on each event for details.)

FIGURE 8-15  Customer ID Filter
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8.4.11  Alarms

8.4.11.1 Properties

The following table lists the properties for Alarms and the ones used for setting up criteria for custom alarm 
views.

TABLE 8-13  Properties for Alarm Criteria

MO Form 
Property Description for Criteria - Alarms

Property for 
Custom View (use 
this exact text) Example

Filter View Name A name for the particular custom view. If 
nothing is provided, the corresponding 
custom view is named as Fault Management 
Network Events0, Fault Management.Alarms 
Alarms1, etc. 

Severity The level of the alarm. The severity of the 
alarm to be filtered can be assigned using the 
combo box. Multiple severities can also be 
assigned by separating them using a comma. 

severity Critical Major Minor 
Warning Clear
(separated by comma 
when choose more than 
one)

Previous severity The match criteria based on the previous 
severity of the alarm.

previousSeverity Critical Major Minor 
Warning Clear
(separated by comma 
when choose more than 
one

Owner The name of the owner of the alarm. owner Paul

Category The category for the alarm. category Telesyn
(for MAP devices)

Group A group value on which alarms are grouped in 
the client.

Message Any additional information. To use, fill the 
message in and alarms with the corresponding 
message are displayed.

message Unavailable seconds-line 
15-minute threshold

Failure object Information about the specific entity, within 
the source of the alarm, which is primarily 
responsible for the alarm. When filled in, it 
provides a filter.

entity ADSL_172.16.33.19;adsl
AtucUASL_Port0.15
(Separated with 
semicolons, these are 
objects affected by the 
alarm)

Source Information about the source of the alarm. 
When filled in, it provides a filter.

source 172.16.33.19

From Date/Time 
(modified)

The date and time after which alarms that are 
modified are displayed.
Format is month, date, year, hour, 
minute, second and AM / PM

Form has GUI

To Date/Time 
(modified)

The date and time before which alarms that 
are modified are displayed.

Format is month, date, year, hour, 
minute, second and AM / PM

Form has GUI
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8.4.11.2 Example of Custom Alarm Filter (Alarms by Location)

In this example, custom alarm views are created in which each view contains alarms from a specific location.

1. In the Object tree, select the Alarms node icon and right click Custom Views -> Add Custom Views (select-
ing the Alarms node is not necessary, but helps set the location of the custom view, as shown below).

2. In the Specify Alarm Filter Criteria window, change the name of the view to NMS_B5.
3. Click on Additional Criteria, then input the Property Name and match criteria. The property name we are 

using is sysLocation, and the criteria we are using is the string Raleigh, which we configured when providing 
device information. Figure 8-16 shows the example.

FIGURE 8-16  Setting Criteria for Custom Alarm View (sysLocation)
4. Select the tic box, OK, and then Apply Filter. Now when the NMS_B5 custom view is shown, only those 

devices with the sysLocation of B5 are listed in the view, as shown in Figure 8-17.

From Date/Time 
(Created) 

The date and time after which alarms that are 
generated are displayed.
Format is month, date, year, hour, 
minute, second and AM / PM

Form has GUI

To Date/Time 
(created)

The date and time before which alarms that 
are generated are displayed.
Format is month, date, year, hour, 
minute, second and AM / PM

Form has GUI

Alarm Age 
(modified time)

The age of the alarm for filtering purposes. 
The age of an alarm is the time lapsed since 
the last modification of the alarm in the NMS 
system. The alarm age property can be age in 
min, age in hrs, age in days, today, yesterday 
and so on.

Form has GUI

id The id number given to the alarm id 41931

(More...) notes Unavailable seconds-line 
15-minute threshold

(More...) priority 0

(More...) sysLocation see 8.4.11.2.

TABLE 8-13  Properties for Alarm Criteria (Continued)

MO Form 
Property Description for Criteria - Alarms

Property for 
Custom View (use 
this exact text) Example
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FIGURE 8-17  Example of Showing Alarms for Specific Location



Custom Physical Maps with Links Adding Links to Existing Custom Physical Map

AlliedView NMS Installation Guide (Object Properties to Define Objects and Custom Views)8-36

8.5  Custom Physical Maps with Links
Links can be added to the custom Physical Maps. However, certain criteria must be used to create a custom map 
that will allow link symbols to be placed on it. These are described below.

8.5.1  Adding Links to Existing Custom Physical Map
To add links to an existing map (provided it’s criteria are suitable) refer to the following figure, which shows the 
system Physical Map and links between 9000-type devices.

FIGURE 8-18  Physical Map with Links
For links to be added to a custom map, the map’s criteria can only include the following parameters:

• “name”
• “classname”
• “type”

Use one or more of these parameters to specify a set of iMAP devices, then the Add Links To Map operation 
will automatically create link lines for the Links that are defined in the NMS and have end ports on iMAPs exist-
ing on the custom map.

For example, if you are using DNS names and they are assigned so that the initial/final characters of each 
device’s name identifies the custom map that you would like it to be on, then a “name” criteria could be used to 
collect those devices onto a single Custom Map. Specifically, if the devices RAL1, RAL2, …, RAL30 are to be 
put on a single Custom Map, then use the criteria “name=RAL*” for that map.



Adding Links to Existing Custom Physical Map Custom Physical Maps with Links

8-37AlliedView NMS Installation Guide (Object Properties to Define Objects and Custom Views)

If not using DNS, then the names will look like IP addresses, and a subnet map can be matched by a pattern like 
“name=172.16.33.*”.

You can also use “type” to separate-off by device type (e.g., 9700, 9400, 9*, …).

The classname should be CLISNMPNodeMO to pick up iMAP devices only; otherwise many Port objects can 
appear on the custom map.

To create a custom map that looks like the Physical Map and also has links, do the following:

1. Custom Views-> Add New Map
2. Set topology to “grid(isActualIconSize=true;gapX=20;gapY=20;cellWidth=100;cellHeight=100;scroll=ver-

tical),star,ring,flow”
3. Set mapSymbolRenderer="com.adventnet.nms.mapui.ATIMapSymbolRendererImpl_3"
4. Add criteria by selecting "more" at the bottom of the window.

•    Only use the following criteria names if Links are to be added later:

   - name        (e.g. name = 172.16.33.*)

   - classname   (e.g. classname = CLISNMPNodeMO)

   - type        (e.g. type = 9700)

Note: These can be updated to also include linksets, which is what the Add Links operation will do.

•  The map will be created looking like the Physical Map but the background is gray (instead of white) and 
no links will show. (To update the background, double-click the background and in the Map Properties 
tab add an ImageName.) 

5. While the custom map is active, select the View -> Add Links to Map and the map will now have link lines 
drawn.

6. Refer to the following figures.

Note: The system Physical Map and custom Physical Map have the same features and interact; 
When new links are created or old links deleted on the system Physical Map they will now be 
automatically updated on the Custom map, and vise versa.
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FIGURE 8-19  Setting Custom Physical Map Criteria
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FIGURE 8-20  Adding the Links to the Custom Physical Map
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