[index] CentreCOM x540Lシリーズ コマンドリファレンス 5.5.4
NoteVRF-Liteを使用するにはフィーチャーライセンスが必要です。
ライセンスのインストール方法については「運用・管理」/「システム」の「ライセンスキーのインストール」をご参照ください。
Note作成したVRFインスタンスでは一部のマネージメント機能(Telnetサーバー等)が動作しません。これらを使用したいときはグローバルVRFインスタンスで行ってください。なお、ping、traceroute、telnet、sshの各コマンドでは、vrfパラメーターにより任意のVRFインスタンスを指定できます。また、以下の機能はVRFインスタンス単位での動作に対応しています。
- DNSリレー
- DHCPリレー
- SSHサーバー
- TFTPクライアント
- SNMP(トラップ送信のみ)
- HTTPサーバー/クライアント
- syslog
- TACACS+クライアント
- RADIUSクライアント
- DHCP Snooping
- SNMP
- sFlowエージェント
- NTPサーバー/クライアント
- NETCONFサーバー
- RESTCONFサーバー
NoteIPv4マルチキャストに関連する下記の機能は、グローバルVRFインスタンスだけでなく、作成したVRFインスタンスでも使用可能です。
なお、下記の機能は、作成したVRFインスタンスでは使用できません。
- PIM-SM
- IGMP
- IGMPプロキシー
- IGMP Snooping
また、作成したVRFインスタンス上では、1つ目のマルチキャストパケットの転送は未サポートです(グローバルVRFインスタンスではサポート)。
- PIM-DM
- IPv4マルチキャストのスタティック経路
- VRFインスタンス間のIPv4マルチキャスト通信
PIM-SMについては「IPマルチキャスト」/「PIM」を、IGMP、IGMPプロキシーについては「IPマルチキャスト」/「IGMP」を、IGMP Snoopingについては「IPマルチキャスト」/「IGMP Snooping」をご覧ください。
NoteAMF関連VLANはグローバルVRFインスタンスで使用してください。マネージメントVLAN(初期設定vlan4092)、ドメインVLAN(同vlan4091)、および、AMF仮想リンクで使用するVLANは、グローバルVRFインスタンスに所属させる必要があります。
NoteグローバルVRFインスタンスは最初から存在しているため、作成する必要はありません。
awplus(config)# ip vrf VRF-BLUE 1 ↓ awplus(config-vrf)# exit ↓
awplus(config)# ip vrf VRF-PINK 2 ↓ awplus(config-vrf)# exit ↓
Note作成したVRFインスタンスに割り当てていないインターフェースはグローバルVRFインスタンスの所属になります。
awplus(config)# interface vlan10 ↓ awplus(config-if)# ip vrf forwarding VRF-BLUE ↓ awplus(config-if)# ip address 10.0.0.1/8 ↓ awplus(config-if)# exit ↓
awplus(config)# interface vlan11 ↓ awplus(config-if)# ip vrf forwarding VRF-BLUE ↓ awplus(config-if)# ip address 192.168.1.1/24 ↓ awplus(config-if)# exit ↓
awplus(config)# interface vlan20 ↓ awplus(config-if)# ip vrf forwarding VRF-PINK ↓ awplus(config-if)# ip address 10.0.0.1/16 ↓ awplus(config-if)# exit ↓
awplus(config)# interface vlan21 ↓ awplus(config-if)# ip vrf forwarding VRF-PINK ↓ awplus(config-if)# ip address 192.168.1.1/24 ↓ awplus(config-if)# exit ↓
awplus(config)# interface vlan31 ↓ awplus(config-if)# ip address 192.168.1.1/24 ↓ awplus(config-if)# exit ↓ awplus(config)# exit ↓
awplus(config)# ip route vrf VRF-BLUE 192.168.2.0/24 192.168.1.254 ↓
awplus(config)# router rip ↓ awplus(config-router)# address-family ipv4 vrf VRF-BLUE ↓ awplus(config-router-af)# network 192.168.1.0/24 ↓ awplus(config-router-af)# network 10.0.0.0/8 ↓ awplus(config-router-af)# exit-address-family ↓ awplus(config-router)# exit ↓
awplus(config)# router ospf 1 VRF-BLUE ↓ awplus(config-router)# network 192.168.1.0/24 area 0 ↓ awplus(config-router)# network 10.0.0.0/8 area 0 ↓ awplus(config-router)# exit ↓
awplus(config)# router bgp 65010 ↓ awplus(config-router)# address-family ipv4 vrf VRF-BLUE ↓ awplus(config-router-af)# redistribute connected ↓ awplus(config-router-af)# neighbor 192.168.1.2 remote-as 65010 ↓ awplus(config-router-af)# neighbor 192.168.1.2 activate ↓ awplus(config-router-af)# exit-address-family ↓ awplus(config-router)# exit ↓
awplus(config)# router ipv6 rip ↓ awplus(config-router)# address-family ipv6 vrf VRF-BLUE ↓ awplus(config-router-af)# exit-address-family ↓ awplus(config-router)# exit ↓ awplus(config)# interface vlan10 ↓ awplus(config-if)# ip vrf forwarding VRF-BLUE ↓ awplus(config-if)# ipv6 router rip ↓ awplus(config-if)# exit ↓
Note前記「VRFインスタンスの作成」の構成例では vlan10、vlan11 にIPv6アドレスを設定していないため、以下の例にはipv6 addressコマンドによるIPv6アドレスの設定手順を含めています。また、前記例と重複しますが、VRFインスタンスの割り当てを行う ip vrf forwardingコマンドも示しています。
awplus(config)# router ipv6 ospf vrf VRF-BLUE ↓ awplus(config-router)# router-id 10.0.0.1 ↓ awplus(config-router)# exit ↓ awplus(config)# interface vlan10 ↓ awplus(config-if)# ip vrf forwarding VRF-BLUE ↓ awplus(config-if)# ipv6 address 2001:db8:1:10::1/64 ↓ awplus(config-if)# ipv6 router ospf area 0 tag VRF-BLUE ↓ awplus(config-if)# exit ↓ awplus(config)# interface vlan11 ↓ awplus(config-if)# ip vrf forwarding VRF-BLUE ↓ awplus(config-if)# ipv6 address 2001:db8:1:11::1/64 ↓ awplus(config-if)# ipv6 router ospf area 0 tag VRF-BLUE ↓ awplus(config-if)# exit ↓
Note各VRFインスタンスではVRFインスタンス間でのルーティングとは別にスタティックルーティング、RIP、OSPF、BGP、OSPFv3を使用することができます。
NoteVRFインスタンス間通信を行っているときはVRFインスタンス間で経路情報を送受信するため、各VRFインスタンスの独立性はなくなります。そのため、VRFインスタンス間で重複するIPアドレス空間は使用できません。
NoteVRFインスタンス間通信時は、 VRFインスタンス間でECMP経路は単一経路としてインポート/エクスポートされます。
NoteVRFインスタンス間のマルチキャスト通信は未サポートです。
awplus(config)# ip vrf VRF-BLUE 1 ↓ awplus(config-vrf)# exit ↓
awplus(config)# ip vrf VRF-PINK 2 ↓ awplus(config-vrf)# exit ↓
awplus(config)# interface vlan10 ↓ awplus(config-if)# ip vrf forwarding VRF-BLUE ↓ awplus(config-if)# ip address 192.168.10.1/24 ↓ awplus(config-if)# exit ↓
awplus(config)# interface vlan20 ↓ awplus(config-if)# ip vrf forwarding VRF-PINK ↓ awplus(config-if)# ip address 192.168.20.1/24 ↓ awplus(config-if)# exit ↓
Note本コマンドはデフォルト有効なため、明示的に無効化していない場合は省略できます。
awplus(config)# ip route static inter-vrf ↓
NoteVRFインスタンス間通信用のスタティック経路を登録する場合の転送先(GATEWAY、IFNAME)指定方法の詳細については、「VRFインスタンスをまたぐスタティック経路」をご覧ください。
awplus(config)# ip route vrf VRF-BLUE 192.168.20.0/24 vlan20 ↓
awplus(config)# ip route vrf VRF-PINK 192.168.10.0/24 vlan10 ↓
awplus(config)# ip route vrf VRF-PINK 192.168.11.0/24 192.168.10.2 vlan10 ↓
awplus(config)# router ospf 1 VRF-BLUE ↓ awplus(config-router)# network 192.168.10.0/24 area 0 ↓ awplus(config-router)# redistribute static ↓ awplus(config-router)# exit ↓
awplus(config)# interface vlan10 ↓ awplus(config-if)# ip address 192.168.10.2/24 ↓ awplus(config-if)# exit ↓
awplus(config)# interface vlan11 ↓ awplus(config-if)# ip address 192.168.11.1/24 ↓ awplus(config-if)# exit ↓
awplus(config)# router ospf ↓ awplus(config-router)# network 192.168.10.0/24 area 0 ↓ awplus(config-router)# redistribute connected ↓ awplus(config-router)# exit ↓
awplus(config)# ip vrf VRF-BLUE 1 ↓ awplus(config-vrf)# rd 500:1 ↓ awplus(config-vrf)# exit ↓
awplus(config)# ip vrf VRF-PINK 2 ↓ awplus(config-vrf)# rd 500:2 ↓ awplus(config-vrf)# exit ↓
awplus(config)# ip vrf VRF-BLUE 1 ↓ awplus(config-vrf)# route-target export 500:1 ↓
awplus(config-vrf)# route-target import 500:2 ↓ awplus(config-vrf)# exit ↓
awplus(config)# ip vrf VRF-PINK 2 ↓ awplus(config-vrf)# route-target export 500:2 ↓ awplus(config-vrf)# route-target import 500:1 ↓ awplus(config-vrf)# exit ↓
awplus(config)# interface vlan10 ↓ awplus(config-if)# ip vrf forwarding VRF-BLUE ↓ awplus(config-if)# ip address 192.168.10.1/24 ↓ awplus(config-if)# exit ↓
awplus(config)# interface vlan20 ↓ awplus(config-if)# ip vrf forwarding VRF-PINK ↓ awplus(config-if)# ip address 192.168.20.1/24 ↓ awplus(config-if)# exit ↓
awplus(config)# router bgp 500 ↓
awplus(config-router)# address-family ipv4 vrf VRF-BLUE ↓ awplus(config-router-af)# redistribute connected ↓ awplus(config-router-af)# redistribute ospf ↓ awplus(config-router-af)# exit-address-family ↓
awplus(config-router)# address-family ipv4 vrf VRF-PINK ↓ awplus(config-router-af)# redistribute connected ↓ awplus(config-router-af)# exit-address-family ↓
awplus(config)# router ospf 1 VRF-BLUE ↓ awplus(config-router)# network 192.168.10.0/24 area 0 ↓ awplus(config-router)# redistribute bgp ↓ awplus(config-router)# exit ↓
awplus(config)# interface vlan10 ↓ awplus(config-if)# ip address 192.168.10.2/24 ↓ awplus(config-if)# exit ↓
awplus(config)# interface vlan11 ↓ awplus(config-if)# ip address 192.168.11.1/24 ↓ awplus(config-if)# exit ↓
awplus(config)# router ospf ↓ awplus(config-router)# network 192.168.10.0/24 area 0 ↓ awplus(config-router)# redistribute connected ↓ awplus(config-router)# exit ↓
Note特定宛先のパケットを破棄するためのnull指定についてはここでは割愛します。詳細はip route、ipv6 routeコマンドのページをご参照ください。
awplus(config)# ip route vrf VRF-BLUE 192.168.11.0/24 192.168.10.2 ↓
awplus(config)# ip route vrf VRF-BLUE 192.168.20.0/24 vlan20 ↓ awplus(config)# ip route vrf VRF-PINK 192.168.10.0/24 vlan10 ↓
awplus(config)# ip route vrf VRF-PINK 192.168.11.0/24 192.168.10.2 vlan10 ↓
(C) 2024 - 2025 アライドテレシスホールディングス株式会社
PN: 613-003277 Rev.F