firewall
rule 10 permit any from private to private
rule 20 permit any from private to dmz
rule 30 permit any from private to public
rule 40 permit any from dmz to dmz
rule 50 permit any from dmz to private
rule 60 permit any from dmz to public
rule 70 permit dns from public.wan.ppp0 to public
rule 80 permit http from public to dmz.eth2.http
protect
nat
rule 10 portfwd http from private to public.wan.ppp0 with dst dmz.eth2.http
rule 20 masq http from private to dmz with src public.wan.ppp0
rule 30 portfwd http from public with dst dmz.eth2.http
rule 40 masq any from private to public
rule 50 masq any from dmz to public
enable
!
zone dmz
network eth2
ip subnet 172.16.0.0/24
host http
ip address 172.16.0.80
!
zone private
network lan
ip subnet 192.168.1.0/24
!
zone public
network wan
ip subnet 0.0.0.0/0 interface ppp0
host ppp0
ip address 10.0.0.1
!
firewall
rule 10 permit any from private to private
rule 20 permit any from private to dmz
rule 30 permit any from private to public
rule 40 permit any from dmz to dmz
rule 50 permit any from dmz to private
rule 60 permit any from dmz to public
rule 70 permit dns from public.wan.ppp0 to public
rule 80 permit http from public to dmz.eth2.http
protect
!
nat
rule 10 portfwd http from private to public.wan.ppp0 with dst dmz.eth2.http
rule 20 masq http from private to dmz with src public.wan.ppp0
rule 30 portfwd http from public with dst dmz.eth2.http
rule 40 masq any from private to public
rule 50 masq any from dmz to public
enable
!
no spanning-tree rstp enable
!
interface eth1
encapsulation ppp 0
!
interface eth2
ip address 172.16.0.1/24
!
interface vlan1
ip address 192.168.1.1/24
!
interface ppp0
ppp ipcp dns request
keepalive
ppp username user@isp
ppp password isppasswd
ip address 10.0.0.1/32
ip tcp adjust-mss pmtu
!
ip route 0.0.0.0/0 ppp0
!
ip dns forwarding
!
end