[index] AT-AR3050S/AT-AR4050S コマンドリファレンス 5.4.5
Note - ISP2から学習した経路をISP1に再通知すると、ISP1からISP2に宛てたトラフィックが自ASを通過する可能性があります。複数のASに接続しているときは、不要なトラフィックが自ASに流れ込まないよう、通知する経路情報の選別が必要です。
no spanning-tree rstp enable |
interface eth2 ip address 192.168.30.1/24 |
interface eth1 ip address 192.168.100.1/24 |
interface vlan1 ip address 192.168.10.1/24 |
ip as-path access-list list1 permit ^$ ip as-path access-list list1 permit ^65030_ ip as-path access-list list2 permit ^$ |
route-map add_myasn permit 1 match as-path list2 set as-path prepend 65030 65030 65030 route-map add_myasn permit 2 |
router bgp 65030 |
redistribute connected redistribute static |
neighbor 192.168.30.2 remote-as 65030 neighbor 192.168.30.2 next-hop-self neighbor 192.168.30.2 allowas-in neighbor 192.168.30.2 route-map add_myasn out |
neighbor 192.168.100.2 remote-as 65010 neighbor 192.168.100.2 allowas-in neighbor 192.168.100.2 filter-list list1 out |
end |
no spanning-tree rstp enable |
interface eth2 ip address 192.168.30.2/24 |
interface eth1 encapsulation ppp 1 |
interface ppp1 keepalive ppp username test01@cug ppp password test01! ip address 10.1.1.1/32 |
interface vlan1 ip address 192.168.20.1/24 |
crypto isakmp key secret address 10.1.1.2 |
interface tunnel1 ip address 172.16.0.1/30 tunnel source 10.1.1.1 tunnel destination 10.1.1.2 tunnel mode ipsec ipv4 tunnel protection ipsec |
ip as-path access-list list1 permit ^$ ip as-path access-list list1 permit ^65030_ ip as-path access-list list2 permit ^$ |
ip prefix-list ppp seq 5 deny 10.1.1.1/32 ip prefix-list ppp seq 10 permit any |
route-map add_myasn permit 1 match as-path list2 set as-path prepend 65030 65030 65030 route-map add_myasn permit 2 |
router bgp 65030 |
redistribute connected |
neighbor 172.16.0.2 remote-as 65020 neighbor 172.16.0.2 allowas-in neighbor 172.16.0.2 prefix-list ppp out neighbor 172.16.0.2 filter-list list1 out |
neighbor 192.168.30.1 remote-as 65030 neighbor 192.168.30.1 next-hop-self neighbor 192.168.30.1 allowas-in neighbor 192.168.30.1 prefix-list ppp out neighbor 192.168.30.1 route-map add_myasn out |
ip route 10.1.1.2/32 ppp1 |
end |
awplus# copy running-config startup-config ↓ Building configuration... [OK] |
awplus# write memory ↓ Building configuration... [OK] |
! no spanning-tree rstp enable ! interface eth2 ip address 192.168.30.1/24 ! interface eth1 ip address 192.168.100.1/24 ! interface vlan1 ip address 192.168.10.1/24 ! ip as-path access-list list1 permit ^$ ip as-path access-list list1 permit ^65030_ ip as-path access-list list2 permit ^$ ! route-map add_myasn permit 1 match as-path list2 set as-path prepend 65030 65030 65030 route-map add_myasn permit 2 ! router bgp 65030 ! redistribute connected redistribute static ! neighbor 192.168.30.2 remote-as 65030 neighbor 192.168.30.2 next-hop-self neighbor 192.168.30.2 allowas-in neighbor 192.168.30.2 route-map add_myasn out ! neighbor 192.168.100.2 remote-as 65010 neighbor 192.168.100.2 allowas-in neighbor 192.168.100.2 filter-list list1 out ! end |
! no spanning-tree rstp enable ! interface eth2 ip address 192.168.30.2/24 ! interface eth1 encapsulation ppp 1 ! interface ppp1 keepalive ppp username test01@cug ppp password test01! ip address 10.1.1.1/32 ! interface vlan1 ip address 192.168.20.1/24 ! crypto isakmp key secret address 10.1.1.2 ! interface tunnel1 ip address 172.16.0.1/30 tunnel source 10.1.1.1 tunnel destination 10.1.1.2 tunnel mode ipsec ipv4 tunnel protection ipsec ! ip as-path access-list list1 permit ^$ ip as-path access-list list1 permit ^65030_ ip as-path access-list list2 permit ^$ ! ip prefix-list ppp seq 5 deny 10.1.1.1/32 ip prefix-list ppp seq 10 permit any ! route-map add_myasn permit 1 match as-path list2 set as-path prepend 65030 65030 65030 route-map add_myasn permit 2 ! router bgp 65030 ! redistribute connected ! neighbor 172.16.0.2 remote-as 65020 neighbor 172.16.0.2 allowas-in neighbor 172.16.0.2 prefix-list ppp out neighbor 172.16.0.2 filter-list list1 out ! neighbor 192.168.30.1 remote-as 65030 neighbor 192.168.30.1 next-hop-self neighbor 192.168.30.1 allowas-in neighbor 192.168.30.1 prefix-list ppp out neighbor 192.168.30.1 route-map add_myasn out ! ip route 10.1.1.2/32 ppp1 ! end |
(C) 2015 アライドテレシスホールディングス株式会社
PN: 613-002107 Rev.D