[index] CentreCOM x900シリーズ・SwitchBlade x908 コマンドリファレンス 5.3.4
- 用語一覧 - 設定手順例 - 受信時CoS値によるQoS設定例 - ポリシーマップによるQoS設定例 - ポリシーマップとクラスマップ - クラスマップ - ポリシーマップ - QoS処理フロー詳細 - 受信時のQoS処理 - 送信キューの割り当て - ポリシーマップによるQoS処理 - トラフィック分類 - プレマーキング - メータリングとポリシング - シングルレートポリサー - ツインレートポリサー - リマーキング - ポリシーベースルーティング - 送信時のQoS処理 - キューへの格納 - テールドロップの動作パラメーター - WREDの動作パラメーター - キューからの送信 - 送信スケジューリング - シェーピング - ポリシーマップのフィルタリング機能 - 設定例 - 高負荷環境における制御パケットの優先設定
Note - 同一ポート上において、ハードウェアパケットフィルターとポリシーマップを併用することは可能です。該当ポートで受信したパケットの処理は、ハードウェアパケットフィルター、ポリシーマップの順に行われます。ただし、次項で述べる制限事項があるので注意してください。
Note - ハードウェアパケットフィルターにマッチしたパケットに対して、ポリシーマップによるQoSは適用されません(ここでの「マッチ」とは、破棄(deny)だけでなく明示的な転送許可(permitなど)も含みます)。ハードウェアパケットフィルターで破棄(deny)のアクションだけを使用する場合は両者を併用しても問題はありませんが、ハードウェアパケットフィルターで破棄以外のアクションを使用する場合は、ハードウェアパケットフィルターとポリシーマップを併用せずに、ポリシーマップのフィルタリング機能を使ってフィルタリングを行ってください。
Note - 以下に述べるのは本解説編の説明のための定義です。一般に使われている用語の意味とは必ずしも一致しない場合がありますのでご注意ください。
awplus(config)# mls qos enable ↓ |
awplus(config)# mls qos map cos-queue 0 to 2 ↓ awplus(config)# mls qos map cos-queue 1 to 2 ↓ awplus(config)# mls qos map cos-queue 2 to 3 ↓ awplus(config)# mls qos map cos-queue 3 to 3 ↓ awplus(config)# mls qos map cos-queue 4 to 4 ↓ awplus(config)# mls qos map cos-queue 5 to 5 ↓ awplus(config)# mls qos map cos-queue 6 to 6 ↓ awplus(config)# mls qos map cos-queue 7 to 7 ↓ |
Note - タグなしパケットにはデフォルト送信キュー(初期値は2)が割り当てられます。デフォルト送信キューは、mls qos queueコマンドで受信スイッチポートごとに設定できます。
Note - VCS(バーチャルシャーシスタック)構成時は、VCSの制御パケットが送信キュー7を使うため、その他のパケットを送信キュー7に割り当てないでください。初期設定ではCoS値「7」が送信キュー「7」にマップされているので、VCS構成時は送信キュー「7」を使わないよう、mls qos map cos-queueコマンドでマッピングを変更してください。
Note - BPDU(スパニングツリープロトコル)、LACP、EPSR使用時は、これらのプロトコルが送信キュー6を使うため、その他のパケットを送信キュー6、 7に割り当てないでください。初期設定ではCoS値「6」、「7」が送信キュー「6」、「7」にそれぞれマップされているので、BPDU、 LACP、EPSR使用時は送信キュー「6」、「7」を使わないよう、mls qos map cos-queueコマンドでマッピングを変更してください。
awplus(config)# interface port1.0.1-1.0.24 ↓ awplus(config-if)# wrr-queue group 1 weight 60 queues 7 6 ↓ awplus(config-if)# wrr-queue group 1 weight 30 queues 5 4 ↓ awplus(config-if)# wrr-queue group 1 weight 12 queues 3 2 ↓ awplus(config-if)# wrr-queue group 1 weight 6 queues 1 0 ↓ |
awplus(config)# mls qos enable ↓ |
awplus(config)# access-list 3001 permit ip 192.168.1.1/32 any ↓ awplus(config)# access-list 3002 permit ip 192.168.1.2/32 any ↓ awplus(config)# access-list 3003 permit ip 192.168.1.3/32 any ↓ |
Note - ハードウェアアクセスリストの概要と作成方法については、「トラフィック制御」の「アクセスリスト」をご覧ください。
awplus(config)# class-map host1 ↓ awplus(config-cmap)# match access-group 3001 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map host2 ↓ awplus(config-cmap)# match access-group 3002 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map host3 ↓ awplus(config-cmap)# match access-group 3003 ↓ awplus(config-cmap)# exit ↓ |
awplus(config)# policy-map three-hosts ↓ awplus(config-pmap)# |
awplus(config-pmap)# class host1 ↓ awplus(config-pmap-c)# police twin-rate 50000 80000 10000 10000 action drop-red ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class host2 ↓ awplus(config-pmap-c)# police single-rate 30000 10000 10000 action drop-red ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class host3 ↓ awplus(config-pmap-c)# police single-rate 20000 10000 10000 action drop-red ↓ awplus(config-pmap-c)# exit ↓ |
awplus(config)# interface port1.0.1-1.0.3 ↓ awplus(config-if)# service-policy input three-hosts ↓ awplus(config-if)# exit ↓ |
awplus(config)# mls qos queue-set 2 threshold 128000 256000 64000 128000 32000 64000 ↓ awplus(config)# mls qos queue-set 2 averaging-factor 9 ↓ awplus(config)# mls qos queue-set 2 drop-probability 1 1 1 ↓ awplus(config)# interface port1.1.1 ↓ awplus(config-if)# mls qos queue-set 2 random-detect ↓ |
awplus(config)# access-list 3021 permit tcp 192.168.20.0/24 192.168.10.0/24 ↓ |
Note - ハードウェアアクセスリストの概要と作成方法については、「トラフィック制御」の「アクセスリスト」をご覧ください。
awplus(config)# class-map tcp20to10 ↓ |
awplus(config-cmap)# match access-group 3021 ↓ |
awplus(config-cmap)# exit ↓ |
awplus(config)# class-map tcp20to10 ↓ awplus(config-pmap)# |
Note - ポリシーマップに関連付けられているクラスマップの内容を変更することはできません。クラスマップの変更は、ポリシーマップとの関連付けを解除してから行ってください。
awplus(config)# no class-map tcp20to10 ↓ |
Note - ポリシーマップに関連付けられているクラスマップを削除することはできません。クラスマップの削除は、ポリシーマップとの関連付けを解除してから行ってください。
awplus# show access-list ↓ Hardware IP access list 3021 permit tcp 192.168.20.0/24 192.168.10.0/24 |
awplus> show class-map ↓ CLASS-MAP-NAME: tcp20to10 QOS-ACCESS-LIST-NAME: 3021 |
awplus(config)# policy-map test ↓ |
awplus(config-pmap)# class downWeb ↓ |
awplus(config-pmap-c)# police single-rate 50000 10240 10240 action drop-red ↓ awplus(config-pmap-c)# exit ↓ |
awplus(config-pmap)# class default ↓ awplus(config-pmap-c)# police single-rate 10000 10240 10240 action drop-red ↓ awplus(config-pmap-c)# exit ↓ |
Note - デフォルトクラスマップのアクションは、ポリシーマップモードのdefault-actionコマンドで変更できます。
awplus(config-pmap)# exit ↓ |
awplus(config)# interface port1.0.1 ↓ awplus(config-if)# service-policy input test ↓ |
awplus(config)# interface sa1 ↓ awplus(config-if)# service-policy input mypolicy ↓ |
awplus(config)# interface port1.0.12 ↓ awplus(config-if)# service-policy input mypolicy ↓ % Service policy cannot be applied to an interface that is a member of a static-channel-group. Try applying the policy to "sa" interface. |
awplus(config)# interface port1.0.1-1.0.10 ↓ awplus(config-if)# service-policy input mypolicy ↓ |
awplus(config)# interface po1 ↓ awplus(config-if)# service-policy input mypolicy ↓ % Service policy cannot be attached to a dynamic aggregator interface. |
awplus(config)# interface port1.0.1 ↓ awplus(config-if)# no service-policy input test ↓ |
awplus(config)# policy-map test ↓ awplus(config-pmap)# |
Note - スイッチポートに適用されているポリシーマップの内容を変更することはできません。ポリシーマップの変更は、スイッチポートへの適用を解除してから行ってください。
awplus(config)# no policy-map test ↓ |
Note - スイッチポートに適用されているポリシーマップを削除することはできません。ポリシーマップの削除は、スイッチポートへの適用を解除してから行ってください。
awplus> show policy-map ↓ POLICY-MAP-NAME: test State: attached Default class-map action: permit CLASS-MAP-NAME: default Policer single-rate action drop-red: average rate(10000 kbps) minimum burst(10240 B) maximum burst(10240 B) CLASS-MAP-NAME: tcp20to10 QOS-ACCESS-LIST-NAME: 3021 Policer single-rate action drop-red: average rate(20000 kbps) minimum burst(10240 B) maximum burst(10240 B) |
awplus> show mls qos interface port1.0.1 ↓ Interface: port1.0.1 INPUT-POLICY-MAP-NAME: test CLASS-MAP-NAME: default Policer single-rate action drop-red: average rate(10000 kbps) minimum burst(10240 B) maximum burst(10240 B) CLASS-MAP-NAME: tcp20to10 QOS-ACCESS-LIST-NAME: 3021 Policer single-rate action drop-red: average rate(20000 kbps) minimum burst(10240 B) maximum burst(10240 B) ... |
1 | スイッチポートでパケットを受信 |
2 | 受信パケットがタグ付きの場合は、パケットのCoS値(0〜7)をキーとしてcos-queueマップを参照し、パケットに割り当てる送信キュー(0〜7)を決定する。受信パケットがタグなしの場合は、受信ポートごとに設定されたデフォルト送信キュー(初期値は2)を割り当てる |
3 | 受信パケットがレイヤー2スイッチングの対象なら、フォワーディングデータベースを参照して出力ポートを決定する |
4 | クラスマップにより、パケットをトラフィッククラスに分類する。どのクラスマップにもマッチしなかったパケットは、デフォルトトラフィッククラスに分類する。なお、パケットとクラスマップの照合は、クラスマップをポリシーマップに関連付けした順序で行われる |
5 | プレマーキングの設定がなされている場合、受信パケットの4属性を書き換える。各属性値を任意設定する方法と、DSCP値をキーにpremark-dscpマップを参照して書き換える方法がある |
6 | トラフィッククラスでポリサーの設定がなされている場合、該当トラフィッククラスがどの程度帯域を使用しているかを計測し、受信パケットを帯域クラスに分類する |
7 | トラフィッククラスでポリサーの設定がなされている場合、ポリサーのアクションがリマーキングなら、DSCP値と帯域クラスをキーにpoliced-dscpマップを参照して受信パケットの4属性を書き換える。ポリサーのアクションがポリシングの場合は、帯域クラスRedに分類されたパケット(帯域超過パケット)を破棄する |
8 | 受信パケットがIPルーティングの対象なら、IP転送表を参照してネクストホップを決定し、出力ポートを決定する。ただし、クラスマップ内でポリシーベースルーティングが指定されている場合はIP転送表を参照せずに、クラスマップで指定されたネクストホップを採用し、出力ポートを決定する |
9 | ここまでの処理で決定した送信キューにパケットを格納する。キューが混雑している場合の処理は、キュー管理方式によって異なる。テールドロップ方式の場合は最大キュー長を超えたパケットを単純に破棄し、WRED方式の場合は最大キュー長に達する前にランダムにパケットを破棄してキューの混雑解消を試みる |
10 | 設定されたスケジューリング方式にしたがい、送信キューからパケットを出力する。PQ(絶対優先)、WRR(重み付きラウンドロビン)のいずれか、あるいは、両者の併用も可能。なお、送信キューや送信ポートに送信レートの上限値が設定されている場合は、指定されたレートでパケットを送信するシェーピング動作を行う |
11 | スイッチポートからパケットを送信 |
awplus(config)# mls qos map cos-queue 0 to 2 ↓ awplus(config)# mls qos map cos-queue 1 to 2 ↓ awplus(config)# mls qos map cos-queue 2 to 3 ↓ awplus(config)# mls qos map cos-queue 3 to 3 ↓ awplus(config)# mls qos map cos-queue 4 to 4 ↓ awplus(config)# mls qos map cos-queue 5 to 5 ↓ awplus(config)# mls qos map cos-queue 6 to 6 ↓ awplus(config)# mls qos map cos-queue 7 to 7 ↓ |
Note - VCS(バーチャルシャーシスタック)構成時は、VCSの制御パケットが送信キュー7を使うため、その他のパケットを送信キュー7に割り当てないでください。初期設定ではCoS値「7」が送信キュー「7」にマップされているので、VCS構成時は送信キュー「7」を使わないよう、mls qos map cos-queueコマンドでマッピングを変更してください。
Note - BPDU(スパニングツリープロトコル)、LACP、EPSR使用時は、これらのプロトコルが送信キュー6を使うため、その他のパケットを送信キュー6、 7に割り当てないでください。初期設定ではCoS値「6」、「7」が送信キュー「6」、「7」にそれぞれマップされているので、BPDU、 LACP、EPSR使用時は送信キュー「6」、「7」を使わないよう、mls qos map cos-queueコマンドでマッピングを変更してください。
awplus(config)# no mls qos map cos-queue ↓ |
awplus> show mls qos maps cos-queue ↓ COS-TO-QUEUE-MAP: COS : 0 1 2 3 4 5 6 7 -------------------------------------- QUEUE: 2 2 3 3 4 5 6 7 |
awplus(config)# interface port1.0.1 ↓ awplus(config-if)# mls qos queue 4 ↓ |
Note - VCS(バーチャルシャーシスタック)構成時は、VCSの制御パケットが送信キュー7を使うため、その他のパケットを送信キュー7に割り当てないでください(VCS構成時は、mls qos queueコマンドで7を指定しないでください)。
Note - BPDU(スパニングツリープロトコル)、LACP、EPSR使用時は、これらのプロトコルが送信キュー6を使うため、その他のパケットを送信キュー6、 7に割り当てないでください(BPDU、LACP、EPSR使用時は、mls qos queueコマンドで6、7を指定しないでください)。
awplus> show mls qos interface port1.0.1 ↓ Interface: port1.0.1 Default Queue: 4 Number of egress queues: 8 Queue Set: 1 Drop Mode: Taildrop ... |
awplus(config)# policy-map example ↓ awplus(config-pmap)# class royal ↓ awplus(config-pmap-c)# set cos 7 ↓ awplus(config-pmap-c)# set dscp 31 ↓ awplus(config-pmap-c)# set queue 7 ↓ |
Note - VCS(バーチャルシャーシスタック)構成時は、VCSの制御パケットが送信キュー7を使うため、その他のパケットを送信キュー7に割り当てないでください(VCS構成時は、set queueコマンドで7を指定しないでください)。
Note - BPDU(スパニングツリープロトコル)、LACP、EPSR使用時は、これらのプロトコルが送信キュー6を使うため、その他のパケットを送信キュー6、 7に割り当てないでください(BPDU、LACP、EPSR使用時は、set queueコマンドで6、7を指定しないでください)。
awplus(config)# mls qos map premark-dscp 1 to new-cos 7 new-queue 7 ↓ awplus(config)# mls qos map premark-dscp 2 to new-cos 4 new-queue 4 ↓ |
Note - VCS(バーチャルシャーシスタック)構成時は、VCSの制御パケットが送信キュー7を使うため、その他のパケットを送信キュー7に割り当てないでください(VCS構成時は、mls qos map premark-dscpコマンドのnew-queueパラメーターで7を指定しないでください)。
Note - BPDU(スパニングツリープロトコル)、LACP、EPSR使用時は、これらのプロトコルが送信キュー6を使うため、その他のパケットを送信キュー6、 7に割り当てないでください(BPDU、LACP、EPSR使用時は、mls qos map premark-dscpコマンドのnew-queueパラメーターで6、7を指定しないでください)。
awplus(config)# policy-map example ↓ awplus(config-pmap)# class public1 ↓ awplus(config-pmap-c)# trust dscp ↓ |
awplus(config)# policy-map example ↓ awplus(config-pmap)# class public2 ↓ awplus(config-pmap-c)# set dscp 5 ↓ awplus(config-pmap-c)# trust dscp ↓ |
awplus> show policy-map ↓ POLICY-MAP-NAME: example State: detached Default class-map action: permit CLASS-MAP-NAME: default CLASS-MAP-NAME: royal Set CoS: 7 Set DSCP: 31 Set Queue: 7 CLASS-MAP-NAME: public1 Trust state: DSCP CLASS-MAP-NAME: public2 Set DSCP: 5 Trust state: DSCP |
awplus> show mls qos maps premark-dscp 1 ↓ PREMARK-DSCP-MAP: DSCP 1 Bandwidth Class Green Yellow Red ------------------------------------------------- New DSCP 1 - - New CoS 7 - - New Queue 7 - - New Bandwidth Class green - - |
Green | 少ない | 帯域割り当ての優先度は最高 |
Yellow | 中程度 | 帯域割り当ての優先度は中。キューが混雑したときは(Redの次に)優先的に破棄 |
Red | 使いすぎ | 帯域割り当ての優先度は最低。キューへの格納前に破棄、あるいは、キューが混雑したとき優先的に破棄 |
Note - 複数のスイッチチップ(インスタンス)にまたがるトランクグループ(スタティックチャンネルグループ、LACPチャンネルグループとも)ではメータリングが機能しません。複数インスタンスにまたがるトランクグループに対しては、メータリング(ポリサー)設定(police aggregateコマンド、police single-rateコマンド、police twin-rateコマンド)を含むポリシーマップを適用しないでください(適用してもメータリングが動作しません)。
awplus(config)# policy-map example ↓ awplus(config-pmap)# class traffic1 ↓ awplus(config-pmap-c)# police single-rate 20000 10240 10240 action drop-red ↓ |
awplus(config)# policy-map example ↓ awplus(config-pmap)# class traffic2 ↓ awplus(config-pmap-c)# police twin-rate 30000 80000 10240 10240 action drop-red ↓ |
awplus(config)# mls qos aggregate-police ap1 single-rate 40000 10240 10240 action policed-dscp-transmit ↓ |
awplus(config)# policy-map example ↓ awplus(config-pmap)# class traffic3 ↓ awplus(config-pmap-c)# police aggregate ap1 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class traffic4 ↓ awplus(config-pmap-c)# police aggregate ap1 ↓ awplus(config-pmap-c)# exit ↓ |
awplus(config)# mls qos aggregate-police ap2 twin-rate 20000 60000 10240 10240 action drop-red ↓ |
awplus(config)# policy-map example ↓ awplus(config-pmap)# class traffic5 ↓ awplus(config-pmap-c)# police aggregate ap2 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class traffic6 ↓ awplus(config-pmap-c)# police aggregate ap2 ↓ awplus(config-pmap-c)# exit ↓ |
awplus> show policy-map ↓ POLICY-MAP-NAME: example State: detached Default class-map action: permit CLASS-MAP-NAME: default CLASS-MAP-NAME: traffic1 Policer single-rate action drop-red: average rate(20000 kbps) minimum burst(10240 B) maximum burst(10240 B) CLASS-MAP-NAME: traffic2 Policer twin-rate action drop-red: minimum rate(30000 kbps) maximum rate(80000 kbps) minimum burst(10240 B) maximum burst(10240 B) CLASS-MAP-NAME: traffic3 Police Aggregate ap1 CLASS-MAP-NAME: traffic4 Police Aggregate ap1 CLASS-MAP-NAME: traffic5 Police Aggregate ap2 CLASS-MAP-NAME: traffic6 Police Aggregate ap2 |
awplus> show mls qos aggregate-policer ↓ AGGREGATE-POLICER-NAME: ap1 Policer single-rate action policed-dscp-transmit: average rate(40000 kbps) minimum burst(10240 B) maximum burst(10240 B) AGGREGATE-POLICER-NAME: ap2 Policer twin-rate action drop-red: minimum rate(20000 kbps) maximum rate(60000 kbps) minimum burst(10240 B) maximum burst(10240 B) |
Green | 少ない | バースト量 <= MINBURST |
Yellow | 中程度 | MINBURST < バースト量 <= MAXBURST |
Red | 使いすぎ | バースト量 > MAXBURSTSIZE |
Green | 少ない | バースト量(MIN) <= MINBURST |
Yellow | 中程度 | バースト量(MIN) > MINBURST かつ バースト量(MAX) <= MAXBURST |
Red | 使いすぎ | バースト量(MAX) > MAXBURST |
awplus(config)# policy-map example ↓ awplus(config-pmap)# class traffic7 ↓ awplus(config-pmap-c)# police single-rate 70000 10240 10240 action policed-dscp-transmit ↓ |
awplus(config)# mls qos map policed-dscp 0 bandwidth-class green to new-queue 7 new-cos 7 ↓ awplus(config)# mls qos map policed-dscp 0 bandwidth-class yellow to new-queue 4 new-cos 4 ↓ awplus(config)# mls qos map policed-dscp 0 bandwidth-class red to new-queue 0 new-cos 0 ↓ |
Note - VCS(バーチャルシャーシスタック)構成時は、VCSの制御パケットが送信キュー7を使うため、その他のパケットを送信キュー7に割り当てないでください(VCS構成時は、mls qos map policed-dscpコマンドのnew-queueパラメーターで7を指定しないでください)。
Note - BPDU(スパニングツリープロトコル)、LACP、EPSR使用時は、これらのプロトコルが送信キュー6を使うため、その他のパケットを送信キュー6、 7に割り当てないでください(BPDU、LACP、EPSR使用時は、mls qos map policed-dscpコマンドのnew-queueパラメーターで6、7を指定しないでください)。
awplus> show policy-map ↓ POLICY-MAP-NAME: example State: detached Default class-map action: permit CLASS-MAP-NAME: default CLASS-MAP-NAME: traffic1 Policer single-rate action drop-red: average rate(20000 kbps) minimum burst(10240 B) maximum burst(10240 B) ... CLASS-MAP-NAME: traffic7 Policer single-rate action policed-dscp-transmit: average rate(70000 kbps) minimum burst(10240 B) maximum burst(10240 B) |
awplus> show mls qos maps policed-dscp 0 ↓ POLICED-DSCP-MAP: DSCP 0 Bandwidth Class Green Yellow Red ------------------------------------------------- New DSCP 0 0 0 New CoS 7 4 0 New Queue 7 4 0 New Bandwidth Class green yellow red |
awplus(config)# policy-map pbrexample ↓ awplus(config-pmap)# class client10 ↓ awplus(config-pmap-c)# set ip next-hop 192.168.10.32 ↓ |
awplus(config)# ip route 0.0.0.0/0 192.168.100.10 ↓ awplus(config)# ip route 0.0.0.0/0 192.168.200.10 ↓ |
awplus(config)# mls qos enable ↓ |
Note - ハードウェアアクセスリストの概要と作成方法については、「トラフィック制御」の「アクセスリスト」をご覧ください。
awplus(config)# access-list 3010 permit ip 192.168.10.0/24 192.168.20.0/24 ↓ awplus(config)# access-list 3011 permit ip 192.168.10.0/24 192.168.100.0/24 ↓ awplus(config)# access-list 3012 permit ip 192.168.10.0/24 192.168.200.0/24 ↓ awplus(config)# access-list 3013 permit ip 192.168.10.0/24 any ↓ |
awplus(config)# access-list 3020 permit ip 192.168.20.0/24 192.168.10.0/24 ↓ awplus(config)# access-list 3021 permit ip 192.168.20.0/24 192.168.100.0/24 ↓ awplus(config)# access-list 3022 permit ip 192.168.20.0/24 192.168.200.0/24 ↓ awplus(config)# access-list 3023 permit ip 192.168.20.0/24 any ↓ |
awplus(config)# class-map vlan10to20 ↓ awplus(config-cmap)# match access-group 3010 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map vlan10to100 ↓ awplus(config-cmap)# match access-group 3011 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map vlan10to200 ↓ awplus(config-cmap)# match access-group 3012 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map vlan10toWAN ↓ awplus(config-cmap)# match access-group 3013 ↓ awplus(config-cmap)# exit ↓ |
awplus(config)# class-map vlan20to10 ↓ awplus(config-cmap)# match access-group 3020 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map vlan20to100 ↓ awplus(config-cmap)# match access-group 3021 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map vlan20to200 ↓ awplus(config-cmap)# match access-group 3022 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map vlan20toWAN ↓ awplus(config-cmap)# match access-group 3023 ↓ awplus(config-cmap)# exit ↓ |
awplus(config)# policy-map pbrv10 ↓ awplus(config-pmap)# |
awplus(config-pmap)# class vlan10to20 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class vlan10to100 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class vlan10to200 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class vlan10toWAN ↓ awplus(config-pmap-c)# set ip next-hop 192.168.100.10 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# exit ↓ |
awplus(config)# policy-map pbrv20 ↓ awplus(config-pmap)# class vlan20to10 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class vlan20to100 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class vlan20to200 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class vlan20toWAN ↓ awplus(config-pmap-c)# set ip next-hop 192.168.200.10 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# exit ↓ |
awplus(config)# interface port1.0.1-1.0.4 ↓ awplus(config-if)# service-policy input pbrv10 ↓ |
awplus(config)# interface port1.0.5-1.0.8 ↓ awplus(config-if)# service-policy input pbrv20 ↓ |
awplus(config)# interface port1.0.1-1.0.4 ↓ awplus(config-if)# mls qos queue-set 1 random-detect ↓ |
awplus(config)# interface port1.0.1-1.0.4 ↓ awplus(config-if)# no mls qos queue-set ↓ |
awplus> show mls qos int port1.0.1 ↓ Interface: port1.0.1 Number of egress queues: 8 Queue Set: 1 Drop Mode: Random Detect ... |
awplus> show mls qos queue-set 1 ↓ Queue Set 1: Description: 1G Defaults BandwidthClass Min Max Drop Probability -------------------------------------------------------------------------- Queue 0 | Green 125 KB 250 KB 1 (50%) | Yellow 62 KB 125 KB 1 (50%) | Red 31 KB 62 KB 1 (50%) -------------------------------------------------------------------------- Queue 1 | Green 125 KB 250 KB 1 (50%) | Yellow 62 KB 125 KB 1 (50%) | Red 31 KB 62 KB 1 (50%) -------------------------------------------------------------------------- Queue 2 | Green 125 KB 250 KB 1 (50%) | Yellow 62 KB 125 KB 1 (50%) | Red 31 KB 62 KB 1 (50%) -------------------------------------------------------------------------- Queue 3 | Green 125 KB 250 KB 1 (50%) | Yellow 62 KB 125 KB 1 (50%) | Red 31 KB 62 KB 1 (50%) -------------------------------------------------------------------------- Queue 4 | Green 125 KB 250 KB 1 (50%) | Yellow 62 KB 125 KB 1 (50%) | Red 31 KB 62 KB 1 (50%) -------------------------------------------------------------------------- Queue 5 | Green 125 KB 250 KB 1 (50%) | Yellow 62 KB 125 KB 1 (50%) | Red 31 KB 62 KB 1 (50%) -------------------------------------------------------------------------- Queue 6 | Green 125 KB 250 KB 1 (50%) | Yellow 62 KB 125 KB 1 (50%) | Red 31 KB 62 KB 1 (50%) -------------------------------------------------------------------------- Queue 7 | Green 125 KB 250 KB 1 (50%) | Yellow 62 KB 125 KB 1 (50%) | Red 31 KB 62 KB 1 (50%) -------------------------------------------------------------------------- Queue Length Averaging Factor Queue 0: 9 Queue 1: 9 Queue 2: 9 Queue 3: 9 Queue 4: 9 Queue 5: 9 Queue 6: 9 Queue 7: 9 |
awplus(config)# mls qos queue-set 2 threshold 0 50000 0 30000 0 10000 ↓ |
Note - WRED方式は流量制御や輻輳回避の機能を持つTCPトラフィックに対してもっとも効果を発揮します。UDPのように輻輳制御機能を持たないプロトコルに対しては効果がありませんのでご注意ください。
awplus(config)# mls qos queue-set 1 threshold 128000 256000 64000 128000 32000 64000 ↓ awplus(config)# mls qos queue-set 1 drop-probability 1 1 1 ↓ |
awplus(config)# interface port1.0.13 ↓ awplus(config-if)# wrr-queue group 1 weight 60 queues 6 7 ↓ awplus(config-if)# wrr-queue group 1 weight 30 queues 4 5 ↓ awplus(config-if)# wrr-queue group 1 weight 12 queues 2 3 ↓ awplus(config-if)# wrr-queue group 1 weight 6 queues 0 1 ↓ |
awplus(config)# interface port1.0.14 ↓ awplus(config-if)# wrr-queue group 1 weight 60 queues 7 ↓ awplus(config-if)# wrr-queue group 1 weight 30 queues 6 ↓ awplus(config-if)# wrr-queue group 1 weight 12 queues 5 ↓ awplus(config-if)# wrr-queue group 1 weight 6 queues 4 ↓ awplus(config-if)# wrr-queue group 2 weight 60 queues 3 ↓ awplus(config-if)# wrr-queue group 2 weight 30 queues 2 ↓ awplus(config-if)# wrr-queue group 2 weight 12 queues 1 ↓ awplus(config-if)# wrr-queue group 2 weight 6 queues 0 ↓ |
awplus(config)# interface port1.0.15 ↓ awplus(config-if)# priority-queue 7 ↓ awplus(config-if)# wrr-queue group 1 weight 60 queues 6 ↓ awplus(config-if)# wrr-queue group 1 weight 30 queues 4 5 ↓ awplus(config-if)# wrr-queue group 1 weight 12 queues 2 3 ↓ awplus(config-if)# wrr-queue group 1 weight 6 queues 0 1 ↓ |
awplus> show mls qos interface port1.0.15 ↓ Interface: port1.0.15 Number of egress queues: 8 Queue Set: 1 Drop Mode: Taildrop Egress Queue: 0 Status: Enabled Scheduler: Wrr Group 1 Weight: 6 Queue Limit: 12% Egress Rate Limit: 0 Kb Egress Queue: 1 Status: Enabled Scheduler: Wrr Group 1 Weight: 6 Queue Limit: 12% Egress Rate Limit: 0 Kb Egress Queue: 2 Status: Enabled Scheduler: Wrr Group 1 Weight: 12 Queue Limit: 12% Egress Rate Limit: 0 Kb Egress Queue: 3 Status: Enabled Scheduler: Wrr Group 1 Weight: 12 Queue Limit: 12% Egress Rate Limit: 0 Kb Egress Queue: 4 Status: Enabled Scheduler: Wrr Group 1 Weight: 30 Queue Limit: 12% Egress Rate Limit: 0 Kb Egress Queue: 5 Status: Enabled Scheduler: Wrr Group 1 Weight: 30 Queue Limit: 12% Egress Rate Limit: 0 Kb Egress Queue: 6 Status: Enabled Scheduler: Wrr Group 1 Weight: 60 Queue Limit: 12% Egress Rate Limit: 0 Kb Egress Queue: 7 Status: Enabled Scheduler: Strict Priority Queue Limit: 12% Egress Rate Limit: 0 Kb |
awplus(config)# interface port1.0.13 ↓ awplus(config-if)# wrr-queue egress-rate-limit 5m queues 0 1 2 ↓ % Egress rate limit of port1.0.13 has been set to 5208 Kb |
awplus(config-if)# egress-rate-limit 50m ↓ % Egress rate limit has been set to 50127 Kb |
awplus> show mls qos interface port1.0.15 ↓ Interface: port1.0.15 Number of egress queues: 8 Queue Set: 1 Drop Mode: Taildrop Egress Queue: 0 Status: Enabled Scheduler: Wrr Group 1 Weight: 6 Queue Limit: 12% Egress Rate Limit: 5208 Kb Egress Queue: 1 Status: Enabled Scheduler: Wrr Group 1 Weight: 6 Queue Limit: 12% Egress Rate Limit: 5208 Kb Egress Queue: 2 Status: Enabled Scheduler: Wrr Group 1 Weight: 12 Queue Limit: 12% Egress Rate Limit: 5208 Kb Egress Queue: 3 Status: Enabled Scheduler: Wrr Group 1 Weight: 12 Queue Limit: 12% Egress Rate Limit: 0 Kb ... |
awplus> show interface port1.0.16 ↓ Interface port1.0.16 Scope: both Link is UP, administrative state is UP Thrash-limiting Status Not Detected, Action learn-disable, Timeout 1(s) Hardware is Ethernet, address is 0000.cd24.0367 (bia 0000.cd24.0367) index 5016 metric 1 mtu 1500 <UP,BROADCAST,MULTICAST> VRF Binding: Not bound Egress Rate Limit 50127 Kb input packets 0, bytes 0, dropped 0, multicast packets 0 output packets 0, bytes 0, multicast packets 0 broadcast packets 0 |
awplus(config)# mls qos enable ↓ |
awplus(config)# access-list 3011 permit tcp 192.168.10.0/24 192.168.20.0/24 ↓ awplus(config)# access-list 3012 deny tcp 192.168.10.0/24 192.168.20.0/24 ↓ |
Note - ハードウェアアクセスリストの概要と作成方法については、「トラフィック制御」の「アクセスリスト」をご覧ください。
awplus(config)# class-map permitSA10 ↓ awplus(config-cmap)# match access-group 3011 ↓ awplus(config-cmap)# match tcp-flags syn ack ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map denyS10 ↓ awplus(config-cmap)# match access-group 3012 ↓ awplus(config-cmap)# match tcp-flags syn ↓ awplus(config-cmap)# exit ↓ |
awplus(config)# policy-map acl10 ↓ awplus(config-pmap)# |
awplus(config-pmap)# class permitSA10 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class denyS10 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# exit ↓ |
awplus(config)# interface port1.0.1-1.0.2 ↓ awplus(config-if)# service-policy input acl10 ↓ |
Note - BPDU(スパニングツリープロトコル)、IGMP、LACP、EPSR、VCS(バーチャルシャーシスタック)の制御パケットについては、自動的に優先制御が行われるため特別な設定は不要です。
Note - すでにQoSの設定を行っている場合は、既存のポリシーマップに下記の設定(制御パケットを優先するための設定)を追加してください。
awplus(config)# mls qos enable ↓ |
awplus(config)# access-list 3001 permit udp any any eq 520 ↓ awplus(config)# access-list 3002 permit proto 89 any any ↓ awplus(config)# access-list 3003 permit proto 112 any any ↓ awplus(config)# access-list 3004 permit proto 103 any any ↓ |
Note - ハードウェアアクセスリストの概要と作成方法については、「トラフィック制御」の「アクセスリスト」をご覧ください。
awplus(config)# class-map RIP ↓ awplus(config-cmap)# match access-group 3001 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map OSPF ↓ awplus(config-cmap)# match access-group 3002 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map VRRP ↓ awplus(config-cmap)# match access-group 3003 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map PIM ↓ awplus(config-cmap)# match access-group 3004 ↓ awplus(config-cmap)# exit ↓ |
awplus(config)# class-map UntaggedARP ↓ awplus(config-cmap)# match eth-format ethii-untagged protocol 0806 ↓ awplus(config-cmap)# exit ↓ awplus(config)# class-map TaggedARP ↓ awplus(config-cmap)# match eth-format ethii-tagged protocol 0806 ↓ awplus(config-cmap)# exit ↓ |
awplus(config)# policy-map CtrlPkts ↓ awplus(config-pmap)# |
Note - BPDU(スパニングツリープロトコル)、LACP、EPSRの使用時は、これらのプロトコルの制御パケットが送信キュー6を使うため、ここで述べる各プロトコルの制御パケットは3番目に優先度の高い送信キュー5に割り当ててください。
awplus(config-pmap)# class RIP ↓ awplus(config-pmap-c)# set queue 6 ↓ awplus(config-pmap-c)# exit ↓ |
awplus(config-pmap)# class OSPF ↓ awplus(config-pmap-c)# set queue 6 ↓ awplus(config-pmap-c)# exit ↓ |
awplus(config-pmap)# class VRRP ↓ awplus(config-pmap-c)# set queue 6 ↓ awplus(config-pmap-c)# exit ↓ |
awplus(config-pmap)# class PIM ↓ awplus(config-pmap-c)# set queue 6 ↓ awplus(config-pmap-c)# exit ↓ |
awplus(config-pmap)# class UntaggedARP ↓ awplus(config-pmap-c)# set queue 6 ↓ awplus(config-pmap-c)# exit ↓ awplus(config-pmap)# class TaggedARP ↓ awplus(config-pmap-c)# set queue 6 ↓ awplus(config-pmap-c)# exit ↓ |
awplus(config-pmap)# exit ↓ |
awplus(config)# interface port1.0.1-1.0.24 ↓ awplus(config-if)# service-policy input CtrlPkts ↓ |
Note - スタティックチャンネルグループ(手動設定のトランクグループ)を設定している場合は、インターフェース名「saX」(Xはスタティックチャンネルグループ番号)にポリシーマップを適用してください。
(C) 2007 - 2010 アライドテレシスホールディングス株式会社
PN: 613-000751 Rev.K